XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)

I have the exact same issue and I remember dealing with this back when I updated past 1.15. Windows recently decided it wanted to update my BIOS automatically for me (even though I previously had the options to not auto update devices and drivers) and I'm back to trying to figure out why this is happening. I rolled back to 1.15. It said it failed, but it is registering at 1.15.

I don't think I have a TPM on this machine. It has never shown up in the BIOS and it has never shown up in Windows. I don't know why these stupid BIOS updates think I have one. 

We've had nothing but trouble with Dells at work as well. I will never buy another Dell.

2 Bronze
2 Bronze

How is this not fixed yet?

2 Bronze
2 Bronze

I have the same problem. I have also tried almost every possible solution I have found on the web, to no avail. 

I am wondering if there is a pattern of laptop use that brings this error, or not. For example, I rarely switch off properly my laptop, and could have missed some crucial updates - could this be the issue that has brought this fault?

 

On the other hand I've read somewhere that there never was a TMP on the laptop, and that the updated BIOS may wrongly "look for" a TMP that is not there. In any case, will this issue disappear with the next update? Should we be worried about losing the laptop at all?

Same problem for me.  Come on Dell.  Your customers need a fix!!!!

I am reading all about the XPS15 problems - these all are what i have been experiencing for over a year.  I have bought so many dell computers over the years for myself, family and friends.  But sadly, it looks like the long streak will end next time I have spare $.  I am trying to downgrade my BIOS to see if that cures my CURRENT issue.  I am frustrated and upset that i spent this much money on a high-end laptop that frequently is non-responsive and unfixable.  Despite YEARS of customer complaints from so many users. We deserve better Dell.

USE: I use the laptop as a trading platform and minor browsing/other apps.  (no games) with 32GB ram and the nvidia GPU, i thought the spec was more than adequate.  Except for this minor computer engineering thing that Dell has overlooked.

PROBLEMS: After updating all the drivers and bios, i now get random total shutdowns while on battery - no BSOD - just straight to black.  Worse, it has to be plugged in to restart. no errors show up in the logs either.

Another long-running issue is Desktop Window Manager sucking up ALL the GPU0 power, basically bringing the PC to a near halt.  I recently got serious about tracking it down by watching different metrics on the Task Manager/Performance tab. an update sometime reduces the issue, then here comes another Windows or Dell fix to make things worse.

Any advice/suggestions are welcome.

2 Bronze
2 Bronze

bump. also happening to mine.

#MeToo

This is ridiculous. There's no point downgrading the BIOS to 1.15 as on a subsequent reboot, it starts flashing to 1.19.2 again, as a previous poster also experienced. 

I have a TPM module in this 9560 laptop - the order confirmation shows this. It is incredibly poor form to release a BIOS update that causes such an issue, not allow downgrading to a working version, then basically telling us to stick it where the <profane> by not providing any fix because the machine is out of warranty? And come on, who wants to pay upwards of ~£250 for extra premium support for a year just to have an issue fixed that was caused by Dell themselves? They cause an issue, they should <profane> well fix it.

2 Bronze
2 Bronze

Same issue here. 
This started for my 8/16/2020, but I do remember a bios update recently.

XPS 15 9560
Bios 1.19.2
Windows 10 Home, never had bitlocker (?), never heard of TPM

Tried TPM 2.0 updater anyway, get Query Fails message.  
Tried the shutting down with/without power connected etc.   

I have no idea how to remove the battery here and sending it somewhere for a new motherboard sounds absurd with all my data and projects on it. 

I'm glad the $2000 laptop still works but I am not under warranty.  I have a little heart palpitation every time it sleeps or boots and gives me that screen.  
Thanks for having me I pray for some software fix

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition 12.1.5.3
All my software is legit

I had a similar error today on my XPS 15 9560 - during bootup "Alert! TPM device is not detected." The TPM was not visible in the bios/ Windows device manager / tpm.msc

Found a 2016 solution - "restore Bios defaults" which worked for me and now no more error on boot and  also TMP visible in Bios,etc, the solution which worked for me:

  • Switch the PC off
  • Disconnect Power plug
  • Press CTRL + ESC and reinsert the power plug
  • Menu appears with 3 options(restore default, rollback,etc)
  • Select "Restore BIOS defaults"
  • Laptop will restart and the error disappeared for me.

I will check the next few days and hope this problem is not back.

 

 

I'm experiencing the same issue and have tried all the suggested fixes including the last post of restoring BIOS defaults and nothing fixes this issue.

Top Contributor
Latest Solutions