XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)

@HamsFazil Your answer worked for me, when no others did (no disrespect to the other posters).

To make it work for me, I selected "Roll Back" to force an attempt to roll back to the previous BIOS. Although the rollback didn't work, it DID stop the TPM messages (which nothing else had done) and allowed my Dell Latitude 5590 to boot and to show me the TPM options in the BIOS setup again. Many thanks for taking the time to give others the secret of Ctrl-Esc while plugging in main power!!!

2 Bronze
2 Bronze

I tried this
1) Go to Bios
2) Go to Settings/Security/UEFICapsuleFirmwareUpdates (This allows/blocks Bios updates from services such as WindowsUpdater
3) Deactivate this function
4) Boot PC & Login
5 (Maybe Optional)) Install all Windows Updates first ( Installed Bios 1.19.2 too)
6 (Maybe Optional)) Check that you dont have any Windows Updates left
7) Install Bios 1.15

Community Accepted Solution

Thanks this worked perfectly

Thanks @fishfishmac for your solution. Unfortunately it didn't fully work for me. It does remove the error message but does not reactivate the TPM module. Windows still can't find the TPM anymore and Bitlocker can't be reactivated.

Yeah, @GuiYomM sadly I can't help you with the reactivation of the TPM Device, since aparently doesn't have it built in. Lets hope, Dell brings out a solution fixing this mess soon.

You saved my day. It works for me. I got a warning message at the end that the PC was shut down due to high temperature but it got flashed. So Im all good!

Thanks @fishfishmac , worked a treat for me too. Been bugging me for ages

This has not worked for me, I started having the issue after i installed the latest BIOS 1.20

Does anyone know a solution? I tried it all.

 

Do we know if someday there will be a fix?  

Like maybe when there's a new bios they will bother to fix this?  or is this user error so they dont care?

Currently I am just used to getting a bios error every time it comes out of sleep, and Im too beat down by desperate forum searching to try to get help for an out of warranty problem.  This thread is the only source of hope  

Just seems like Dell did it so why wont they push out a fix..how can they not

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition 12.1.5.3
All my software is legit

This worket perfectly for my XPS 15 9560!

 

Thanks a lot  @fishfishmac

The BIOS 1.15 can be downloaded from DELL (just google it)

I will write again, if there is trouble again

Top Contributor
Latest Solutions