XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)

This work for my Dell XPS 9560, I have tried everything else but rolling the bios back from 1.21 to 1.15 worked it sad that Dell hasn't manage to fix this yet

Bios 1.15 writes the TPM issue to log, but it is still present. Subsequent BIOS updates issue a stopping alert for the issue.

This seems to have worked for me! 

2 Bronze
2 Bronze

I managed to fix this on my XPS 13 9360 by installing Bios 2.12.0 and resetting the bios settings to factory settings

No change after updating to 1.21. 
reset to default doesn’t help unfortunately. 

I had the same issue even after updating to 1.21. This is how I solved it. Download 1.15.0.exe file and copied it in a usb drive. Restarted laptop with usb drive connected and press f12 when the dell logo flashes up. There is an option to flash bios and I pointed the exe file in the drive. The flashing failed but after restarting I did not get any TPM alert. One more thing I did was deactivate automatic bios update in the settings so that dell updater wont <Profanity removed> me again!

2 Bronze
2 Bronze

I would not mark this thread as solved since downgrading to bios version 1.15 will result in an unsecure system. The latest bios updates have been patching some serious vulnerabilities. It is really frustrating that Dell is staying silent on this one. I will never recommend buying Dell again unfortunately. The XPS 9560 is a marketing stunt gone bad. They put together some very powerful components but unfortunately it has resulted in a never ending pool of issues. So many GSODs, power throttling (when using the dedicated graphics card making the computer garbage) and this BIOS issue have resulted in so many wasted hours of my life. @Anonymous 

I still have this problem on my XPS 15 9650 running the latest bios. It's really strange that Dell is staying silent on this one, why your programmers can't modify bios firmware by picking some changes from 1.15 to the latest version? It's really annoying for about two years without problem resolution.

Enric01_0-1610886079405.png

 

1.15 is not a solution. Why don't they fix this issue? Over 2.5 years of problems with this XPS 15 9560.
I think the best solution is to recycle it already.

Top Contributor
Latest Solutions