XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)

Also having this issue and have completed recommended steps. Commenting to follow this discussion to discover if Dell will actually step up or if they believe in continuing the practice of creating errors like this that force customers to buy new products from them.

Today when I got up my XPS  9650 was running full speed like crazy, rushing fan and extremely hot.  I had manually put it in sleep last night.

It seems to have woken and entered the TPM blue screen of misery that is now what I equate to Dell, and the hardware stays hot and the screen stays on.  

My other post on here has no replies. Its pretty hopeless feeling if Dell wont advise. 

Will they push out a new bios someday that's smart enough to know that my laptop never had TPM ?  Why wont they comment in this thread with all these people struggling?

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition 12.1.5.3
All my software is legit
2 Bronze

Same exact issues. Purchased 1 year warranty expired on August 31, 2018. Thanks to the original poster for the excellent detail.

2 Bronze

I have been having the same issue. I've taken all of the suggested steps and nothing has worked.

2 Bronze

Yep having the same problem with my XPS 15 9560. Do we know when dell might fix this?

2 Bronze

Since the beginning with BIOS version 1.16, they have not fixed this bug.
I think the main thing for Dell is to make money. They are not interested in working with clients.
Just don't recommend buying Dell to anyone. That's all.

2 Bronze

Same issue here!!  

how could this issue not solved for such a long tim.

I am 15 year Dell user.  Now considering not to use Dell anymore. ;-<

Has anyone actually brought this issue to Dell's attention?

Yes, I contacted Dell when I first got the issue when upgrading to 1.16. Their advice, after some back and forth without a solution, was to revert back to 1.15, which I did. Disappointing that we're on 1.19 and still no solution, if anything because the popup saying I have updates to install is getting quite annoying, and I can't install any other updates without also updating the bios..

2 Bronze

Yeah I tried downgrading to 1.15, but my XPS doesn't actually allow the downgrade to happen. So I'm just stuck with 1.19. I don't know what to do now, it's just really frustrating. Any suggestions on what to do?

Top Contributor
Latest Solutions