XPS

Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found

 

I read as much as I could, but I could not find a solution. 

@Dellalias

@TeHe 

@Richie1981 

@JD111 

If anyone could, Please help this poor student and Thanks!

 

 

Replies (64)

Same problem for me, with 1.21.1 BIOS on Dell XPS 9560...

A pity...

we have bought new laptops in the company, and of course we have not counted on dell. Whenever I have the opportunity I advise against buying a dell.

2 Bronze
2 Bronze

I'm writing to second this issue. It's been going on for years. Very frustrating, especially as it presents as a stopping error on BOOT. The firmware 1.15 simply wrote the error to a log file rather than stopping the process, but the error was there: "TPM is not detected". I've tried all those battery draining tricks recommended on other threads, at al and nothing. I am of the firm conclusion my model does not have the chip. The explanation that some territories do not ship with TPM chips correlates with the reduced price on the website when I purchased the model originally and why it took so long to deliver (to Australia).

 

In short: my laptop is not suitable for the upcoming Windows update due to; either not being produced up to specification, or being rendered incompatible by update error or hardware failure within 3 years of purchase.

 

My next business machine could not possibly be justified to be a Dell. Unless of course Dell could solve the issue of their premium line being incompatible with common security requirements within the territories they sold them?

7 Thorium

If this is an XPS 9560, it's not just the TPM that's the issue -- it's the CPU they use, which does not meet Microsoft's requirements.  It doesn't matter which name is on the outside - Dell, HP, Lenovo, ASUS, Acer, Apple, etc. -- the generation CPU used in these is not compliant with Windows 11 requirements.

 

Top Contributor
Latest Solutions