XPS

Last reply by 03-28-2020 Solved
Start a Discussion
2 Jasper
2 Jasper
169438

XPS 15-9570, Audio crackling and popping

I have an issue that renders the audio on this laptop unusable.

I have a new XPS 9570, and occasionally (I stress that word because 75% of the time there is no issue) when playing audio, either through the built in speakers or through the audio jack, there is a loud popping and crackling noise that accompanies the audio. This renders any audio generated by the laptop unusable.

Because the issue is not always present, it is very hard to debug since you can't know if the issue was actually fixed, or just temporarily gone.

Testing I have done thus far:

When playing a continuous tone, such as generated by<TOU> , the issue is still present.

The crackling and popping increases with system volume, so if I turn the volume up on the laptop, the crackling becomes louder.

I have reflashed the BIOS to the newest version, uninstalled realtek, reinstalled realtek, disabled wave-maxx-audio (or whatever it is called), and tried using the built in windows drivers. Nothing has worked.

And note that when playing from bluetooth, there is no issue. So it is not a software issue in that way.

Very disappointing that on such an amazing laptop (it truly is amazing), an integral part of it is basically useless.

Replies (422)
4543

Can anyone recommend another Windows portable laptop that works well with audio ? I don´t want to buy a gamer laptop (weight), and would not like to switch to mac... After several months waiting for Dell to fix this audio problems, with the latest BIOS update (1.10) maybe got a little better, but didn´t solved the audio problems for me. I´m thinking of selling my XPS 15 9570 and buy another brand. Thanks.
4529

Razer Blade 15? :)

4504

I'm having the highest DPC  Latency numbers ever with BIOS 1.10 it actually became much worse than before.

Something is very very very wrong.... :(

4453


@AndreaBussolan wrote:

@Dell-Alan D wrote:

@kostlerdc wrote:
The sound issue is not fixed even after installing the recommended 1.10.1 BIOS update. Of course all latest drivers are installed as well. After owning this expensive laptop for 2 weeks still I cannot hear any of my favorite music. The speakers hurt my ears ... Please advise what to do, how to fix it ...

@kostlerdc are you able to provide more detail to your response please to help get a better understanding of what is happening. 

a) Is the issue constant or is it infrequent?

b) Is the sound that you are hearing an audible pop or is it a crackle?

c) When do you hear the sound, i.e when you connect or disconnect the ac adaptor?

d) Is it when audio is played back?

e) Does it happen on the internal speakers or external headphones or both?

f) Does it happen on ac only, battery only or combination of both?

Alan


Also in my case the update doesn't fix the audio problem. For the informations you asked:

a) it is constant and it happens with Windows' sound, such as turning up or down the volume, as well as songs or video played with apps or internet broswers. It happens in the same moment of a song or a video.

b) it is always a crackling sound but sometimes you can hear pops.

c) and f) you can hear always and it doesn't depend on if the computer is running with the battery or with ac.

d) I didn't notice any differences if the audio plays in the back or not.

e) in my case it happens only with internal speakers.


@AndreaBussolan thanks for your feedback. I'll drop you and private message to get your service tag details from you.

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

4374

I

4275

The lates BIOS updated resolved nothing.

Still having heavy DPC problems and audio cracking all the time. Sadly it's a institutional laptop and I cannot resell it or change it for another brand.

 

yAxD9RT

 

 

4219

Hmm, that's odd, my latency appears to be even worse also.. Now it's borderline red with some spikes here and there. Although even before BIOS update, pops and clicks for simple replay were gone at some point and those didn't come back.

2 Bronze
2 Bronze
7444

I haven't read all replies in this forum so excuse me if my suggestion is a duplicate of an existing entry.

My resolution to this intermittent, spontaneous yet very annoying issue is to tune the MaxxBass setting using the MaxxAudioPro software. 

  1. Start an audio replay application like Spotify or VLC and have it generate audio with crackling/muffled sounds. 
  2. Start the MaxxAudioPro software from the Windows Start Menu.
  3. Click the "Playback" item.
  4. Reduce the MaxxBass value to a desirable amount of bass without distortion. In my case a value in between 10 and 20 is acceptable. 
  5. Optionally create a preset for the current set of values.
  6. Close the application(s). 

Currently installed version of the MaxxAudio Pro software is v1.1.131.0. 

IMHO Dell clearly is not in control releasing a set of drivers and accompanying software without audio issues. Combined with heat dissipating issues of the 9570 my initial enthusiasm is slowly eroding. Pay more attention to quality management Dell.

 

 

4851

Dear Alan,

Below you will find my answers:

a)Is the issue constant or is it infrequent? 

The issue is constant but after several updates as well as disables and re-enables of devices in 'device manager', it became less intense although it is still very annoying and needs to be fixed

b) Is the sound that you are hearing an audible pop or is it a crackle?

It sounds more like audible pop - like it doesn't handle the sound well-

c) When do you hear the sound, i.e when you connect or disconnect the ac adaptor?

It’s always the same

d) Is it when audio is played back?

Its when audio or video is played back

d) Does it happen on the internal speakers or external headphones or both?

I used to hear it from headphones as well. Now after the update I can hear it from the laptop speakers

e) Does it happen on ac only, battery only or combination of both?

It doesn’t matter if the laptop runs on battery or the ac adaptor is plugged in

Latest update:

I followed Erik_B ‘s advise and disabled completely the Maxx Audio Pro audio enhancements and it is the only that worked so far! No more annoying sounds. The music now is flat but without issues!

Thank you Erik_B!!!

7387

Thanks. Setting the basses to 20 solved the problem. It was always obvious this was a bass case, but I did not know how to solve it.

I agree with you that a high-end laptop should not have the sound, heating, fan, ... issues. With 9570 also "my initial enthusiasm is ... eroding".

Latest Solutions
Top Contributor