XPS

Last reply by 03-28-2020 Solved
Start a Discussion
2 Jasper
2 Jasper
162619

XPS 15-9570, Audio crackling and popping

I have an issue that renders the audio on this laptop unusable.

I have a new XPS 9570, and occasionally (I stress that word because 75% of the time there is no issue) when playing audio, either through the built in speakers or through the audio jack, there is a loud popping and crackling noise that accompanies the audio. This renders any audio generated by the laptop unusable.

Because the issue is not always present, it is very hard to debug since you can't know if the issue was actually fixed, or just temporarily gone.

Testing I have done thus far:

When playing a continuous tone, such as generated by<TOU> , the issue is still present.

The crackling and popping increases with system volume, so if I turn the volume up on the laptop, the crackling becomes louder.

I have reflashed the BIOS to the newest version, uninstalled realtek, reinstalled realtek, disabled wave-maxx-audio (or whatever it is called), and tried using the built in windows drivers. Nothing has worked.

And note that when playing from bluetooth, there is no issue. So it is not a software issue in that way.

Very disappointing that on such an amazing laptop (it truly is amazing), an integral part of it is basically useless.

Replies (422)
6696

Turns out to fix my problem all I needed to do was go into my MaxxAudioPro which I never new was being used and turned down the bass down to 12.  I haven't seen the problem since.  I think MaxxAudioPro turns up the bass so much that it distorts the sound.

6658

@tblockey thanks for advising of that. It's an interesting solution that I will add to my list of troubleshooting steps to ask when other customers are reporting this.

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

6529

Just received a 3300 euros Precision 5530. 3300 euros... Take the time to process that! This laptop is at the end of its life cycle, being replaced by the new 5540. The new, uber expensive laptop I just bought is riddled with several issues, that are inadmissible. It is shocking really. First of, I have a Xenon and P2000 QUadro. The computer is an oven, fans always on, CPU and GPU constantly being throttled down. Obviously, even after one year of Dell trying to fix the latency problem... here it is. My new Precision 5530, that costed me 3300 euros, has high latency problems, crackling and popping. I am at a loss of words... I am shocked!
6602

finaly problem solved Who ever found this, thumbs up. Disable Maxx audio worked for me

6346

Hi Alan, 

I've been following this thread for a long time, I bought this laptop back around Christmas. My audio then would be fine for a while then suddenly start buzzing and crackling but it would go away, now I have a persistent low base sound roar and distortion and it's gotten to the point that I cannot hear what's being said. 

I assume I have the same issue that this page relates to. Sorry to be lazy but I don't want to read through 42 pages of responses, can you help me. 

6342

@damaartenman  I had given up on reading any of this thread but after posting my own comment I read yours and it's fixed my problem entirely thank you! 

5794

I had the problem that my XPS 15 had too much bass. Now I don't have this problem anymore - how I fixed it:

  • I uninstalled Realtek Audio Drivers in System Settings ("Apps") and rechecked in Device-Manager
  • Uninstall Maxx Audio in System Settings ("Apps")
  • Now the sound icon should be red -> no sound
  • Reboot
  • Windows fixed it itself, sound is here again and without too much bass.

I don't understand Dell why the install this Maxx Audio **bleep** which sounds very bad.

5783

I've spend 10-15 hours on this issue now. Mainboard changed twice and what not. I've been able to remove the crackle by uninstalling MaxxAudio on a previous BIOS, but this made another DSP function go crazy (autonomously behind the scenes), where it adjusts the volume up and down, depending on the music loudness. This completely removes all dynamics and distorts the signals now and then (this might be harder to notice for the "average Joe", but very clear if you work with music or similar).

I've said all the time that this is a software problem, but Dell is apparently not able to explain or make Realtek find and fix the problem.

The only thing that works 100% correctly, is to install Windows cleanly (from Microsoft media), and use the old (before 2019) High Definition Audio driver (which is provided and made by Microsoft).

This way there's no Realtek and MaxxAudio **bleep** on the drive, and the audio is fixed and sound is crisp and clear.

Only problem is that Microsoft have included a new High Definition Audio driver in 2019, and Windows 10 will sooner or later force an update to this version - which unfortunately doesn't work either (also MaxxAudio infected).

I thought I'd bought the best laptop on the market, and it probably is, if it wasn't taken down by crappy Realtek software. With all the users complaining, it is incredible that Dell is not doing more to fix it. They could start their own analysis by installing a clean Windows from Microsoft, and go from there (see when and what <Substitute character removed> the system for every single update they apply).

I could of course do it myself, but I've sort of hoped that Dell would do this 4 months ago with all their engineering power.

Anyway, I will have time in October to do an in depth analysis, and I'm sure I will find the exact cause (which I'm going to share on youtube or similar). But why are big companies like Dell becomming sitting ducks when it comes to fixing simple stuff like this?

How many people have not spend hours on this? - Dell only needed to take the old Microsoft driver, re-package it, and ship it to all of us - and make it pretend it was the latest and greatest. This way we would at least have working audio, and I think we can all live without the "genuine" Realtek/MaxxAudio crapware that just waste everyone's time...

In 1995 I was as disappointed as I am now by an expensive Pioneer video grabber solution, and I haven't bought anything from them since then.

5261

Try these settings in maxx audio. leave boost on but tone it down to a quarter and up the details to half

5179

Well done @tblockey  for the fix. Go to MaxxAudioPro app and turn bass to 12. done.

 

Latest Solutions
Top Contributor