XPS

Last reply by 02-11-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
47182

XPS 15-9570, BIOS 1.3.0, sleep mode gone?

I just bought my XPS 15-9570 with BIOS 1.2.2 installed, and I updated it to BIOS 1.3.0. I realized that the "sleep mode" option is now gone. I need to set this to "Force S3" sleep to prevent the laptop from waking up randomly, or don't go to sleep properly. So can I do that in the new BIOS?

 

IMG_20180805_165645.jpg

Replies (117)
3643

"At this point when checking `powercfg -a` it would say S3 is supported and S0 Low Power not available."

Didn't show up for me when I first tried, but somehow it worked after the third time. Seems like it needed a proper restart in between. My laptop is now sleeping... thank you!! 

3593

Only problem I'm running into now is that that my network adapter isn't recognized after coming out of sleep. Somebody has a fix for this?

3552

It really works man. All probs to you! Thanks
3465

Thank you! It almost work for me too, with the following exception: If I have a media playing then I close the lid, the laptop will not wake up again (black screen, but light in keyboard). I'm really happy that this is working because for some reason it take >2 minutes to boot windows on this darn thing.
20599

hi billybb,

The problem doesn’t occur with me so I cant reproduce it. My best guess would be to do the following:

it might be happening if the network adapter is allowed to be disabled to save power on hibernation and/or sleep. To uncheck the setting, follow the steps.


  1. Open Device Manager
  2. Expand Network Adapters
  3. Right click on the Network adapter installed on your computer
  4. Go to Properties
  5. On the Power Management tab uncheck all the boxes and apply the settings
  6. Restart the computer and check if the network card works fine.

 

3319

Hi,

Hi polarbeardk,

It could be that the power multimedia settings are messing with the sleep settings. I can reproduce your problem with a second screenattached by making a change in my power settings. So maybe that is set the way I set it to reproduce the problem.

Go to: Control Panel -> All Control Panel Items -> Power Options -> Edit Plan Settings.

Click on advanced power settings.

In advanced settings go to Multimedia settings -> When sharing media -> prevent idling to sleep

Not sure if this is the fix so remember how it was set before you change it.

3217

I just logged in to say THANK YOU! I'm so happy to have normal sleep back. Last night I had charged my laptop to 100%. I got to work this morning about 10 hours later, and my laptop had 64% battery left! Found this solution, and battery life is back to what it should be. Thanks!

2202

Ooooh yeah you nailed it! THANK YOU SO MUCH @Stijn2 !.

Latest Solutions
Top Contributor