Highlighted
s-plus
2 Iron

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

@the.rem
Please don't mark this thread as solved! This thread needs more posts and attention.

Any Dell reps here? Come on Dell, this is a major issue, and it's been unresolved for a few generations of XPS 15!
Please fix it. It's unacceptable for such a premium laptop to have a latency of well over 1 ms! Just install LatencyMon and see for yourself that acpi.sys causes huge audio latency.
Mobron
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

All the workarounds on this forum are fine, but not optimal. Since the first XPS laptops the problem is mostly the Killer Wifi. This wifi card is fine for gaming, but terrible for audio production. Just replace it with an intel card and most of your problems will be solved.

Google: dell xps 9570 replace wifi card

You will find tons of instructions.

 

0 Kudos
s-plus
2 Iron

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

It's just not true that replacing your wifi card to Intel's one will fix all your problems. Many people have done it and they STILL have a huge audio latency. The audio latency will get just a bit better by doing it. The MAIN problem is acpi.sys, which is unrelated to the wifi card.
Mobron
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

That is why I said ''most'' not ''all'' problems. Changing the wifi card will do al lot of good. Turning off Bluetooth will also go a long way, as will all kinds of other tweaks. I got a couple of XPSs working just fine for audio production, reaching very respectable DPC latency levels. Do not despair.

This may help as well: https://bandzoogle.com/blog/20-ways-to-optimize-your-windows-10-pc-for-music-production

 

And ooh yea, I remember that I could make the ACPI latency a lot less problematic by changing the power options a bit. Maybe running at full power while making music will stop the system from changing the processor speed constantly. These constant changes in processor speed could be causing some extra latency. 

 

 

0 Kudos
Jeyh
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

So do we have any insights about when the fix will be available ? I'm completely underwhelmed by my recent purchase of an XPS 9570 for that precise reason...

0 Kudos
DESman
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

Same here! (Hong Kong)

Mine is XPS 15 8th i9 32g Ram 1T SSD, as Dell they just don't know the root cause this problem, and they only is replace my Motherboard and Sound Card, sure the problem is still remain. also please try to close the lid to sleep mode, my XPS will turn it on. 

Ref.

https://www.youtube.com/watch?v=c2dbATWNL34
https://www.youtube.com/watch?v=b1DvRz0oHQE

 

 

0 Kudos
Caustix
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

Yea I'd love to know when too. I mean, £2k+???? Come on Dell!

RGBR
2 Iron

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

I´m thinking of buying one to use with music production, but there seems to have a lot of people on foruns complaining about that. 

0 Kudos
DjangoLives
1 Copper

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

I've been using a Dell XPS 9570 (i7, 16gb, 4k) for about five or six months and I'm having the exact audio latency issues that are described here.

Had some small successes with Process Lasso but it doesn't always seem to work, which especially drives me crazy when I need to record audio (I use Cubase). But the latency issues also occur when I simply play some music on Spotify. 

I bought the laptop in The Netherlands and I've been in contact with Dell for the last couple of months. Today I received an email where they say a bios-update that should fix these issues should be released right before Christmas. Fingers crossed!

RGBR
2 Iron

Re: Win 10 Home High DPC latency XPS 15 9570 ACPI.sys

I hope they fix it in the next days. I just got mine Dell 9570 and I´m not beeing able to just play guitar with some plugins. I get crack noises. I would like to keep this laptop, but without this fixed, it is unusable for me.
0 Kudos