lp1a
1 Copper

XPS 15 9570 - Echo when using headphone

Hi all, yet another problem with the XPS audio. I recently got my 9570 back from Dell after a repair (didn't turn on any more, but this might not be related). Now, there is an annoying issue with the sound: whenever I use a headphone or headset through the 3.5mm jack, there is a serious echo - as if some sound effect was activated. This does not occur on the internal speaker or on the sound through HDMI. I think this has something to do with the Realtek sound drivers, as this issue does also not exist when using older drivers. Version 6.0.1.8428 as of 10-May-18 works, but not 6.0.1.8454 (30-Jul-18) or the newest (6.0.1.8603, 14-Feb-19). However, .8428 produces regular bluescreens (incompatibility with Windows updates I suppose). The problem is also gone when I use the generic Microsoft audio driver (just after freshly installing Windows). However, once other drivers are installed, I cannot downgrade to this one (if I do, there's no sound at all). I have of course also deactivated everything there is to deactivate in the MaxxAudio app (even tried stopping various services, to no avail). Is there anyone who has the same issue and maybe a solution? This echo is driving me mad! 😕
Tags (1)
11 Replies
KeirC
1 Copper

Re: XPS 15 9570 - Echo when using headphone

YES!

I have just come back from holiday to find exactly the same issue....

I get normal sounding audio through the laptop speakers but some weird echoey reverb when listening to audio through headphones. Have tried listening to the same music through my phone and the headphones are fine, it is just when playing through the laptop.

I am a music producer so this is actually a huge deal, need it fixed or to find a workaround asap!!

Any help would be very much appreciated, thanks!

Moderator
Moderator

Re: XPS 15 9570 - Echo when using headphone

KeirC,

In the notifications area (on the right side of the taskbar), find the setting "Dell audio".
Right click this icon and select "Sound manager". There should be a setting under "MaxxAudio Pro" called "Speaker Enhancement". This will be set to "On".
Turn it off.

 

For my notes, click my username and send me the pc service tag number via private message as well as your Registered name
Email address
Phone number

0 Kudos
col_crunch
1 Copper

Re: XPS 15 9570 - Echo when using headphone

I am having this issue, but I dont see Dell Audio anywhere.... I have MaxxAudioPro installed, but I cant find a setting in there called "Sound Enhancement". Did I somehow install the wrong drivers? I got them from the product page.

0 Kudos
Moderator
Moderator

Re: XPS 15 9570 - Echo when using headphone

Thank you for your message. Is this issue observed irrespective of the music application used, both online & offline?

 

Do you find the issue if the AC adapter is connected or disconnected?

 

Do you have any external device connected like a docking station, USB printer, external drives?

 

Please update the latest audio driver (Version: 6.3.9600.2202, A13) followed by the BIOS update (even if you have the latest version)

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Sreejith R) & send a private message with the service tag, registered name & email address.       

  

How to locate the service tag

 

 

0 Kudos
lp1a
1 Copper

Re: XPS 15 9570 - Echo when using headphone

For me, the issue was resolved using either an old driver (from the Dell homepage, I believe it was version 6.0.1.82xx), or a newer version.

The newer version  I'm currently using is 6.0.1.8644, but at that time it was not an official version from the Dell homepage. I got it as a link from Dell support, but the installation was not straightforward.

However, I believe in the meantime, Dell released an updated version as well - you might want to try those.

0 Kudos
wwwingman
1 Copper

Re: XPS 15 9570 - Echo when using headphone

Hi,

I had the same problem.

Here is how solved it :open maxx audio pro, turn off maxx bass.

Hope this helps.

-- W

0 Kudos
RobinAH
1 Copper

Re: XPS 15 9570 - Echo when using headphone

I had the same problem, caused I believe by the Realtek Audio Driver update Version 6.0.1.8642, A05

The fix for me: Download an older driver and install over the current one.

I downloaded this one: Version 6.0.1.8400, A00

https://www.dell.com/support/home/uk/en/ukdhs1/Drivers/DriversDetails?driverId=93M93&osCode=wt64a&pr...

(I also extracted and used the drivers own installer rather than the Dell one, I doubt that made any difference but just in case you get different results try that.)

0 Kudos
kseniak
1 Copper

Re: XPS 15 9570 - Echo when using headphone

Open MaxxAudio and turn off the bass booster. Worked like a charm for me

0 Kudos
david2020
1 Copper

Re: XPS 15 9570 - Echo when using headphone

Update

 

I found turning off Maxx bass by itself was not enough.

Needed to also turn off the Nx head tracking (middle box) too.

Once both were turned off, echo has now GONE!

0 Kudos