Last reply by 02-09-2020 Unsolved
Start a Discussion
2 Jasper
2 Jasper

XPS 15-9570, Premier Color, issues with banding


I own a XPS 15 9570 with the 4k display option.

I am experiencing some really annoying color gradient issues for a while now.

For the first time, about half a Year ago all out of the sudden my Laptop started do have a really bad color representation, unsaturated blacks and color banding. After searching for a solution for a while I decided to reset my windows 10 Pro.

After that the Issues were gone, up until yesterday it suddenly reappeared. not knowing it better I tried to reinstall all kind of graphics drivers, but It didn't helped either. So i decided to reset the Windows again.

After having done that the Issue was gone again.

But today, it reappeared. I was opening the Dell premier color application (preinstalled) and the banding and discoloring reappeared. Although the app settings were set to default (brilliant). Though I don't know if it is connected.

I assume it is some mess with the Color Profiles settings however I am tired of reinstalling windows every time! And now really looking for a real solution.

It clearly appears to be an software related Issue, at least from my understanding. 

Is there Somebody who can help me out with this?

Thanks in advance



Labels (3)
Replies (57)

I can uninstall Dell Premier Color and install Graphics command center.

But there are no options on the Intel Graphics Control Panel to shift the colors to sRGB like I was able In Dell Premiere Color.

Can someone please help me how to create this with the Intel Graphics Control Panel



I’ve just found this thread looking for some help.

I've been having the same issue, really bad banding and the banding or noise moves when moving the mouse or arrow keys. A better description would be that it animates into other poor gradients.

It's like old video cards resolution or something, minds me of trying to play dvds in a Tiny PC for the first time in 1999.

The only way I've been able to fix it is by disabling the intel chip in device manager but the system cooks.





that worked a bloody treat!!


nice one bruvva

2 Bronze
2 Bronze

Hi Dos9570 and everyone suffering with this painful issue,

I don't know if everyone has resolved this issue yet, but through some of the great suggestions already in this thread I have resolved the infuriating banding issue on my XPS 15 9570. I also have set-up colour profiles (sRGB, Adobe RGB, Rec.709 etc) via an alternative method to Dell PremierColor. See this.

1. (this stage may not be necessary for most) Uninstall device for Intel UHD Graphics 630 in Device Manager - this is simply so the driver updates on the next reboot.

2. Disable Dell PremierColor from Startup in Task Manager - perhaps also turn off the ability of DPC to switch between colour profiles linked to different apps. In all honesty, I would simply uninstall DPC (it is available in the Microsoft Store if you want it back) but if you disable and never open it then you should not get banding any more (after a reboot).

3. Uninstall Intel Graphics Control Panel.

4. Install Intel Graphics Command Centre from the Microsoft Store. If you still have banding, then go to Display>Color and click 'Restore to Original Colors'.

This should get rid of banding and, if DPC is disabled/uninstalled, it should not come back after a reboot. This worked a treat for me and I hope it works for all of you.

Re: Color Profiles. You can do some basic adjustments in Intel Graphics Command Centre, but if you need more specific profiles:

1. Search in the start menu for 'Color Management'.

2. In 'devices' choose your display and make sure to check 'Use my settings for this device'.

3. Click 'Add...' and you should be presented with a dialogue box full of colour profile choices.

You can also click on the Advanced tab and choose 'Calibrate Display'. Go through the guided steps and your calibration will be added to the colour profile list.

You can also download any ICC profiles you choose and install them by right clicking them and choosing 'Install profile'.

Then just switch between profiles in 'Color Management'.

I hope this helps everyone who's suffered from this banding issue. I am so glad to have got rid of it! Thanks to previous posters for all the suggestions that lead to this.




I see that our technical support team have booked a system exchange. I'm awaiting further updates on the exchange and would keep you posted.


DELL-Gautam M

Social Media Support


Social Media Support

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.


Hi, Sander.


Hope you're doing good.


I'm still awaiting further updates on the exchange and see that you've been in touch with our technical support team.


I'll get back to you once I have further updates.



Social Media Support

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.



Followed your detailed steps and voila! Banding is gone. 

Your response deserves some kudos. Happy new year!



This solution will make the screen use native gamut and colorspace all the time (Vibrant in DPC). Windows ICC only work in softwares that support it. A lot of professional softwares that I work with doesn't use Windows color correction but relies on a hardware calibrated monitor. So this is not gonna work for me and isn't really a fix to the real problem.

Latest Solutions
Top Contributor