Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15-9570, TB16, USB Type-C, no longer charging


Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.


Replies (75)



Can you test a configuration with both AC power adapters connected to the TB16 and XPS 15-9570 to see if the battery charge issue happens?  Let me know if it charges.


Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

I already did - please refer to my previous post:

Battery charges when

  • Dock is not attached but Notebook AC Adapter is attached
  • Notebook AC Adapter is attached and the Dock is connected afterwards

Battery does not charge when

  • Only the dock is attached
  • Dock is attached first and then the Notebook AC Adapter is connected afterwards.

Any update on this issue or the investigation of it or something?


Bump for me too please.

After reading through this post, I can confirm that I have exactly the same issue.

Tested the same dock/AC-power connection configurations and end up with exactly the same results. 

This thread has gone a little quiet in the past fortnight which is concerning.

Yeah not sure what else I can do - I tried to be as detailed as possible and provided all requested information.

It has been another week and there has been no progress or useful comments on this issue so far.

I see that a new bios version has been released - I will try it and report back of course, however I have little faith that it will magically resolve the issue.

I'm having this same issue with my Precision 5530 and WD15 Docks. I have two WD15 Docks (one at home and one at the office). Things were fine until I ran bios and dock updates a while back. Now I can't charge off just the dock and I need to plug in the laptop power adapter first, then the dock to get a charge (in that order). My laptop adapter is 130W and my WD15 adapters are 180W.

Same issue here too, first encountered yesterday. Currently, it will only charge if booted with the ac adaptor in place.

  • remove the power after booting and reinsert, stops charging
  • won't charge at all from a TB16 dock via USB-C but recognises all devices monitor etc. and will recognise if a lower power supply is used in the TB16
It is running the latest Windows build with all updates from Microsoft and Dell (software and BIOS). I have tried
  • uninstalling the battery device drivers
  • using a different TB16
  • using a different ac adaptor
In all cases the white lights on the power leads illuminate, and the white light on front of laptop illuminates, and the Dell Power Manager says charging but the charge status will decrease until it powers off unless booted with the ac adapator in place in which case it will increase.

Hi, same issue here. Until today morning everything worked fine. I use Dell XPS 15 9570 with Dell TB16 240W dock. Today I noticed that the dock is no longer charging the laptop. I tried everything mentioned on the forums and also stuff I found on the internet regarding this topic. I tried:

- numerous restarts

- modify windows services

- update of TB16 firmware

- update DELL XPS 15 bios, firmware and drivers, including Thunderbolt driver

- reinstalled battery drivers

- tried to use another TB16, but it looks like something happened with laptop internally

- to connect USB C 87W power adapter - nothing happened when I plugged it in, laptop totally ignored it

- standard AC adapter works normally


So I'm running on the standard power adapter and using the dock just as a hub - this works fine - audio, USB, external monitor, ethernet. In order to be able to charge notebook, I must plug AC adapter first and then USB C connector of the TB16. If I plug the TB16 first and then the AC adapter, PC will not charge. 


After plugging the USB C connector of TB16, the notification pops up, saying that PC is not charging and I have to use a proper charger and charging cable. However, that's what I'm doing... Does anyone still cope with the same issue? 

My 9570 had the same chip blow on the motherboard. Fairly certain this happened just after updating the bios while connected to the dock (in my case the WD15 with 180w ac adapter) Warranty expired some time ago. Called dell 9-18 and was told they'll send me a replacement motherboard for $171 (I explained that I am comfortable switching it over myself). Called today (9-25) to check on the order only to be told the motherboard is no longer available and my order was cancelled. Also the person suggested I check local options (whatever the hell that means). How is the motherboard no longer available on a laptop that is less than 2 years old? Why did I have to call dell to be informed of the cancellation? I was told to call back in a month and see if I can buy a motherboard then. I am starting to think the motherboard is being superseded to fix this issue. I am extremely disappointed in dell for constantly letting me down every step of the way. I now face the option of leaving the computer as is or spending several more hours re-explaining this whole mess to a different person at dell.

Top Contributor
Latest Solutions