XPS

Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
38859

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

Replies (75)
7411

Yes I am using the DELL supplied 240Watt power adapter that came with the TB16 Dock.

  • I also verified the same problem with 2 other docks of my co-workers (who can charge their notebook fine on my dock and their docks).
  • I also verified the same problem on a brand new TB16 dock that came with a 180Watt power supply and which also works fine on my co-workers 9570.

The issue is very clearly not the dock but something with the notebook.

7399

Gh0stface,

 

Did you update to the latest bios version here? Also, did you update the tb 16 dock firmware here after the system 9570 bios update?

 

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

7399

Gh0stface,

 

Also, update the drivers listed below from the link here.

 

Dell recommends installing the following BIOS, firmware, and drivers step-by-step in the prescribed order to ensure optimal performance: 
• Flash the latest Basic Input/Output System (BIOS) for the system. This is available in the "BIOS" section. • Install the latest Intel Thunderbolt Controller Driver for the system. This is available in the "Chipset" section. • Install the latest Intel Thunderbolt 3 Firmware Update for the system. This is available in the "Chipset" section. • Install the latest Intel HD Graphics Driver for the system. This is available in the "Video" section. • Install the latest ASMedia USB 3.0 Extended Host Controller Driver for Dell Thunderbolt Dock. This is available in the "Docks & Stands" section. • Install the latest Realtek USB GBE Ethernet Controller Driver for Dell Thunderbolt Dock and Dell Dock. This is available in the "Docks & Stands" section. • Install the latest Realtek USB Audio Driver for Dell Thunderbolt Dock and Dell Dock. This is available in the "Docks & Stands" section. • Restart the system. • After the software update process completes, connect the AC adapter to the TB16 dock first and then attach the Thunderbolt 3 (TypeC) cable to the computer before using the docking station

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

4241

  • Tried the latest BIOS update 1.12.0 - no change
  • Tried reupdating my dockingstation, said everything is up2date and no change
  • Installed/updated all the listed drivers/firmwares/bios - no change

Please let me restate:

  • It doesn't work in windows, linux or in BIOS
    • so drivers can't be the issue
  • My Dockingstation works with my 2 co-workers XPS 15 9570 just fine
  • My XPS 15 9570 doesn't work with 3 other TB16 docks (but the all the docks work fine with the 2 co-worker notebooks). 3 of the docks are 240W and one is 180W
    • so the dock is irrelevant

It must be some Bios,Thunderbird or Hardware issue with my XPS 15. Not sure how the thunderbird controller works and if it can be reset or fully power cycled or something.

4237

I have the same issue with my Dell Precision 5530. Seems like bios upgrade broke it and reverting back the bios does not seems to work. Did bios update physically broke the laptop? or somehow retaining some sort of configuration that got pushed through bios update? Like others have mentioned, this has nothing to do with drivers because battery drains while you are on bios screen.

4219

Gh0stface,

 

Click my name and private message me your registered name, mailing address with zip code/country code, email address, and area code/phone number.

 

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

4123

Thank you - sent you a PM.

@rest I'll keep the thread updated about the progress on this and whenever it fixes anything

4115

Gh0stface,

 

I sent you a private message here on the forum. Reply asap.

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

4103

Do we know what causing this? I'm going to do a warranty exchange if you think this is unfixable over an bios update.

4082

Yup, I'm in the same boat. My place of business can do a warranty claim, but I'd rather not go that route unless we know it can't be fixed via a future bios update or something.  

Latest Solutions
Top Contributor