XPS

Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
37555

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

Replies (75)
7030

Same issue on my precision 5530 (bios version 1.13.0). Blown chip. I am using a TB16 dock. I don't remember updating the Bios while being plugged in to the dock...

Called Dell, they laughed at me saying "hardware failures only come during the first 60 days, not after almost a year"... Anyway, they are sending somebody tomorrow to replace the motherboard.

7294

My Dell XPS 9570 failed in August, sometime after the Bios 1.12 upgrade. Not sure if it was at the same time as the Bios upgrade process, or later on.

At that time, I got all the symptoms described in this thread.

After several discussions with Dell support, I finally got the motherboard changed at home, and since that time, everything is working fine. So most probably, I got a burnt component on the motherboard.

What is a bit worrying is that without a clear root cause, the problem may come again. I understood from searchs on the net that the initial XPS15 motherboard is not longer available and has been replaced. Not sure why, hopefully this is to solve the chip burning issue we all face.

I don't know if my new motherboard is OK or at risk. From Speccy software, I can read :

Manufacturer: Dell Inc.
Model: 0F3DC8 (U3E1)
Version: A04
Chipset Vendor: Intel
Chipset Model: ID3EC4
Chipset Revision: 07
Southbridge Vendor: Intel
Southbridge Model: IDA30E
Southbridge Revision: 10

I will keep my fingers crossed, since I am still using my XPS15 powered through a TB16 dock (this is so convenient...).

 

 

7498

The same thing also happened to "Yorgosphere". So you can deduce that the update process (while the Dock with power is connected to the Thundrbolt / USB-C port) to BIOS 1.13.0, or the same BIOS version itself is the cause of this problem !!

7507

I think the BIOS update to 1.13 with dock plugged in might cause the issue. Two days ago I updated the BIOS to 1.13 and after the update, the XPS 15 was no longer charging from the TB16 and any other USB C charger is no longer working. For charging, I can use only standard AC adapter. Before the update, it was working totally fine without any issues regarding charging via usb c also with other chargers i.e. 87w USB C charger from Apple. 

7530

Someone who has had this laptop for a long time and has always used it without problems with the TB16 / USB-C Dock, can you confirm that the problem started after updating to BIOS 1.13.0?

7557

nope

5616

My 9570 had the same chip blow on the motherboard. Fairly certain this happened just after updating the bios while connected to the dock (in my case the WD15 with 180w ac adapter) Warranty expired some time ago. Called dell 9-18 and was told they'll send me a replacement motherboard for $171 (I explained that I am comfortable switching it over myself). Called today (9-25) to check on the order only to be told the motherboard is no longer available and my order was cancelled. Also the person suggested I check local options (whatever the hell that means). How is the motherboard no longer available on a laptop that is less than 2 years old? Why did I have to call dell to be informed of the cancellation? I was told to call back in a month and see if I can buy a motherboard then. I am starting to think the motherboard is being superseded to fix this issue. I am extremely disappointed in dell for constantly letting me down every step of the way. I now face the option of leaving the computer as is or spending several more hours re-explaining this whole mess to a different person at dell.

5632

Hi, same issue here. Until today morning everything worked fine. I use Dell XPS 15 9570 with Dell TB16 240W dock. Today I noticed that the dock is no longer charging the laptop. I tried everything mentioned on the forums and also stuff I found on the internet regarding this topic. I tried:

- numerous restarts

- modify windows services

- update of TB16 firmware

- update DELL XPS 15 bios, firmware and drivers, including Thunderbolt driver

- reinstalled battery drivers

- tried to use another TB16, but it looks like something happened with laptop internally

- to connect USB C 87W power adapter - nothing happened when I plugged it in, laptop totally ignored it

- standard AC adapter works normally

 

So I'm running on the standard power adapter and using the dock just as a hub - this works fine - audio, USB, external monitor, ethernet. In order to be able to charge notebook, I must plug AC adapter first and then USB C connector of the TB16. If I plug the TB16 first and then the AC adapter, PC will not charge. 

 

After plugging the USB C connector of TB16, the notification pops up, saying that PC is not charging and I have to use a proper charger and charging cable. However, that's what I'm doing... Does anyone still cope with the same issue? 

5777

I can go through my work laptop replacement program but I do not want waist my time doing it if the new replacement motherboard has the same issue. Does Dell recognize this as an issue?

5780

I think most of us noticed this issue after an BIOS update. Could it be that updating Bios while usb-c plugged in caused this?

Latest Solutions
Top Contributor