Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15-9570, TB16, USB Type-C, no longer charging


Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.


Replies (75)

Just finished my 5 week dance on this.  Laptop sent in, tech notes said "Logic board replaced".  Works again.


Piece of advice, if it worked before and no longer does, start the service claim immediately.  Don't waste hours and weeks of your life with the "driver update/support session" dance...


I asked the techguy that. He said there was no change in revision or something so it's basically the same motherboard again and could fail again.


Finally got acknowledgment from Dell that the motherboard needs to be replaced. This is scheduled for monday morning on site (great I don't need to send back the XPS)...

New motherboard installed yesterday. Everything is working fine now. I can charge again the laptop using dock TB16 with USB-C. Great I can use again only one connection for external screen, mouse, keyboard and charging. Looking at the failed motherboard, the tech was not sure what happened and why. Hopefully this is not a design issue that will cause similar problems in the future.

Precision 5530 Owner checking in.  Same issue, after FW update, my laptop stopped charging via my WD16.  Opened up the case, and found a burned out chip.  Swapping out the motherboard (after 4 attempts of Dell sending me the WRONG part - and the right part they finally did send had a damaged RAM socket!) did fix the issue.

Image of the motherboard.  Black part is the shield - you can see the melted area that was above the chip on the shiny part of the shield.



Closeup of the burnt-out chip.chip.jpeg


Thanks for the pictures. I should have taken pictures of my failed mother board, missed that... You are talking about firmware update that created the issue. How did you get this information? Is this BIOS update? Thanks.

I think most of us noticed this issue after an BIOS update. Could it be that updating Bios while usb-c plugged in caused this?


I can go through my work laptop replacement program but I do not want waist my time doing it if the new replacement motherboard has the same issue. Does Dell recognize this as an issue?


Hi, same issue here. Until today morning everything worked fine. I use Dell XPS 15 9570 with Dell TB16 240W dock. Today I noticed that the dock is no longer charging the laptop. I tried everything mentioned on the forums and also stuff I found on the internet regarding this topic. I tried:

- numerous restarts

- modify windows services

- update of TB16 firmware

- update DELL XPS 15 bios, firmware and drivers, including Thunderbolt driver

- reinstalled battery drivers

- tried to use another TB16, but it looks like something happened with laptop internally

- to connect USB C 87W power adapter - nothing happened when I plugged it in, laptop totally ignored it

- standard AC adapter works normally


So I'm running on the standard power adapter and using the dock just as a hub - this works fine - audio, USB, external monitor, ethernet. In order to be able to charge notebook, I must plug AC adapter first and then USB C connector of the TB16. If I plug the TB16 first and then the AC adapter, PC will not charge. 


After plugging the USB C connector of TB16, the notification pops up, saying that PC is not charging and I have to use a proper charger and charging cable. However, that's what I'm doing... Does anyone still cope with the same issue? 


My 9570 had the same chip blow on the motherboard. Fairly certain this happened just after updating the bios while connected to the dock (in my case the WD15 with 180w ac adapter) Warranty expired some time ago. Called dell 9-18 and was told they'll send me a replacement motherboard for $171 (I explained that I am comfortable switching it over myself). Called today (9-25) to check on the order only to be told the motherboard is no longer available and my order was cancelled. Also the person suggested I check local options (whatever the hell that means). How is the motherboard no longer available on a laptop that is less than 2 years old? Why did I have to call dell to be informed of the cancellation? I was told to call back in a month and see if I can buy a motherboard then. I am starting to think the motherboard is being superseded to fix this issue. I am extremely disappointed in dell for constantly letting me down every step of the way. I now face the option of leaving the computer as is or spending several more hours re-explaining this whole mess to a different person at dell.

Latest Solutions
Top Contributor