XPS

Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

Replies (75)

  • Tried the latest BIOS update 1.12.0 - no change
  • Tried reupdating my dockingstation, said everything is up2date and no change
  • Installed/updated all the listed drivers/firmwares/bios - no change

Please let me restate:

  • It doesn't work in windows, linux or in BIOS
    • so drivers can't be the issue
  • My Dockingstation works with my 2 co-workers XPS 15 9570 just fine
  • My XPS 15 9570 doesn't work with 3 other TB16 docks (but the all the docks work fine with the 2 co-worker notebooks). 3 of the docks are 240W and one is 180W
    • so the dock is irrelevant

It must be some Bios,Thunderbird or Hardware issue with my XPS 15. Not sure how the thunderbird controller works and if it can be reset or fully power cycled or something.

I have the same issue with my Dell Precision 5530. Seems like bios upgrade broke it and reverting back the bios does not seems to work. Did bios update physically broke the laptop? or somehow retaining some sort of configuration that got pushed through bios update? Like others have mentioned, this has nothing to do with drivers because battery drains while you are on bios screen.

Gh0stface,

 

Click my name and private message me your registered name, mailing address with zip code/country code, email address, and area code/phone number.

 

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Thank you - sent you a PM.

@rest I'll keep the thread updated about the progress on this and whenever it fixes anything

Gh0stface,

 

I sent you a private message here on the forum. Reply asap.

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Do we know what causing this? I'm going to do a warranty exchange if you think this is unfixable over an bios update.

Yup, I'm in the same boat. My place of business can do a warranty claim, but I'd rather not go that route unless we know it can't be fixed via a future bios update or something.  

Jesse L,

I just checked and did not receive any private message from you.

Last message I got was "Dell Customer Experience Survey" from DCFAdmin.

Gh0stface,

 

I was needing to know your zip code or country code? 

 

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Jesse,

I sent it along with my whole address, anyway that would be A-1100 in Austria.

Thank you

Top Contributor
Latest Solutions