XPS

Last reply by 02-19-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
60162

XPS 15-9570, Windows 10, high DPC latency, acpi.sys

Hello,

I have a dell XPS 15 9570, and I have big issues with on board and external audio.

HW Spec:

Dell XPS 15 9570, i7 8750H, 4K screen, 16g ram /512g ssd, qualcomm Killer wifi and then intel AC-9260, nVidia 1050 Ti with latest WHQL drivers, bios v1.2.2, all drivers to date as of 2018/15/07

Symptoms:

- audio cracks and pops with system audio when watching videos, listening to mp3/flac, playing games with built-in card,

- audio cracks and pops with  external ASIO soundcard (focusrite scarlett 18i8 2nd gen) when running pro DAW software with 256 samples buffer @48Khz or 512 buffer @96Khz

This can damage external speakers and makes the machine unusable for live audio or even standard multimedia use.

What I did:

- applied all tweaks recommended by my external audio card's manufacturer https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10

- ran LatencyMon and found that TCPIP.sys and ndis.sys were causing 4ms DPC latency spikes, followed by ACPI.sys 2ms and dxgkrnl.sys 1.7 ms

- swapped  the qualcom card for an intel AC-9260 which eliminated totally the TCPIP.sys and ndis.sys spikes

- now ACPI.sys and dxgkrnl.sys are still causing 2ms DPC latency spikes

- audio glitches are still present

- disabled all peripherals except for keyboard, integrated graphics, trackpad, screen and storage (I disabled wifi, bluetooth, webcam, nvidia graphics, fingerprint reader, ACPI battery manager, cardreader, fall accelerometer, screen touch, etc.)

- disabled Speed-Step/ SpeedShift and Turbo-Boost, disabled virtualisation support in the BIOS to try to minimize randomness in the behaviour

- disabled fastboot

- ACPI.sys latency is still culminating at 1.7ms and causing audio dropouts with either built-in or external USB asio interface

- I've opened a support ticket over at dell with my premium support, the ticket was automatically closed a week later without anyone getting in touch with me.

 

I've run out of options and am looking for help.

 

Replies (114)
13290

So I guess this problem is not fixed at all?

I have same problems with dpc latencies around 6000 on precision 5530 (which is the same as xps model I guess but with other graphic adapter)

It got way better opening the Dell power Manager and check the performance box in thermal options (sorry don't know the exact English translation because my UI is in German)

Still when I adjust the brightness I will have cracks and pops... Pretty embarrassing performance for a 2000€ machine. Dell, how about fixing it? Seems like a very bad system design when hitting a FN key interrupts a whole core for 6ms and above...

13335

Hello, 

Thanks for reaching out to us. Can we try the steps mentioned in this forum?

https://www.dell.com/community/XPS/Dell-XPS-DPC-Latency-Fix/td-p/7367700

Dell-Vijay A
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

13332

Hi Vijay,

not sure why I should follow things like the step mentioned in the link since I dont have an eGPU Dock attached to my Dell. 

Nevertheless did the applicable things from the linked thread and deactivated the UHD Graphics Card, disabled UHD Audio, deinstalled Realtek Drivers and so on (I am not using the internal sound card at all - I am on an external Interface). Now my laptop runs on the built in Quadro 1000. Result is I cannot adjust screen brightness anymore but hitting the screen brightness buttons will have the same ACPI.sys DPC latencies of over 6ms mentioned in my previous post. 

Regards

Karsten

4868

Hi there, I know your post was done almost a year ago, but I’ve just purchased a top of the line RME ufx+ thunderbolt usb3 interface. RME drivers are world class. The issue is with DELL, and is the same wether using usb2, 3 or thunderbolt. I’m currently scanning all possible fixes and and then rme forum support suggested process lasso as well and various other fixes, this is the ongoing thread:

https://forum.rme-audio.de/viewtopic.php?pid=148389#p148389

there’s a very interesting discussion going on about windows vs mac as well.

If and when I improve the performance of the Dell XPS i9 top of the line audio throttler, I will post the solutions that worked.
In the meantime if anyone has an updated fix for this issue I’m very much interested ! 

7474

No actually, MacBook have had their issues as well, avoiding fixing them as well until enough pressure was built up... Neither windows nor MacOs platforms are real-time Sustemd and they are both based on the same hardware actually. ASIO (windows) is faster and better than Core Audio (Mac). It also all depends on DAWs, plugins etc.. There is no 1 size fits all. To have a good machine you need have it tailor made by a pro audio company that design laptops/desktops/workstations specifically for audio purposes. Obviously it’s potentially more expensive and maybe less versatile. But it will truly be optimised for audio tasks.

 

https://forum.rme-audio.de/viewtopic.php?pid=148389#p148389

6879

Yes you will most probably the issues you mentioned: delays and worse, audio glitches and pops, especially in live situations.

Although you could be lucky and have no issues, unlucky imho.

i have XPS 15 core i9, rme ufx+ (world class sound card) and dell is the issue.

13601

Yes! You maybe have a top of the line sound card (mine is RME ufx+, cost me an arm and a leg, but this company has a stellar reputation when it comes to latency and drivers), and a so called top of the line XPS, if your system creates issues, soundcard will not help. The Laptop/soundcard combo will be limited by the laptop...

38477

Hey everybody !

I changed my computer and still got this problem. So the error doesn't come from the laptop, but I found the issue. It comes from Intel Turbo Boost Technology!

Try this:
* Click Start
* Type power
* Click Edit power plan
* Click Change advanced power settings
* Change the Power option to Balanced
* Open Processor power management
* Change the Maximum processor state to 99% instead of 100%

Capture.JPG

This will avoid the Turbo Boost activation. Windows will no longer get peak from only one processor. It will synchronize all the processors and make the music more stable! It should be fine, then.

Cheers ! 

 

13521

Thank you for your reply and this tip ! I will try that as well.

How do you slow the cpu to 99% ? Is that a setting in the bios or do you use a special software ?

thank you !

6737

Those kind of stuff, Windows power alimentation, or something like that !

Capture d’écran (2).png

Latest Solutions
Top Contributor