Highlighted
2 Bronze

XPS 15-9570, brand new and very laggy

Jump to solution

I've had this laptop for about a month and recently the performance has gotten very bad. The mouse started stuttering, it would take much longer to alt tab through apps, games which normally would have 100+ fps are laggy, and the worst part is that it's like a slideshow when I scroll on a webpage. I did a system restore with a new install of windows and the same problem persists. I used Intel Driver and Support Assistant to see if any of my drivers needed updating, it says my graphics driver needs updating but every time I try to let windows or dell do it it just says that everything is fine and up to date or it says the driver can't be installed on this computer or something. So I took it upon myself to download the latest graphic driver from the intel website and manually install it, but the problem is still there. And now on top of manually installing the driver I still constantly get notifications saying windows has updates to install but when I click it and check for new updates it says I'm all up to date. Why is there so much going on with this laptop is this common? Is it defective? Any help would be great thanks

1 Solution

Accepted Solutions
Highlighted
1 Copper

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Hi there,

for any one who should have the same problem, here is one suggestioun, that helüed in my case.

Please check if by any chance the app "Dell power management" is installed.

The solution in my case was to deinstall this app, but before doing so, i have change the in app temperature settings from "Colling" to "High Performance".

After doing so, my 9570 seems to work fine for now. That app somehow screws up the load exchange between the Intel GMA and the GTX.

 

Hope this helps somebody.

 

Cheers

 

 

 

 

 

 

View solution in original post

11 Replies
Highlighted
2 Iron

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Is it under warranty? If it's new it shouldn't be acting like that. Could be hardware issue since you did a reset  

0 Kudos
Highlighted
Community Manager
Community Manager

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Oceanface,

 

Run the diagnostics on the computer to see if any failures are reported. If so, post the failures on this post. Also, click here to download and install the latest bios version.

 

How to Troubleshoot Slow Performance Issues

 

 

Running the ePSA Diagnostics

Invoke diagnostics boot by either of the methods that are suggested below:

  1. Power on the computer.

  2. As the computer boots, press the F12 key when the Dell logo is displayed.

  3. In the boot menu screen, use Up/Down arrow key to select the Diagnostics option and then press Enter.

     

    NOTE: The Enhanced Pre-boot System Assessment window displays, listing all devices detected in the computer. The diagnostics starts running the tests on all the detected devices.

     

  4. Press the arrow in the lower-right corner to go to the page listing.

    The detected items are listed and tested.
  5. To run a diagnostic test on a specific device, press Esc and click Yes to stop the diagnostic test.

  6. Select the device from the left pane and click Run Tests.

  7. If there are any issues, error codes are displayed.

    Note the error code and contact Dell.

    or

  8. Shut down the computer.

  9. Press and hold the Fn key, while pressing the power button, and then release both.

  10. Repeat steps 3–7 above.

 

 

 



 

0 Kudos
Highlighted
Community Manager
Community Manager

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Oceanface,

 

Did the information provided help you with the performance? Did the ePSA show any faults?

 

 

 



 

0 Kudos
Highlighted
2 Bronze

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Hello I hope it isn't too late to get back to you. I ran the diagnostics test and I got no error codes and it said all tests passed. I have also clicked the link you sent for the latest bios. I have used that service before and already installed the latest bios and drivers. It says "urgent" next to the bios and 2 other drivers I've already updated in the past,  but after letting the support assistant scan  it says "No driver updates found. Your system has the most recent updates." I feel like I've manually installed all the drivers I needed to. Would running a different test and showing you the results help at all? Because I get mixed results on these driver tests. 

Update: I have the Intel Driver and Support Assisant installed on my computer and nex to the icon in the ico tray it says 2 new updates so I checked for updates and the results were that my Intel UHD Graphics 630 were an older version (x.x.x.6471) and so was my Intel Rapid Storage Technology Driver (17.0.2.1076). When I click to install the new update I get this message. 901b3e2266daf15312933cae0129e678.png

   

0 Kudos
Highlighted
Community Manager
Community Manager

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Oceanface,

 

Change power plan to high performance by click here

 

Have you tried disabling automatic panel refresh rate at all?

  1. Right-click on the Desktop, and select Intel® Graphics Settings

  2. Click on Power to access the Power Section

  3. Under Power section uncheck the Panel Self-Refresh to disable it.

Other steps to change that may help the system from the lagging.
Disable Intel Turbo Boost.
Intel Turbo Boost increases the speed of your CPU by overclocking it. It is useful for doing heavy tasks on your computer, but it also throttles your computer’s performance.

The easiest way to disable Turbo Boost is by using the BIOS switch. Note, however, that this is not available for all computers. Check your laptop’s make and model to determine if it has a BIOS switch, then follow the steps below to switch off Turbo Boost using your BIOS configuration:

Click Start > Run.
Type in msconfig in the dialog box, then click OK.
Click Advanced to open the System Utilities screen.
Go to System Configuration > BIOS/Platform Configuration (RBSU) > Performance Options .
Click Intel (R) Turbo Boost Technology, then hit Enter.
Choose Disabled, then press Enter.
Press F10 to exit the window.
If your device does not have BIOS switch, you can turn off Turbo Boost by by editing your computer’s Power Options. To do this:

Go to Control panel > Hardware and Sound > Power Options.
Click Change plan settings beside the plan you are using.
Click Change advanced power settings.
Click Processor power management to expand it.
Click Maximum processor state to show the options.
Change both On battery and Plugged in to 99%.
Hit Apply, then OK.
Fix #4: Uninstall DPTF.
Some users reported that removing Intel Dynamic Platform & Thermal Framework (DPTF) has worked for them. Follow the steps below to uninstall DPTF:

Press Windows + R to launch the Run command.
Type in apprize.cpl in the dialog box, then hit the OK button.
Right-click on Intel Dynamic Platform & Thermal Framework, then choose Uninstall.
Follow the on-screen instructions to remove DPTF from your computer.
Next, open Device Manager and find Intel Dynamic Platform & Thermal Framework.
Right-click each item under Intel Dynamic Platform and Thermal Framework, then click Uninstall.
Click Delete the driver software if the option is available. This should prevent DPTF from reinstalling itself when the computer restarts.

 

 

 



 

0 Kudos
Highlighted
2 Bronze

Re: XPS 15-9570, brand new and very laggy

Jump to solution

1.) When I right click my desktop I don't have the "Intel Graphics Settings" option displayed, only Nvidia Control Panel which has no options of that sort.

2.) When I run msconfig to disable Turbo Boost I have no "advanced" option. It's just 5 tabs that say general, boot, services, startup, and tools. None mention advanced or system utilities. 

3.) When I go to control panel > hardware and sound > Power options and advanced power settings there's no option for processor power management.... I just have very basic options like buttons, close lid, sleep, etc. Why the **bleep** can't I change the processor power management? Regardless the power option is set to high performance.

4.) I cannot uninstall Intel Dynamic Platform & Thermal Framework because when I go to run and type in apprize.cpl it gives me an error saying windows can't find that... 

Are there any other options left? All drivers are up to date and so is windows. 

0 Kudos
Highlighted
2 Bronze

Re: XPS 15-9570, brand new and very laggy

Jump to solution

aa1de6142460b1ecbe97488e6232aa5a.png51765f2415b07ffd552e2c34052da0ae.png5abbfe23df45eb776d4998c574824c03.png

0 Kudos
Highlighted
Community Manager
Community Manager

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Oceanface,

 

Click here and download the support assist app and connect to resolve the performance issues.  Let me know the outcome. 

 

 

 

 



 

0 Kudos
Highlighted
Community Manager
Community Manager

Re: XPS 15-9570, brand new and very laggy

Jump to solution

Oceanface,

 

Did the support assist help resolve the issue? 

 

 

 



 

0 Kudos