XPS

XPS 15-9570, color banding issue

Recently got this xps 15, but am dissapointed by the ridiculous amount of color banding on the monitor. All the blacks are pixelated and crunchy. How do I fix this?

Labels (4)
Solutions (2)

Accepted Solutions

Hi all,

I have XPS 7590 with 4K IPS Touch Screen and exactly the same issue from the day I bought it.

The way to fix it:

- Close or uninstall Dell PremierColor;

- In the "Intel Graphics Command Centre" go to "Display --> Color --> Restore to Original Colours".

I still think it could be better, but now I can leave with it.

Hope it helps to the others.FastStoneEditor1.jpg11.jpg222.jpg

View solution in original post

Community Accepted Solution

Hey everyone!
After a year of having this issue and playing with the color gammut  setting slider in Intel Graphics control panel I finally found an solution which works after restart and all the latest updates and Bios.
Issue was coming from Dell Premier Color and here are the steps I followed from this post by @Anonymous :

1. Remove Dell Premier Color

2. Set color profile to Premier Color sRGB 6500 or Premier Color Adobe RGB 6500
Control Panel -> Color Management: add the color profile and set as default

3. Open Intel Graphics Command Center and reset the colors to default
Display -> Color-> Reset Original Colors


Hope that can help

View solution in original post

Community Accepted Solution
Replies (193)
2 Bronze

I am having the same problem

2 Bronze

I've had the xps 15 9570 for a few months now and the banding has made watching video on this expensive 4k screen almost impossible.  I'm not a very techie person so I hope there's a fix for this issue

2 Bronze

Same issue here on my XPS 15 9570 FHD display and latest Intel drivers (26.20.100.6952).

Tried several solutions like dis-/enabling Dell Prmier Color, en-/disabling hardware support in Chrome, installing older drivers for Intel 630 UHD graphics and going back to latest.

The only thing that helped removing color banding was completely uninstalling Intel graphics drivers. But then you cannot adjust brightness with the brightness switches on the laptops keyboard.

@Anonymous: HELP PLEASE!

 

Michael

Hello there,

 

since the issue seems to be widespread and I was one of the first here in this thread who mourned about it I would like to give more input on how I "solved it" for me (cause it is not actually a solution but a work around).

After hours of trying and retrying I finally found that if you uninstall Dell Premier Color but keep Intel Drivers AND (important!) use Intel Graphics Control Center, the banding is far less visible - at least in video content.

Note that the key to satisfaction is Intel Graphics Control Center. There you got to click on "Video" and find "Input Range" (I translated this from German; It is the 2nd menu from top). Open it and set "Driver settings" and there set "Full Range" instead of the standard value "Limited Range".

This will set your range of visible hex colors from about 10 - 235 to 0 - 255.

Hope I could help.

Michael

Hi

 

Unfortunately, it didn't fix the issue at all. Obiously, Dell isn't concerned with this issue and they don't even try to solve it. There are too many Users with this issue and nothing is done by Dell! Paying +2000 Euros for a device and not getting support is a shame.

Just contacted Dell via twitter.

Even funnier there - I send that GeForce Experience screenshot which I posted here above - he says he don't see any issues with the image 

That is really top level of respect to a customer. Can't believe it is possible in the end of 2019.
If someone sane from Dell ever sees this, I'd be very happy to see some comments on this.


DellTwitter_1.JPGDellTwitter_2.JPGDellTwitter_3.JPG

This is madness. I have been having these fruitless conversations for more than 2 months now. For the first time tonight there was some minor progress - we installed Intel Graphics Command Centre. It did improve the banding a bit, did not resolve it, but it messed up the colours, so it requires additional tweaking. If you have not yet, you can give it a go and see if it does anything for you.

Thank you Raine!


I'll try this option, but thing I'd better get back to that old bios and try to find some good combination with an old graphic driver where we had ideal picture condition.

Anyways, the funniest and strange thing that this Dell people even pretend that they don't see any issues it all. I just can hardly believe it's possible. Here's the last part of the same twitter dialogue and image I'm referring to there attached. This is rediculous.

DellTwitter_4.JPGGeForceExperience start.jpg

Hello, same issue.

Andrew I just wanted to say that if I view this topic with my dell xps 15 i can see the banding problem (because even mine has it), but if I watch it with my phone the images are great, try to do the same.

So I think that the only way to show them the issue is to take a photo of the screen with a camera.

Top Contributor
Latest Solutions