ThomasXPS15
1 Copper

Re: XPS 15 9570 is really slow after update to BIOS 1.11.2

Hello, I think I have already send my service tag to you. But my service period is over... I have started this community post to give you some feedback about your product and to allow you to improve it. Maybe other customers have same troubles and my feedback could help them also. So I do not expect any individual support. Thanks, Thomas.
Reply
Highlighted
EVRLG
1 Copper

Re: XPS 15 9570 is really slow after update to BIOS 1.11.2

Hi, I had a very similar problem, 1.11.2 made everything very sluggish but ONLY when the laptop was plugged in. I have a XPS 15 9550 running elementary OS BTW.

Eventually, I rolled back on 1.10 and all is good.

A couple days ago, I saw that on the 9550 page Dell deleted 1.11.2 only to publish 1.9.0 (dating back from 2018) as the newest and latest; no idea why, since 1.10 is newer (March 2019) and works perfectly.

Today though 1.11.2 reappeared, with no mention of "Enhances thermal management of the system" in details.

I tried it, but the sluggishness when plugged in reappeared so I rolled back once again on 1.10.

Dell, make up your mind with 1.11.2!   😄

Reply
Highlighted
MusicisLyfe
1 Copper

Re: XPS 15 9570 is really slow after update to BIOS 1.11.2

i am having the same issue except mt processor seems to be caped at a max speed 0f .80 when i stress test using the intel extreme tuning  utility and the GPU performance is horrid. Total waste of money im unable to record audio as i have foreign noise on my recorded tracks. Already had too send it in cause the 4k touchscreen stopped working have not even owned it for 6months problem after problem after problem after problem  !

Reply