s-plus
2 Iron

Re: XPS 15 9570 Keyboard Skipping Keys

It must have been Windows updating the Intel graphics driver, and that made it re-enable the panel self refresh.

It would be good if Dell issues the BIOS fix soon, so we don't have to think about this...

0 Kudos
Tho MY
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

On my 9570, disable panel self refresh does not fix the problem. The self refresh is already disabled from day one due to screen will dim itself if switch to dark background and back to white page, very annoying for web development work.

After updating to bios 1.3.0 it is much better, but it still happens occasionally.

As a Web/SQL developer, i do a lot of typing, the skipping keys still happen but a lot less after the bios update. 

0 Kudos
Highlighted
Moderator
Moderator

Re: XPS 15 9570 Keyboard Skipping Keys

Changes to new updated list below:

-XPS 15 9570 status update

-Latitude 7390 2 in 1 added

-XPS 13 9360 added

-New BIOS for Inspiron 13 5379 to solve a 'random key added' issue

Resolved:

XPS 9550 1.7.0 Improved keyboard typing experience with high typing speed.

XPS 9560 1.9.4 Prevent ghost key trigger while pressing multiple keys at the same time.

Precision 5510 1.7.0 Improved keyboard typing experience with high typing speed.

Precision 5520 1.9.4 Prevent ghost key trigger while pressing multiple keys at the same time.

XPS 13 9370 - Fix introduced in BIOS 1.3.3 and carried over to latest 1.4.0

Latitude 5289 - 1.13.0  - Fixed keyboard trigger abnormal when press multiple keys at the same time

Latitude 5290 - 1.3.2 Fixed keyboard trigger abnormal when press multiple keys at the same time.

Latitude 5490 - 1.3.2 Fixed keyboard trigger abnormal when press multiple keys at the same time.

Latitude 5590 - 1.3.2 Fixed keyboard trigger abnormal when press multiple keys at the same time.

Latitude 7290 - 1.4.1 Fixed keyboard trigger abnormal when press multiple keys at the same time.

Latitude 7390 - 1.4.1 Fixed keyboard trigger abnormal when press multiple keys at the same time.

Latitude 7490 - 1.4.1 Fixed keyboard trigger abnormal when press multiple keys at the same time.

In progress:

XPS 13 9350 - Dell is working to spread the fix to this model

XPS 13 9360 - Dell engineering is looking to spread the fix out to a broad list of systems, 9360 included

XPS 13 9365 - Dell engineering has committed to a BIOS update. New ETA to come soon

XPS 15 9570 - New BIOS with fix ETA for end of August

Precision 5530 - Dell engineering is looking to spread the same fix from other models to Precision 5530

Inspiron 13 5379 - The Inspiron 5379 was confirmed to have a different issue of adding random letters - resolved in 1.10.0

Latitude 7390 2 in 1 - Dell engineering is looking to spread the fix out to a broad list of systems including the Latitude 7390 2 in 1

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


Splainte
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Hi,

Same issue here on my XPS 9570 4K.

I noticed that it is particularly obvious when you press the same key rapidly over and over again like that : AAAAAAAAAAAAAA there is only 14 "A", but I swear I press "A" 20 times... 😕

I'm running on the latest BIOS, latest Windows Version...

Please Dell, do something, this is incredibly annoying.

 

0 Kudos
Abhi221211
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

I am facing the same issue, even after updating the bios

0 Kudos
uncle_hacky
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Received my 9570 on 8/8/18 and immediately noticed a problem with the keyboard skipping. Also it just crashed today... contemplating a return.

0 Kudos
Splainte
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Hi !

Good news.

I just updated my Nvidia Drivers... And it seems that it has fixed the issue...
My keyboard works just perfectly fine now !

Abhi221211
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Try this - 

  1. Right-click on the Desktop, and select Intel® Graphics Settings

  2. Click on Power to access the Power Section

  3. Under Power section uncheck the Panel Self-Refresh to disable it.

I did those steps then rebooted and I have not seen an issue since.

Tags (2)
Yoshifizzle
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Justin,

I have the same problem on my XPS 15 9530.  Will it be covered in the August BIOS update?

-Mark

0 Kudos
Abhi221211
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Try this - 

  1. Right-click on the Desktop, and select Intel® Graphics Settings

  2. Click on Power to access the Power Section

  3. Under Power section uncheck the Panel Self-Refresh to disable it.

I did those steps then rebooted and I have not seen an issue since.

0 Kudos