Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

Hi !

Good news.

I just updated my Nvidia Drivers... And it seems that it has fixed the issue...
My keyboard works just perfectly fine now !

Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

Try this - 

  1. Right-click on the Desktop, and select Intel® Graphics Settings

  2. Click on Power to access the Power Section

  3. Under Power section uncheck the Panel Self-Refresh to disable it.

I did those steps then rebooted and I have not seen an issue since.

1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

Same problem. Thought I was just not typing well.  

Highlighted
2 Bronze

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

Has any one tried the latest intel driver for the 630?  Dells Support assist will complain about it being the wrong computer, so just get the latest driver In device manager.  I have installed it and it seems better, the only thing I have lost is the Intel UHD graphics control panel.

Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

My brand new XPS 15 9570 is also having this big problem with keyboard skipping, it's nearly un-usable. When is the BIOS update coming? Seriously thinking of returning this Dell and buying another brand.

UPDATE: Just tried disabling the Intel Graphics 'Panel Self Refresh' option as some people here have suggested and this has made a huge difference, keyboard no longer skipping typing. Looks like an inter-operability bug between the Intel driverset and the Dell keyboard is in play here.

Highlighted
2 Bronze

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

just rolled back the intel driver, and got the wife to test the keyboard, she is a touch typist and does not even have to look at the keyboard when typing.  She could not find a problem, and I must say typing this not one key was skipped!  Could someone else try updating the 630 driver, & then roll back to see if they get the same result? 

Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

on this the 'Panel Self Refresh' option in the Intel Graphics settings seems to turn itself back on following reboot - I guess it reverts to the profile, causing the keyboard issue to come back. Switching it off again fixes it, probably need to save the new Profile.

Highlighted
2 Bronze

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

The Dell Support told me now that the product engineering team is working on the keyboard problem. There will be a new BIOS Version after October 2018. Pretty late but hopefully it will be fixed with that update. Dell calls the Problem: "Intermittent key presses not recognized when typing".

 

And they said to me that they are also working on a new version of the realtek audio driver because I had problems with that. I had sometimes an Audio Crackling issue. then I had to disable the realtek audio driver and enable it again to have a clear sound again. Maybe this is interesting for some people here, with the same problem.

Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

Still waiting for a fix since Dell release XPS in june. It's really irritating. Hope this gets fixed one day...

Highlighted
1 Copper

Re: XPS 15 9570 Keyboard Skipping Keys

Jump to solution

This is my first day using my XPS 15 9570, and I also ran into the keyboard skipping glitch, among a few other odd issues (such as the Caps Lock light staying lit; that seems to have fixed itself after my first reboot). Typing speed has nothing to do with it; even a single keypress can get missed if you pressed it during the intermittent split-second the keyboard cut out. Updating the BIOS or Win10 to the latest versions didn't fix the problem, either; I got everything on this system up to date, yet the keyboard skipping persisted.

However, after checking this thread for answers, I can confirm that this problem was remedied by disabling Panel Self Refresh in the Intel Graphics Settings. So, for those who aren't good with computers, I've made a quick guide to help you out:

1) Right-click anywhere on your desktop background.

2) You should see "Intel® Graphics Settings" in the drop-down menu. Click on that.

3) When Intel Graphics Settings finishes initializing, click on "Power" near the lower right-hand corner.

4) In the "Change Settings for the Plan" menu, you should immediately see "Panel Self Refresh". Underneath that, click on "Disable". 

5) Once it's been disabled, click on "Apply" in the lower right-hand corner.

6) Then, click on "Save Profile". You'll be asked what you want to call the profile. (I called mine "Keyboard Fix", followed by today's date.) Save the new name.

7) When you're done, close out of Intel Graphics Settings.

Now, just open up a program like WordPad or Notepad, type out a whole bunch of sentences, and see if you notice any improvements. As I've been typing out this response, I haven't been running into any problems with the keyboard cutting out anymore. So, whatever's going on with Intel's graphics program, its panel refresh seems to be doing something that's interrupting the XPS' keyboard.

Hope this helps at least some of you who are having problems! emoticon.Yes.title