Start a Discussion
2 Iron

XPS 15-9570, mouse/keyboard lag, repeating keys


I have a Dell XP 9570 i9 (HD) which I've only had for a couple of weeks. Apart from not waking from sleep which I've managed to cure I have terrible lag with my external USB keyboard and mouse. Initially I thought it might be the StarTech dock I was using but some testing has led me to believe it is a hardware/software issue with the Laptop.

The symptom is that as I type for a few seconds it will be fine and then it starts to lag and then it repeats keys. Eventually it settles down and then the issue starts again.

I have tried:

  • Keyboard plugged into a StarTech dock (I have 2 and have tried both).
  • Keyboard plugged into an old pluggable USB 2 hub which worked flawlessly for years with my old laptop.
  • Keyboard plugged directly into the Laptop - this seems to rule out the docks.
  • Two different keyboards - I have a wireless logitech at work and a wired QPad at home.
  • The StarTech dock is the USB3 one that allows 2 devices to share peripherals and display (KVM) and the other device I have attached is a small Dell PC and the keyboard works fine with that when plugged into the dock.
  • I have run Dell and Windows updates and updated everything including the BIOS (1.7.0).
  • I have disabled USB selective suspend in case it was that.
  • I have disabled Panel Self-Refresh in the Intel graphics control program as there some reports I found that suggested that as a possible culprit.

I'm not sure where else to go with this, but given that I know my docks work with other Laptops/PCs with the same keyboard(s) it MUST be related to the laptop software orhardware.

When you have access to important data a repeating delete key can be disasterous.



Labels (4)
Solution (1)

Accepted Solutions

Hey same issues here man. Disable c states in bios, disable intel speed step

View solution in original post

Community Accepted Solution
Replies (40)
2 Bronze
2 Bronze

I signed up just to say I also have this issue on two XPS 9570 my work bought and we were hoping to use these as CAD laptops but both have the same issue with key lagg, where keyboard doesnt respond when typing keys randomly and then repeating keys. The issue only occurs when docked and I have installed what seems like all available drivers and reinstalled windows several times. Im running out of ideas what the issssue is. Using Dell Dock as well so seems its not specifiiiiiic to what dock you are using. (these repeated letters are not typos' - thats what happens when you type, either nothing comes out or it repeats the keys) Keyboard is dell as well. I even ran driver fusion to find and update all drivers and still have the issue. Its quite bad really that this is happening and due to this we wont be buying more of these as we all use docking stations at my company and the only way I have found around this is to unplug the keyboard from the dock and connect directly to the laptop. I even installed the display link software as well as the driver and made no difference. tried both USB ports and still the same. Please can there be some response and update on how to fix this? all firmware drivers are installed. ran dell command update and dell support assissssst to check drivers and update and tune laptop but no luck. issue is occurring from stockkkkk dell OS image with no extra apps installed. just when docked Sorry for the long post. Rob

Hey same issues here man. Disable c states in bios, disable intel speed step

Community Accepted Solution

wow, seems to help so far! Thanks a lot! This issue was making the laptop basically worthless and all the PRO support wanted to do, was to exchange the keyboard (hahahaha, I use mainly external ...). Let's hope one day they solve the issue with activated c-states... Nevertheless, probably the last XPS laptop for me.

Same issue, XPS 9570 with i7-8750H. Issue happens with Dell WD15 dock and happend with HP Accelerator Shell eGPU. Sold the eGPU thinking it was the cause. Ugh.

Will try the C-State thing. Maybe it'll resolve other issues with docking as well.

Disabling C States worked for me too. However, that's not acceptable solution as it limits single core turbo boost and drains battery/using more power more in idle. And while I didn't really test this through I bet it makes forced Modern Standby battery drain even worse (yesterday my laptop was really hot after I put it out from my backpack). Really unacceptable and I really hope that Dell will fix this.

@IvanBernatovic- are you sure that disabling c-states affects turbo boost - I thought that was more to do with speed step/p-states? My limited understanding of c-states is that it saves power when CPU cores are idle by powering them down. I presume if c-states control is disabled the cores stay powered so whilst it affects battery life I wouldn't think it would affect performance!?

I'm also not the export on the topic but I ran some tests in ThrottleStop because I was trying to find out best settings for single and multicore workloads. Single thread tests behave differently with C-States enabled and disabled. If C-States are enabled I can get 4 Ghz for one core in single thread test (using ThrottleStop's integrated benchmark tool - TS Bench). If C-States are disabled when I run same single thread test my max frequency is the one that's set if all 6 cores are active. In my case that is 3.4 Ghz. I also noticed that with C-States enabled each core had unique frequency as opposed to disabled C-States where all cores were on exactly the same frequency. That suggests that multiplier is synced for all cores. Also, ThrottleStop author confirmed that here. I used HWINFO to monitor the frequencies.

It seems that disabling C-States not only prevent power saving features but also limits CPU's frequency when running single threaded or low-threaded workloads. While this is not a huge deal for me it's still very sad and unacceptable to be forced to disable C-States if I want usable experience when using USB mouse and keyboard.

I'm not only disappointed in Dell but also in big YouTubers out there who gave this laptop favorable reviews and only mentioned thermals as an issue while in reality this is far more bigger issue than thermal performance.

Hello, I've disabld both C state in BIOS and the Intel speed step Hoever, I am still having issus particularly with the ww and e keys either not inputting or repeating Also, attempting to capitalise either using shift usually does not input anything. Any further advice? BIOS is up to date and I've carefully cleaned the keys in questions.

And disable dgpu if your using an egpu

Top Contributor
Latest Solutions