XPS

Last reply by 12-08-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
119648

XPS 15-9570, not using Nvidia GPU, BIOS related bug

I'am having exactly this problem with my XPS 9570 laptop with Nvidia GTX 1050 Ti. Currently, I am playing Witcher 3. The problem is that the game starts running using the onboard GPU (Intel UHD Graphics 630). The only way I can force the laptop to use NVIDIA GPU, is to use XTU (Intel Software) and run a Stress Test on the CPU. When the CPU reaches 140°F, then the GPU starts working, fps increase to normal ranges. I've been searching on the web for solutions to this, and I have tried everything: updating drivers, uninstall drivers with DDU and install Dells drivers for my GPU and CPU graphic processors, selecting the High Performance GPU on the Panel Control of Nvidia, right click - run with - high processor GPU, etc. I do now see a bit of hope knowing that this is a known problem by the community. Anyone experiencing the same?

Replies (30)
11308

1-Aug-2018 ????

OMG !!!

11185

@AnonymousTechnical Support

I have been looking for a solution for this problem for some time now and I appreciate that Dell acknowledges the problem, works on it and even tries to provide a date when the problem will be fixed.

As for delivery delays, knowing how complex software development can become, I'd rather wait another week and be sure that the fix does not create new problems somewhere else.

11157

Maybe they have no idea how solve it...

11150

Issue is still ongoing. Made an account here just to get some support as dell doesen't want to be reached.

11148

Seconded on that notion. These laptops aren't cheap and to see such an carelessness from dell is frankly sickening.

11114

Hi,

You mean Aug 1st, 2019 or Jan 8th, 2019?

It certainly is not a minor issue, why does it take you so long?

2 Bronze
2 Bronze
11107

Have you tried sliding the WINDOWS (not Nvidia, etc) power slider all the way over to the right? I know it sounds ridiculous, but I was having the exact same symptoms, and could only play Fortnite at 10FPS because Task Manager showed only the Intel GPU was activating. When I tried all the things you did and gave up, I forgot about the slider, readjusted and and boom! Nvidia GPU kicked into life every time!

I agree it's a bug, but it could be a work around (I can now play fortnite at an acceptable FPS).

P.S. I'm still on Bios 1.3 because of all the fan issues reported with later bios versions

11351

After updating BIOS to 1.7 the issue remains. Nothing changed and my previous comment remains in effect. I would like to rant a lot and give Dell people a piece of my mind.

11292

Here's 1.7

@Raidoloom,

Send me a PM with your service tag and we'll work together on it.

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


11289

@DELL-Justin C The GPU max 74°C issue was not fixed... 

Latest Solutions
Top Contributor