XPS

Last reply by 12-08-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
119484

XPS 15-9570, not using Nvidia GPU, BIOS related bug

I'am having exactly this problem with my XPS 9570 laptop with Nvidia GTX 1050 Ti. Currently, I am playing Witcher 3. The problem is that the game starts running using the onboard GPU (Intel UHD Graphics 630). The only way I can force the laptop to use NVIDIA GPU, is to use XTU (Intel Software) and run a Stress Test on the CPU. When the CPU reaches 140°F, then the GPU starts working, fps increase to normal ranges. I've been searching on the web for solutions to this, and I have tried everything: updating drivers, uninstall drivers with DDU and install Dells drivers for my GPU and CPU graphic processors, selecting the High Performance GPU on the Panel Control of Nvidia, right click - run with - high processor GPU, etc. I do now see a bit of hope knowing that this is a known problem by the community. Anyone experiencing the same?

Replies (30)
95840

Hi,

I bought a Inspiron G3 15-3590 and had the same problem, luckily it came with bios 1.8.0, this is how I solved it.

I went to: Device Manager > Display Adapters. Right click on Intel Integrated Graphics > Disable device.

For my Inspiron, this setup will define Nvidia as default, but you can always enable Intel graphics again.

 

XPS 15-9570 users =
1. Update the BIOS to 1.15.1
2. After reboot, install the Dell Intel Chipset driver 10.1.17541.8066   and reboot
3. Install the Dell Intel GPU driver 26.20.100.7262 and reboot
4. Install the Dell Nvidia driver 26.21.14.4145 and reboot

<ADMIN NOTE: Broken link has been removed from this post by Dell>

Hope this helps all the way from Brazil.

Latest Solutions
Top Contributor