XPS

Last reply by 02-08-2020 Unsolved
Start a Discussion
3 Argentum
72551

XPS 15-9570, performance has tanked

Hi Alan,

I have been troubleshooting poor performance on an XPS 9570 without much luck the past 2 weeks. Drops of up to 80% performance in games (from 150fps to 15-30fps) V-sync does not fix the issue, makes it worse. Terrible performance with Adobe video editing applications. 

To answer your questions:

a) Yes exact same games, same Adobe applications.

b) AC power

c) Updated to windows 1803  (I believe this is could be the problem!) :Hmm:

d) Updated to BIOS 1.3.1 for XPS 9570 (again possibly the problem!) :Hmm:

e) Yes, I've tweaked everything to maximum and set all apps to use Nvidia GPU.

f) No faults detected. I tested with the recovery image and then updates (from Dell site) no change.

Also

I wiped the laptop back to the factory image from the recovery partition. This didn't fix anything... even with the old drivers. It was working fine when I first received the laptop, had no performance problems. The fact this is no longer the case with the original factory image is puzzling! I suspect the recent BIOS update is the issue.

Other issues include, videos stuttering for the first few seconds or when the cursor is moved. Videos not up-scaling correctly on YouTube (You can see a pixel-like grid on 1080p and lower) When you move the cursor in full screen videos appear smoother and up-scaled. When the cursor and play-bar dissapears videos lag for a few seconds and you can then see a grid/rough edges as the videos aren't up-scaling.  

Lastly both the Intel and Nvidia GPU are under load at the exact same time under the performance monitor. The GPU switching might be broken, causing all these issues. I re-installed the Intel Thermal Dynamic Platform driver and even rolled it back, but had no luck.

For the laptop to suddenly drop in performance by 5x is beyond thermal throttling. The only other explanation I can think of is a hardware fault if not the BIOS or Windows update. A number of people have reported these faults over the past few weeks.

Please send this to the system engineers/software devs so we can get this fixed ASAP!

Replies (66)
11209

Bump @Dell-Alan D

11061

I am having the very same issues as OP on my 9570, is there a fix out there?

2 Bronze
2 Bronze
10406

I'm having the same problem. And no one from dell is responding, that's just sad.

3 Argentum
20159

Hi all,

This is indeed BIOS related. It is a very strange GPU temperature bug from 1.3.1 onwards - causing performance issues under 48 degrees. Yes, completely ridiculous! See the recent article below - it also confirms my experience running the Unigine benchmark from other posts. Hopefully Dell will finally fix it now the issue is growing...

https://www.notebookcheck.net/Some-Dell-XPS-15-9570-laptops-may-have-a-BIOS-related-GPU-bug.355026.0...

Soooo, in the meantime run the laptop "not too hot, not too cold - just right" (seriously DELL FIX IT!)

1_62sGHvOE0c2_fIKYTqX7LQ 

 

2 Bronze
2 Bronze
11372

Hello everyone,

I got a Dell XPS 15 9570, just 5 months back in june/july. And until the first week of November, it was working great.

One day while running benchmark tests I noticed the multicore performance was very low. Upon checking the task manager, my processor utilization wouldn't go above 60-70%. In multicore applications, once my processor utilization went above 35-40% my clock speeds would drop down to 1.5-1.7Ghz and never increased causing slow applications and task execution.

I reset my computer twice(once without and once with deleting the files) but to no avail.
My cooling policy is set to active but my fans are just not running maybe dell changed the cooling policy in the BIOS 1.5.0 update. But on testing the ESAT BIOS testing utility my computer was working fine and in its processor stress tests my fans were running properly.
Running the performance test section in the custom diagnostics of the dell support assist application detects no errors but Cinebench R15, as well as User Benchmark, show the problem(results below).

Test Results:
1) User Benchmark:
                                a) Overall this PC is performing below expectations (26th percentile). This means that out of 100 PCs with exactly the same components, 74 performed better. The overall PC percentile is the average of each of its individual components. Use the charts in the benchmark sections of this report to identify problem areas.
                               

                                b) Processor: With a good single core score, this CPU can easily handle the majority of general computing tasks. Additionally, this processor can handle very light workstation and even some very light server workloads. Finally, with a gaming score of 57.6%, this CPUs suitability for 3D gaming is above average.
                                Actual Results:
                                Intel Core i7-8750H
                                 36,282 User benchmarks, average bench 84%
                                 U3E1, 1 CPU, 6 cores, 12 threads, 
                                 Base clock 2.2 GHz, turbo 2.5 GHz (avg) ~ the turbo average look at that
                                 Performing way below expectations (10th percentile bench 56%):
                                 Single core score: SC Int 116, SC Float 124, SC Mixed 122, 97% 121 Pts ~ Single core is ok
                                 Quad-core score: QC Int 417, QC Float 258, QC Mixed 223, 68% 299 Pts~ Look at this
                                 Multi-core score: MC Int 288, MC Float 324, MC Mixed 306, 46% 306 Pts ~ Look at this

                         c) SSD: 97.9% is a very good SSD score. This drive is suitable for moderate workstation use, it will facilitate fast boots, responsive applications and ensure minimum IO wait times.

                          d) RAM: 16GB is enough RAM to run any version of Windows and it's more than sufficient for nearly all games. 16GB also allows for very large file and system caches, software development and batch photo editing/processing(RAM slowdown has also occurred due to slow multicore speeds

Earlier the overall score always used to be always above the 93rd percentile

2) Cinebench:
On battery(max performance mode): 348
Power cable plugged in(max performance): 395(just a slight increase)Screenshot_2.png

 

 

 

As quoted on https://www.notebookcheck.net/The-XPS-15-9570-with-i7-8750H-CPU-is-almost-twice-as-fast-as-its-prede... the score should be around 1050 points, not 390 which is pathetic

Cinebench is a multicore benchmark test still my processor utilization would not go above 60%. It hit 100% first and then in an instant dropped down to 55% and stabilized there. Also look at the clock speeds this is on max load

On reading this dell community forum query on this link: https://www.dell.com/community/Laptops-General-Read-Only/XPS-9550-Always-Slow-Performance-again-the-...
It says that the motherboard has to be replaced. But I am not at the USA right now I'm in another country at the moment and will be here till the next August because of my work demands and unfortunately, I don't have international warranty.

What should I do? I cannot afford to spend on another laptop as my config already cost me $1500. Anyone who can provide any valuable suggestions and solutions please help as this is my brand new laptop.

Note: On running single core tasks the results are just as good as before it gives the same max clock speeds of above 3.6Ghz

11371

9937

BUMP - FIX IT!

 

@Dell-Alan D

9847

Seriously, I run an XPS 15 9560 with the GTX 1040... I frequently use this laptop playing HOTS or Fortnite. With no issue.

At first, it was very frustrating. It throttled at the worst times and often below 50c. I searched much like all of you did.

Eventually Dell will fix it, but in the mean time you must take action into your own hands and at your own risk.

You can disable the software service that is responsible. I have done so at my own risk and have had no problems.

Every time I post about it on these forums; however, it gets removed as "spam"

With some research you can figure out what to disable at your own risk.

Good luck.

9613

What is the software service to disable?

 

I just upgraded from BIOS 1.5.0 to 1.6.0 which came out a few days ago. Will begin testing to see if it continues to stutter during anything, even watching a youtube video and nothing else i get random stutters and issues.

9606

Guys do not upgrade your bioses. Dell new bios releases are designed to make your laptop worthless so you'll cough up $$$$ again.  Just stay at ver 1.2.2. For people who upgraded, refund or just sell your laptops and shift to other brands.

Latest Solutions
Top Contributor