Last reply by 10-15-2021 Solved
Start a Discussion
2 Jasper
2 Jasper

XPS 17 9700 Blue Screen Error while sleeping: Thunderbolt(TM) Bus Driver to blame

I am experiencing a series of issues resulting in blue screen errors on my new XPS 17 9700 when Windows 10 is in idle sleep mode.

Previous threads I have started:

  1. 01-22-2021 12:22 PM XPS 17 9700 crashes when sleeping - Googix fingerprint to blame? 
  2. 08-21-2020 01:38 AM XPS 17 9700 Blue screen while sleeping: Thunderbolt(TM) Bus Driver to blame 
  3. ‎08-01-2020 12:49 AM XPS 17 9700 crashes when sleeping - Goodix fingerprint to blame

I bought this laptop within a month of them coming available under 6 months ago. While the Goodix fingerprint device issue has recurred for me since Dell replaced the motherboard, the workaround I identified in the first thread works for me and many other Dell laptop owners with this device.

I am now faced with a reappearance of the Thunderbolt(TM) Bus Driver causing a crash while Windows was sleeping due to a memory access violation exception not being handled. This has happened twice in the last 4 days:


As you can see in SupportAssist. Digging for a bit more information with WinDBG (MS app available from the Microsoft Store) it says this is due to a memory access violation:

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.


I do not know how to go about remedying this but will update this thread if I figure anything out.

Note on motherboard replacement:

I had hoped that this issue had disappeared after Dell replaced the motherboard. I didn't experience this crash for a few months since that was done. The motherboard was replaced due to a power circuit issue with the early batch of laptops which resulted in the battery draining pretty quickly if the laptop was under load for extended periods (video encoding, gaming etc.) This was due to the early motherboard not being able to draw full power from the 130W power supply.

Replies (25)

Clarification on my last post:

I only get devices disabled on waking the system issue when I have the external devices plugged in via the Dell Thunderbolt dock. On it's own, the laptop doesn't display this issue. It did however display the BSOD without the devices plugged in, but possibly only after it had been plugged in to the dock since booting.



Hi Steven,

It was about two weeks ago that started having this issue with my XPS17 9700 with I9.

I received the device early December 2020 and had it connected to the Dell WD19TB (130W) docking station from day one.

Until recently, I didn't have this issue before.

But recently, I opened the lid and pressed a key to wake up the PC and it wouldn't.

It was just a black screen so I thought it may have been an overnight update that had an issue.

But after that first time, it's happened everyday.

At first I thought it was turning off because it was just a black screen.

However, I noticed it was still warm and you can hear it running at times.

I would hold the power button for over 30 seconds thinking it would turn on.

But it wasn't and now I know that I was forcing it to shut down - thinking it was already turned off.

In one of the instances doing this, I noticed that signing in by fingerprint wasn't an option.

Now, I've felt that my trackpad has had issues since receiving the unit and talked briefly to support in February.

They said that I'm not using the trackpad correctly and referred me to an article.  

I tend to look for issues before calling support because it is time consuming, but this issue finally drove me to call in on 3/31.

Two hours later, the rep reinstalled drivers, bios and unchecked fastboot from sleep option. 

He said to see if the issue continues and if it does, then it's possible it an OS issue and you may need to reinstall.

With hopes that this issue was fixed, I opened the lid and tried to awaken the unit.

This time it froze on the background image, which finally helped me realize it was freezing and how I was able to find your post.







Hi @hard2kill,

I have reinstalled Windows from the SupportAssist OS recovery tool something like five or six times now since I got this laptop in June 2020 (ten months ago). Word of warning - it may not fix things if you reinstall as the Dell support engineer suggested.


My laptop has stopped crashing when sleeping for a couple of weeks now after I disabled Windows Hello devices in the biometric devices section of Device Manager: both Goodix fingerprint and Windows Hello Face Software Device. Right click them and select disable device. I have to type my PIN to unlock but that's an inconvenience I'm prepared to live with to have a laptop which doesn't crash when sleeping.

device manager.png

Thoughts / Rant:

The first line guys who answer calls and respond to posts in this forum have a limited set of trouble shooting steps to follow and the Microsoft/Dell/3rd party ecosystem is just inherently complicated and tedious to trouble shoot. I'm not ignoring the massive improvements in the ecosystem over the years and the good will of Dell staff to try and fix things but like how often do you see here in the community: "oh yeah I called up Dell and the guy totally fixed the issue"?

Every time I've reinstalled Windows on this mid 2020 XPS 17 it has been due to either this thunderbolt issue or the fingerprint reader issue I have posted about previously and my growing frustration that coding projects I'm working on with a team of other people get messed up, or that I come back to my laptop from taking a break to join a meeting to find it's crashed to a recovery screen. I'm so frustrated by the flakiness of this ecosystem. It's infuriating. This laptop is my daily driver and I can't afford the additional time suck.  

The last time I went through this cycle started about six weeks ago. I take a day or two reinstalling updating and so on to get back to an up-to-date vanilla install (following the recovery tool sequence of steps it guides you through). After that its fine for a while until one day the crashes start to occur again on a daily basis.

This time I got the impression that things start to go wrong once windows issues a major patch to the OS through the standard update process. I can't confirm this but I can't think of what else changed that went from stable system to crashing once a day. My guess is that there is some kind of config change which results in these devices no longer being able to work right with the power management in Windows but its just a hunch.

The only positive in all this is that I've learnt a bit about recovering Docker container state (used in my dev work) after such crashes.


Hi @Steven Pavett

Thanks for the detailed instructions on avoiding this.

But for a top tier unit, this is unacceptable!

I really like this 9700, but it seems like they cut corners.

In my previous XPS 15's, I rarely had any issues.

The only major issue was an BIOS update that created and issue about two years ago.

I'm also frustrated by the flakiness of this ecosystem because I've lose work due to it crashing overnight.

This is also my my daily driver and can't waste time troubleshooting an issue such as this.

But this crashing has caused me to lose work that wasn't saved.


Another week on and I'm still happy that this workaround has prevented the crashes I was previously experiencing.

I know that the next version of Windows is meant to include some changes to the Hello features - like being able to switch between built in and external cameras. I'll no doubt have a go at reenabling these devices then or if I notice that the Goodix device gets an update via Dell.

At the end of the day I didn't buy this laptop because it had a fingerprint reader or face recognition but I do miss the convenience now I have disabled them. 


@Steven Pavett 

Thanks for the update.

I notice this issue only happens when either plugged into docking station or USB-C power brick overnight.

If not plugged in, it doesn't happen.

I spoke with DELL support again about this issue and they suggested replacing the motherboard.

It sounds like you did that a few months ago and it didn't resolve the issue.

Is that correct?


Hi @hard2kill i did have a motherboard replacement in sept 2020. I’ve had these reboot issues since then. I also use the 180w dell thunderbolt usb c dock for desk setup with external monitor speakers webcam and usb mic and I haven’t noticed a specific issue with it. The motherboard change was because I noticed the battery draining quite significantly even when plugged in. This was possibly related to a fault in the early batch of motherboards not being able to draw the full 130w from the standard power supply. 

i still get strange charging behaviour like sometimes I notice the charge has dropped below 100% even when plugged in and not doing much. It also does things like drops to 95% as soon as I unplug then jumps back to 100%when plugged in. I can keep doing back and forth which just seems wrong but apparently it’s by design as part of the way Dell tries to prolong battery life. Seems flakey to me but I usually have 95% when I unplug so again I live with it.

for me the disabling of the biometric devices still remains the only way to avoid the bsod while the laptop is idle. One thing you might find is that the smart sleep is the issue. When on external power the device doesn’t seem to really fully sleep. Like I can come back to mine and find it warm enough for the fans to be running after leaving it plugged in over night. I enabled hibernate for closing my lid because I don’t trust the smart sleep to not do something stupid like run software while the thing is in my bag.

i can’t comment on if the motherboard change will help you It may well help but as I’ve said before the dell support process is a bit blunt when it comes to fixing specific user issues and it’s just that is the next thing on their list to suggest.


@Steven Pavett 

Since this issue just started in the last 6 weeks, I'm hesitant on replacing the motherboard. 

This unit was built late November 2020.


I have been having similar issues. This hits home. Your issue in relation to the screen blacking out with the fans running; the computer refusing to boot unless forced to reset; random blue screen errors; two days ago my trackpad just stopped working; and don`t get me started on the random reboots when the laptop is docked. Even the whole fingerprint and face scanner thing, I can live without it but the fact that its not working as advertised rubs me the wrong way. And in support with the comment you made after this, the reason why I opted for a mid-top tier laptop such as the XPS17 is to avoid downtime. I legit have no time to do resets, redownload all applications, all that *sugar* takes at least two days.

Early on this year I had to factory reset the laptop cause of the fingerprint/face scanner not working. yes my laptop is fully updated, yes I have reinstalled and installed the latest drivers. I have not contacted the support team cause I don`t want to factory reset my laptop and it not solve anything (based on peoples experiences). I just want the bloodclaat machine to work!


I am also having an issue with the machine running hot at a black screen with the caps lock light on.  This has been going on for a month, and it has to be an update that occured recently, as someone on Reddit was having the same issues.  The machine will boot up and want to check the ram, but its ok.   Everything in the laptop is stock.  I have reloaded, rolled back various drivers, tried the fingerprint fix, etc.  It seems that a bios update or setting is causing something here.

Latest Solutions
Top Contributor