XPS

2 Bronze

XPS 17 Can't enter the BIOS or shut down

Hello,

My XPS-17 was fine but today once I power on the fan works at full speed, the screen is completelly black, and I can't even enter the BIOS with F2.

I have the same problem (the thread is closed and I can't post there) that Tad Minor comment in this thread: https://www.dell.com/community/Laptops-General/XPS-17-won-t-shut-down/td-p/3787412

My battery dead years ago and I use the laptop always with the power cord. Anyway I have followed the DELL Harish R instructions:

1. Release flee power from the system. Shut the system down, remove Battery and AC Adapter. Press and hold down the power button for 15 to 20 secs. Now connect the Battery and AC Adapter and start the system. Now check if the shutdown option works fine.

but when I turn it on, the same things happend: fan full speed, black screen, no keyword response even holding the power button down for 10 seconds... I can only power off removing the AC adapter cord.

I can neither follow 2 and 3 options:

2. You can Load/Reset BIOS defaults. Shut the system down, restart and keep tapping 'F2' key. This will show the BIOS screen. Select Load/Reset defaults and restart the system.

3. If the previous options wont work, you can try updating the latest BIOS. You can download the latest BIOS from the following link:

Because I can't enter the in the BIOS with F2.

Any help would be very appreciated.

Thanks in advance.

 

Labels (1)
Replies (10)
6 Gallium

:BigSmile:

Just making sure you're performing the F2 key correctly....

Power on system, quickly start tapping the F2 key continuously until you see the BIOS setup

Pease don't wait for a few seconds to start tapping, soon as you power on, quickly start tapping.... 

 

Yes, I hit repeteadly F2 as soon as I press the power button but I can't enter in the BIOS. No "beep" sound when you hit too many times the F2 and you enter the BIOS.

The 3 tactil icons that are at the right of the power button that lights secuencially as soon as you press the power button, are not lightening neither.

The F12 to run diagnostics doesn't work neither.

I've tried removing the HDs because I read in other post that doing this could solve the problem but nothing.

I've tried to use a USB keyboard to press the F2 there, but no success.

I don't know what to do.

Any other ideas?

Please list exact Dell model number and version of windows.  Example:  Dell XPS 17 L701X, windows 7

If you don't know, enter the service tag number onto the link below.

Support | Dell US

You should see the exact Dell model number in your Dell Product Support page. If you don't know service tag number, click on the link below.

How to find Dell Service Tag (Official Dell Tech Support)  

Yes, is is a XPS 17 L702X, Windows 10

Any ideas?.

Could be a BIOS corrupted problem although I have never updated it?.

Could be a solution to remove the button battery of the CMOS?... If so, any video tutorial of doing it?

Thanks


@Ukidtat0wrote:

Any ideas?.

Could be a BIOS corrupted problem although I have never updated it?.

Could be a solution to remove the button battery of the CMOS?... If so, any video tutorial of doing it?

Thanks


I'd first try reseating or removing memory / ram to see if it will make any difference. Faulty ram could cause the use of the F2 or F12 keys to not function. Please read Service Manual thoroughly in link below before opening computer case and removing memory.

Support for XPS 17 L702X | Manuals & documents | Dell US

And check out the video in link below:

Dell XPS 17 (L702X) RAM Memory Replacement Video Tutorial Teardown

https://youtu.be/EqfAPEWn3WQ

I also suggest using a can air blower to clean out any debris or dust that might have accumulated around the vents and inside the computer.  

 

If reseating memory / ram doesn't fix the problem, I suggest reseating the Keyboard cable to see if that will trigger the F2 and F12 keys to work normally. Please check video in link below.The keyboard cable is in clear view around the 1:15 mark in video.

Dell XPS 15 (L502X) Keyboard How-To Video Tutorial

https://youtu.be/mi9JAX0GiRw

Lastly, 

If none of the above steps work, replace the coin cell battery with a new one. You can purchase a new battery at your local Walmart, dollar store, online or any other retail store for about $1.00 - $5.00.

CR2032 Batteries - Walmart.com

After purchasing a new coin cell (CR2032)battery....

1. Power off system. Remove AC adapter and all peripherals such as a printer, flash drive, external drive, USB mouse or speakers.

2. Remove main battery from battery bay 

3. Locate old coin cell battery and then remove it.

4. Press the power button for at least 10 seconds to drain all residual power from the system

5. Replace new coin cell battery. Assemble the unit and verify functionality

Note: When the system is powered on, it will warn that the date and time is not set, indicating a successful reset

 

 

Just in case you need it. 

Dell XPS 15 (L502X) CMOS Battery How-To Video Tutorial.

https://youtu.be/RpSPuAusVA4

Top Contributor
Latest Solutions