slamoureux
1 Copper

Re: XPS 9370 Display and keyboard automatic brightness (and timeout)

The Dell Command | Configure app did the trick! Its got a lot of other useful settings you can edit too.

0 Kudos
Warloe
1 Copper

Re: XPS 9370 Display and keyboard automatic brightness (and

Yes,  even I had recently faced with this issue , to remove the  Dynamic Brightness Control and keyboard backlit issue , follow this link ( https://www.dell.com/support/article/us/en/19/sln143038/access-uefi-bios-system-setup-from-windows-o... ) and open UEFI setting and in it you will find the keyboard and DBC features, disable or change it how ever you want it. Don't worry you can always restore the settings . 

This worked for me. Now I'm a happy guy

0 Kudos
Highlighted
DonFin
1 Copper

Re: XPS 9370 Display and keyboard automatic brightness (and

Firmware version 1.4.0 introduced settings for the timeout of the keyboard backlight. After changing the value in the BIOS, the backlight does not turn off immediately on my XPS 13 2018 under Ubuntu 18.04. I didn't measure the time, but I think it correctly uses the values set in the BIOS now.

0 Kudos
Acersupport
1 Copper

Re: XPS 9370 Display and keyboard automatic brightness (and

I guess Turn-On & Turn-Off Keypad Backlight in Dell laptop must be same for all laptops. So here is a video  Turn-On & Turn-Off Keypad Backlight in Dell

0 Kudos
jawad.csedu
1 Copper

Re: XPS 9370 Display and keyboard automatic brightness (and

I faced the same issue after purchasing the XPS 13 9370 a few months ago. I saw that my keyboard backlight turned off after just 15 seconds if I didn't press any key or use the trackpad. I contacted Dell support and they tried to solve this from windows settings but that didn't work. Then they took two days of time from me. They contacted me after three days and told me to "upgrade" my BIOS to 0.1.7.3. I did it and then I could then set my keyboard timeout duration from my BIOS. "Upgrading" to BIOS 0.1.7.3 solved the problem for me. BTW, it is worth mentioning that in the previous version of BIOS, from which I "upgraded", did not allow to set the keyboard timeout from the BIOS settings. Unfortunately, I do not remember which version my BIOS was in before I "upgraded" to 0.1.7.3.

I found out later that BIOS 0.1.7.3, that they made me upgrade to was not the latest one available at that time. The latest one available was 0.1.8.1. So even though my "update" was actually a downgrade, I am still sticking with this version of BIOS because, well, I found nothing else to solve this problem.

Note: BIOS 0.1.7.3 has been working fine BTW.

0 Kudos