aditKumar
1 Nickel

XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

Hi. I wish to disable wakeup from mouse as it keeps waking up my computer from sleep. However it is said that this setting is under the "power management" tab in device manager and I cannot find this tab on my windows 10 installation.

Am I missing a driver ?

0 Kudos
16 Replies
Saltgrass
4 Ruthenium

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

I am going to assume the 9370 uses modern standby.  If that is not correct, please advise

If that is the case, some devices no longer have power management tabs since the system needs to have control of those devices.  I have no experience with a Bluetooth mouse in this situation but my Pen can turn the display on so I assume your mouse does that also.  The Bluetooth does stay active when in a low power mode.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
perpetoom
2 Iron

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

 

Open Device Manager, browse for the Bluetooth section, expand it and search for your chip manufacturer device (probably Qualcomm in case of XPS 9370). Right click on it and select Properties. In the window that will pop up go to Power Management tab and there should be checkbox that allow to enable/disable "wake up" feature for connected peripherals.

0 Kudos
aditKumar
1 Nickel

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

Thanks. In the bluetooth adapter settings however there is a power management tab but the setting is not selectable. I have attached a picture.

Capture

0 Kudos
Saltgrass
4 Ruthenium

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

Maybe check the mouse for a wake ability option..  If there is no Power tab is there an Advanced Tab?

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
aditKumar
1 Nickel

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

Nope. No advanced tab either in mouse settings.

This is driving me nuts and it is basically rendering the sleep function unusable to carry this laptop around. It has to be a windows  or driver issue because I get the correct behavior in linux.

0 Kudos
Highlighted
perpetoom
2 Iron

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

I've tried on mine and I confirm this issue. Notebook is waking up after I manually put it into sleep mode or when close the lid. Any bluetooth mouse movement turn the device back on (even if the lid is closed). This happens on Dell's preinstalled Windows so... this is not probably caused by some drivers/software or settings that end user applies.

This situation is extremely dangerous to the device. When I pack your laptop into bag/sleeve/backpack and move the mouse at least a little bit (not always intentionally) it will wake up and drain the battery or cook up inside the case (ventilation holes are covered, closed screen decreases air circulation capabilities).

Background info: XPS 13 9370 / i7 / FHD / Windows 10 with latest updates applied / current BIOS 1.0.2 / all BIOS diagnostics tests are passing

aditKumar
1 Nickel

Re: XPS 9370 missing "power management tab" to disable wake from bluetooth mouse

What you describe is exactly what I'm trying to avoid as I often carry my laptop in sleep mode. Come on Dell please provide us all drivers for the 9370.

0 Kudos
R0CKnR0LLA
1 Copper

Re: XPS 9370 missing "power management tab" to dis

Exactly the same issue here, as described above. My workaround is to use hibernation, but I'd rather use sleep.. Any ideas?

Re: XPS 9370 missing "power management tab" to dis

I've run into similar problems while using Linux on 9370. After 5hr of sleep battery dropped from 98% to 73%.
After some investigation and reading it appears that by default my system was suspending into Suspend-to-Idle (s2idle) mode - which according to [https://www.kernel.org/doc/Documentation/power/states.txt] is just extended form of CPU idle mode with most devices powered off, but any of them can still wake up your device. This happened to me, while my XPS was in a sleeve - so after a while it was burning hot.I've just forced my system to go into "deep" sleep instead of s2idle and hopefully tomorrow morning I'll observe minimal or no battery drainage.
P.S. I've OEM Windows on this machine, but I'm not working on it so by far I wasn't able to confirm sleep behaviour on W10.
0 Kudos