Last reply by 01-31-2023 Unsolved
Start a Discussion
1 Amber
1 Amber

XPS 9370 not starting/booting

Dell Thunderbolt Dock TB16


It all started with me wanting to upgrade firmware on the TB16. I was not able to do so because of "ASmedia USB 3.0  host controller firmware failed" warning for which I found a suggested solution to change TB permissions in BIOS. I have changed only the settings under points 2.5 and 2.6 here. 

After the exit from the UEFI/BIOS, the laptop restarted and after a while I have gottent two amber one white flashing lights (CPU error). After several unsuccessful restarts I went ahead and unplugged & plugged back the battery. This have gotten me to the point where I get a solid white light (battery charging) but while the machine is running I do not get anything from it (except extreme heat). 

Later I tried the procedure again but also unplugging the CMOS battery/capacitor, tried pressing F2 at the startup, nothing.

Any ideas what elso to do? Do you think that it is really faulty CPU or did I somehow brick my motherboard?

The machine was running win11 and it is of the following spec: i7-8550u, 16gb, 512gb, 4k

Thank you and best regards


Edit: I tried the BIOS recovery with the method described here. However, while the laptop does turn on when ESC+CTRL are pressed and I plug in the power cable, nothing happens afterwards (tried holding the two keys for more than 30s after the laptop turns ON).

Reply (1)


Click the Get Help Now icon on this thread for assistance from a Dell Agent.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

Latest Solutions
Top Contributor