Highlighted
Cheiz
1 Nickel

XPS 9380 FHD 13: JPEG-like artifacts on LCD

 

I have just bought the XPS 13 9380 with FHD screen, and I am experiences some LCD glitches. I am wondering if it's a general issue with this model or that my laptop is broken. It concerns JPEG-like artifacts, especially visible around black font on a grey or white background. See example below. The effect is quite subtle and I didn't notice it at first. But now I know it I see it all the time and it bother me a lot. On the right you see a zoomed screen capture, so this is how it should look also when small. On the left you see a picture I made with my phone. You see that there are blocks which are a bit lighter/are blue, for example: the bottom part of the first "g"  and "o" is a bit white, around the tips of the first "v" there are blue areas which shouldn't be there etc. When I use Windows Magnifier to zoom in, the effect disappears, therefore it seems to be a hardware issue. I would be really glad if other users with the same screen could confirm whether this is only my problem or a general problem. The snapshot in original (small) size can be downloaded here. You have to open it in Paint to see the unscaled, small size image, (it's not visible in the standard Photos app! You really have to click "open with" and choose Paint). In my case the effects as seen on the left photo then appear.

I am also probably going to contact consumer support but I guess that will be quite hard not having the person sitting next to me, therefore I'd like to check if other users have similar issues.

IMG_7395.jpgphoto of LCD screen using phone camera
Annotation 2019-05-09 235649.pngsoftware screen capture using snip&sketch

Labels (7)
0 Kudos
14 Replies
Community Manager
Community Manager

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

Hi Cheiz,

Thanks for posting.  Apologies that your system is not performing as expected.

From the information that you've posted, it appears that the LCD on your system is performing within factory tolerances and should not be an issue.  

Have you performed a systems diagnostics including the LCD test?  Are there any error messages?  Do the pixels appear distorted during the tests? 

Here is information from the Dell knowledge base you may find helpful:

How to Troubleshoot Display or Video Issues on Dell Laptop LCD Panel


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
Moderator
Moderator

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD


@Cheiz wrote:

 

I have just bought the XPS 13 9380 with FHD screen, and I am experiences some LCD glitches. I am wondering if it's a general issue with this model or that my laptop is broken. It concerns JPEG-like artifacts, especially visible around black font on a grey or white background. See example below. The effect is quite subtle and I didn't notice it at first. But now I know it I see it all the time and it bother me a lot. On the right you see a zoomed screen capture, so this is how it should look also when small. On the left you see a picture I made with my phone. You see that there are blocks which are a bit lighter/are blue, for example: the bottom part of the first "g"  and "o" is a bit white, around the tips of the first "v" there are blue areas which shouldn't be there etc. When I use Windows Magnifier to zoom in, the effect disappears, therefore it seems to be a hardware issue. I would be really glad if other users with the same screen could confirm whether this is only my problem or a general problem. The snapshot in original (small) size can be downloaded here. You have to open it in Paint to see the unscaled, small size image, (it's not visible in the standard Photos app! You really have to click "open with" and choose Paint). In my case the effects as seen on the left photo then appear.

I am also probably going to contact consumer support but I guess that will be quite hard not having the person sitting next to me, therefore I'd like to check if other users have similar issues.

IMG_7395.jpgphoto of LCD screen using phone camera
Annotation 2019-05-09 235649.pngsoftware screen capture using snip&sketch


@Cheiz thanks for getting in touch about this issue. Without knowing a few more details I can't tell exactly what is causing this issue but I can see the issue from the first picture you supplied.

a) First off, what applications are you seeing this issue in i.e is it specific to one application or is it multiple applications?

b) If its specific to an application or suite of applications are they Microsoft apps?

c) If you connect your laptop to an external monitor, is this issue also replicated on the external monitor?

d) Is it only text you see this issue with?

e) The artefacts that you can see, do they change position relative to the text, or do they appear regardless of the text that you have typed? (eg the line in the centre of the d is the most obvious to see, does that move or is it there regardless of lettering and text)

f) If you boot the system into the BIOS, is this fault also seen in the BIOS? (To access the BIOS power on the system and keep tapping the F2 key in rapid succession)

g) As Robert mentioned, are these artefacts seen during the LCD BIST, they will appear most prominent on the white screen part of that test. (To run the LCD BIST, hold down the Fn key and power on the system. The screen will cycle through a series of colours)

Alan

 

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

0 Kudos
Cheiz
1 Nickel

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

Dear Alan,

Thank you for your reply and acknowledging the issue  Here are my answers:


@Dell-Alan D wrote:@Cheiz thanks for getting in touch about this issue. Without knowing a few more details I can't tell exactly what is causing this issue but I can see the issue from the first picture you supplied.

a) First off, what applications are you seeing this issue in i.e is it specific to one application or is it multiple applications?

- It happens in any application as far as I can tell. I noticed it first in Chrome, then I took a screenshot in 'Snip and Sketch', then I opened it in Paint. The most important clue to me is that when I zoom in, the effect disappears, that's why I suspect it's a hardware issue.

b) If its specific to an application or suite of applications are they Microsoft apps?

- see a)

c) If you connect your laptop to an external monitor, is this issue also replicated on the external monitor?

- Unfortunately I cannot test this since I don't have a cable to connect to an external monitor

d) Is it only text you see this issue with?

- For now, yes. But I think that has to do not with text per se. Actually I found out the problem largely disappears when I disable ClearType. So I think it has to do with grey pixels being surrounded by colored pixels (with ClearType, there are some colored pixels between the grey and the black for subpixel rendering). However, I do not want to disable ClearType, and also, this just obfuscates the problem. I am pretty sure I can reproduce the effects in Paint by drawing some lines.

e) The artefacts that you can see, do they change position relative to the text, or do they appear regardless of the text that you have typed? (eg the line in the centre of the d is the most obvious to see, does that move or is it there regardless of lettering and text)

-They change relative with the text. However, they are not always in the exact same positions relative to the text, depending on the location on the screen. For example, I have made another picture at a different area of the screen. You can see that the effects now appear at different positions, for example in the "o" at the left-bottom

IMG_7399.jpg

f) If you boot the system into the BIOS, is this fault also seen in the BIOS? (To access the BIOS power on the system and keep tapping the F2 key in rapid succession)

I don't see it in the BIOS itself. However, the BIOS runs at lower resolution so it looks a bit blurry anyway. And the BIOS does not use subpixel rendering I guess, so not the color combinations where the problem seems to occur.

g) As Robert mentioned, are these artefacts seen during the LCD BIST, they will appear most prominent on the white screen part of that test. (To run the LCD BIST, hold down the Fn key and power on the system. The screen will cycle through a series of colours)

No, I don't see any artifacts there, the colors look completely solid and uniform. However, I do see another artifact when performing a test using SupportAssist, when displaying vertical color bars. In some color transitions (esp. the one below) I see vertical lines around the transition. I don't know whether this issue is related:
IMG_7397.JPG

Alan

 


I would be very curious if these issues can be reproduced on other 9380's. Unfortunately I do not have access to another one. If these issues appear on all 9380's then apparently they fall "within the factory tolerances", as Robert suggested. That, however, would be a huge disappointment to me, although I know I am looking at details, these details matter to me when I buy a €1000+ laptop, especially one that is considered to be (one of) the best ultrabook(s) on the market.

I hope to hear from you soon.

Best,
Gijs Leegwater

0 Kudos
Cheiz
1 Nickel

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

If the last 2 images are not visible, they can be found here and here.

0 Kudos
Moderator
Moderator

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD


@Cheiz wrote:

Dear Alan,

Thank you for your reply and acknowledging the issue  Here are my answers:


@Dell-Alan D wrote:@Cheiz thanks for getting in touch about this issue. Without knowing a few more details I can't tell exactly what is causing this issue but I can see the issue from the first picture you supplied.

a) First off, what applications are you seeing this issue in i.e is it specific to one application or is it multiple applications?

- It happens in any application as far as I can tell. I noticed it first in Chrome, then I took a screenshot in 'Snip and Sketch', then I opened it in Paint. The most important clue to me is that when I zoom in, the effect disappears, that's why I suspect it's a hardware issue.

b) If its specific to an application or suite of applications are they Microsoft apps?

- see a)

c) If you connect your laptop to an external monitor, is this issue also replicated on the external monitor?

- Unfortunately I cannot test this since I don't have a cable to connect to an external monitor

d) Is it only text you see this issue with?

- For now, yes. But I think that has to do not with text per se. Actually I found out the problem largely disappears when I disable ClearType. So I think it has to do with grey pixels being surrounded by colored pixels (with ClearType, there are some colored pixels between the grey and the black for subpixel rendering). However, I do not want to disable ClearType, and also, this just obfuscates the problem. I am pretty sure I can reproduce the effects in Paint by drawing some lines.

e) The artefacts that you can see, do they change position relative to the text, or do they appear regardless of the text that you have typed? (eg the line in the centre of the d is the most obvious to see, does that move or is it there regardless of lettering and text)

-They change relative with the text. However, they are not always in the exact same positions relative to the text, depending on the location on the screen. For example, I have made another picture at a different area of the screen. You can see that the effects now appear at different positions, for example in the "o" at the left-bottom

IMG_7399.jpg

f) If you boot the system into the BIOS, is this fault also seen in the BIOS? (To access the BIOS power on the system and keep tapping the F2 key in rapid succession)

I don't see it in the BIOS itself. However, the BIOS runs at lower resolution so it looks a bit blurry anyway. And the BIOS does not use subpixel rendering I guess, so not the color combinations where the problem seems to occur.

g) As Robert mentioned, are these artefacts seen during the LCD BIST, they will appear most prominent on the white screen part of that test. (To run the LCD BIST, hold down the Fn key and power on the system. The screen will cycle through a series of colours)

No, I don't see any artifacts there, the colors look completely solid and uniform. However, I do see another artifact when performing a test using SupportAssist, when displaying vertical color bars. In some color transitions (esp. the one below) I see vertical lines around the transition. I don't know whether this issue is related:
IMG_7397.JPG

Alan

 


I would be very curious if these issues can be reproduced on other 9380's. Unfortunately I do not have access to another one. If these issues appear on all 9380's then apparently they fall "within the factory tolerances", as Robert suggested. That, however, would be a huge disappointment to me, although I know I am looking at details, these details matter to me when I buy a €1000+ laptop, especially one that is considered to be (one of) the best ultrabook(s) on the market.

I hope to hear from you soon.

Best,
Gijs Leegwater


@Cheiz I believe you have answered your own question by confirming the issue is with ClearType. Going by everything else you have responded it does sound symptomatic of this rather than a hardware issue. As you dont want to disable it I believe the issue is with the way it has been setup. It can be changed depending on your reading style to different variations. The following 3rd party link explains how to do this - https://www.laptopmag.com/articles/adjust-cleartype-windows-10

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

0 Kudos
Cheiz
1 Nickel

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

Dear Alan,

Thank you for the reply. It has been a while, because it took me some time to make the issue more clear. I tried different ClearType settings, that didn't help. Disabling ClearType did circumvent the problem largely, but as I tried to explain before, this seems to hide the issue more than solve it. I do not want to disable ClearType, for example, if I do so it is hard to distinguished disabled (grey) from enabled (black) menu items. Anyway, I have found out some new things:

-The issue disappears when connecting to an external TV

-The issue disappears when booting in Ubuntu

I made an image in Paint where I tried to make the issue clearly visible, by creating a full-screen image at the resolution of the display (1920x1080) with a pattern where the issue seems to emerge. The image can be found here. When displaying this fullscreen at 100% zoom, in Windows 10 I see clearly lighter and darker horizontal bands appearing. I have made a picture of this:

IMG_7458.JPGhorizontal darker and lighter bands appear

As mentioned above, the effect disappears on an external TV.

Then, I created an Ubuntu USB boot disk, and opened the same image in Ubuntu, also 100% fullscreen (so the image is displayed pixel-by-pixel, as I did in Windows). Now, the artifacts disappear and there are no horizontal bands:IMG_7459.JPGno horizontal bands in UbuntuSo, it seems to be an issue with the graphics driver in Windows?

Before, I have already tried updating the graphics drivers, and also uninstalling them altogether and let Windows use standard drivers. Unfortunately, in both cases the effects did not disappear.

Then there is the separate issue of the vertical lines in the color bands. This effect also disappeared on the external TV. I have not tested this in Ubuntu yet.

I am also still very curious if this is a problem on all XPS 9380 FHD's, and not only mine. If you know of a way to get access to one (I live in Amsterdam), please let me know. If I come across one running Windows, I will definitely open the relevant pictures to see if the effect appears.

I would still very much like this problem to be acknowledged and solved, since I am still bothered by the artifacts when using the laptop.

Best, Gijs

0 Kudos
Moderator
Moderator

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD


@Cheiz wrote:

Dear Alan,

Thank you for the reply. It has been a while, because it took me some time to make the issue more clear. I tried different ClearType settings, that didn't help. Disabling ClearType did circumvent the problem largely, but as I tried to explain before, this seems to hide the issue more than solve it. I do not want to disable ClearType, for example, if I do so it is hard to distinguished disabled (grey) from enabled (black) menu items. Anyway, I have found out some new things:

-The issue disappears when connecting to an external TV

-The issue disappears when booting in Ubuntu

I made an image in Paint where I tried to make the issue clearly visible, by creating a full-screen image at the resolution of the display (1920x1080) with a pattern where the issue seems to emerge. The image can be found here. When displaying this fullscreen at 100% zoom, in Windows 10 I see clearly lighter and darker horizontal bands appearing. I have made a picture of this:

IMG_7458.JPGhorizontal darker and lighter bands appear

As mentioned above, the effect disappears on an external TV.

Then, I created an Ubuntu USB boot disk, and opened the same image in Ubuntu, also 100% fullscreen (so the image is displayed pixel-by-pixel, as I did in Windows). Now, the artifacts disappear and there are no horizontal bands:IMG_7459.JPGno horizontal bands in UbuntuSo, it seems to be an issue with the graphics driver in Windows?

Before, I have already tried updating the graphics drivers, and also uninstalling them altogether and let Windows use standard drivers. Unfortunately, in both cases the effects did not disappear.

Then there is the separate issue of the vertical lines in the color bands. This effect also disappeared on the external TV. I have not tested this in Ubuntu yet.

I am also still very curious if this is a problem on all XPS 9380 FHD's, and not only mine. If you know of a way to get access to one (I live in Amsterdam), please let me know. If I come across one running Windows, I will definitely open the relevant pictures to see if the effect appears.

I would still very much like this problem to be acknowledged and solved, since I am still bothered by the artifacts when using the laptop.

Best, Gijs


@Cheiz I believe there are 2 separate issues here that need to be discussed, the lines and the single pixel that appear during the LCD BIST are the first, the second is the jpeg like artifacts.

For the first issue, those fine lines and the single pixel appearing in the LCD BIST shouldn't happen, therefore I would like to get the screen replaced on the laptop for you. I will drop you a private message to get your service tag details etc from you. That should resolve those issues for you , however, I don't believe it will resolve the main issue caused you to get in touch in the first place.

For the second issue, as it's not seen on an external monitor that would suggest it's a problem with the FHD screen, however the same image looks perfect in Ubuntu. This confirms that the issue is not hardware related and is either to do with Windows itself or the graphics drivers. I personally think this is a Windows issue rather than the graphics.

As previously mentioned, you commented that disabling Clear Type does improve it however you don't want to use it because it makes other text harder to read. That then becomes a problem with how your eyes interprets text and colours issue rather than a technical issue and I don't see there being a real solution for you. 

Do you have this problem on any other laptop running Windows 10?

I wondering if it's a resolution related issue as it looked fine on your TV - what resolution is your TV running?

Have you tried changing your Windows resolution settings?
Additionally, within the Windows resolution settings have you tried changing the scaling settings to see how it affects the issue?

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

0 Kudos
Cheiz
1 Nickel

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

Dear Alan,

Thank you for your reply. See answers below after the arrows ----->



@Cheiz I believe there are 2 separate issues here that need to be discussed, the lines and the single pixel that appear during the LCD BIST are the first, the second is the jpeg like artifacts.

For the first issue, those fine lines and the single pixel appearing in the LCD BIST shouldn't happen, therefore I would like to get the screen replaced on the laptop for you. I will drop you a private message to get your service tag details etc from you. That should resolve those issues for you , however, I don't believe it will resolve the main issue caused you to get in touch in the first place.

-----> Thank you for this. I don't know what you mean with "single pixel appearing", maybe you are mixing my case up with another? It would be nice if replacing the display removes those vertical lines. On the other hand, I have not encountered this issue anywhere else except during the color bar test. I have now also tested it in Ubuntu (by print-screening the testscreen and opening it in Ubuntu) and there the lines also appear. This indeed confirms that the two issues are separate, since the "jpeg-artefacts" do not appear in Ubuntu. Before replacing my LCD screen, however, I'd like to be sure that the lines do not appear on other 9380's, otherwise swapping the display probably won't help. Also, I care about the other problem much more, since I encounter it all the time when using the laptop daily.

---

For the second issue, as it's not seen on an external monitor that would suggest it's a problem with the FHD screen, however the same image looks perfect in Ubuntu. This confirms that the issue is not hardware related and is either to do with Windows itself or the graphics drivers. I personally think this is a Windows issue rather than the graphics.

As previously mentioned, you commented that disabling Clear Type does improve it however you don't want to use it because it makes other text harder to read. That then becomes a problem with how your eyes interprets text and colours issue rather than a technical issue and I don't see there being a real solution for you. 

-----> To make it a bit more clear I have now made a video showing the issue, see here. I want to reiterate that ClearType does not seem to be the cause of the problem. Also, I showed the issue to a friend of mine, asking "do you notice anything that's not good" and he immediately noticed it, so it does not seem to be a particulr problem of my perception and my eyes. I can now also confirm that it seems to be an issue with the Intel drivers (in combination with this particular computer), since I have again tried uninstalling them, and when I manage to activate the "Microsoft Basic Display Adapter" instead (which is quite a hassle, since Windows automatically wants to install the Intel UHD 620 drivers again), the problem disappears!!! However, using this driver is not really a solution, since it disables all hardware acceleration, and I cannot even change the brightness anymore. I have tested, manually, many of the older Intel drivers (26.xxx, 25.xxx, 15.xxx AKA 24.xxx) for the 620 UHD. Unfortunately, the problem reappears with all the Intel drivers, and the artifacts only disappear when using the default Microsoft driver (to be clear, ClearType then also works perfectly).

---

Do you have this problem on any other laptop running Windows 10?

---> I haven't had access to another Windows 10 laptop in the meantime. If I will, I will try, but my guess is it is a specific problem of the Dell XPS FHD in combination with Intel UHD 620 graphics.

---

I wondering if it's a resolution related issue as it looked fine on your TV - what resolution is your TV running?

---> As shown in the video, both the Dell display and the TV are running at Full HD, 1920x1080, so the pixels on the screen match the pixels of the picture when displayed at 100% scale.

---

Have you tried changing your Windows resolution settings?

---> Yes, I have selected many other resolutions. The issue appears only when the pixels are mapped 1-1 to the display (so at full HD resolution, or any other resolution with setting 'center screen' instead of scaling). But this isn't surprising, otherwise the pixels are scaled using interpolation, everything becomes a bit blurry, so probably the specific colors where the problem occurs disappear. Of course, I want to use the display at its full, native resolution, not some lower, blurry, scaled resolution.

---

Additionally, within the Windows resolution settings have you tried changing the scaling settings to see how it affects the issue?

---> Yes, I have changed the scaling to 100% instead of 150%. This did not solve the problem.

Alan


Also, I may have found another user with the same problem, who has reported this on the Intel support forum. See here. Still it would help me a lot to see if the problem occurs on any other 9380 FHD 13 inch (maybe also earlier XPS's?).

Since the default Microsoft driver is pretty useless apart from fixing this single issue, I still want this problem to be solved.

Best,
Gijs Leegwater

0 Kudos
Cheiz
1 Nickel

Re: XPS 9380 FHD 13: JPEG-like artifacts on LCD

Regarding the vertical lines in the color bars... I have found out this lines are actually there in the PNG file I got from the screen capture. So it just seems the test pattern has these vertical lines in them, maybe SupportAssist uses a compressed image. So this issue can be ignored, and should definitely not be a reason to swap my LCD screen!
0 Kudos