wu000168
1 Copper

XPS 9530 BIOS Update Utility Does Not Run (No UI, No Error)

Every time I try to run the updater, I get the elevated permission request and it only shows up in task manager for 2 seconds before it quits with no UI or error message.

Note that I have a modified A09 BIOS, Windows 10 Build 18362.86, and a BCM94352Z wifi card instead of the original one, but none has been an issue previously.

0 Kudos
4 Replies
wu000168
1 Copper

Re: XPS 9530 BIOS Update Utility Does Not Run (No UI, No Error)

The update runs successfully on DOS.

0 Kudos
Moderator
Moderator

Re: XPS 9530 BIOS Update Utility Does Not Run (No UI, No Error)

@wu000168,

There may be a 3rd party service preventing the run. What happens if you boot to safe mode and run from there?

If it runs from safe mode then you'll need to launch MSCONFIG and eliminate or manage your startup services. 

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


0 Kudos
wu000168
1 Copper

Re: XPS 9530 BIOS Update Utility Does Not Run (No UI, No Error)

It doesn't run in safe mode either. Same behavior

0 Kudos
Highlighted
Moderator
Moderator

Re: XPS 9530 BIOS Update Utility Does Not Run (No UI, No Error)

@wu000168,

Understood. You may also try:

1. Running the package in compatibility mode

2. Starting the program VIA 'run as administrator'

3. Try running an SFC /scannow from elevated command prompt and see if that fixes any Windows problems. If so, then try the program again

That's the best I got for you. If these things don't help then it's a Windows issue that is beyond my scope to find. 

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


0 Kudos