Last reply by 10-05-2019 Solved
Start a Discussion

XPS 9570 window displacement problems

With some applications not open to full screen but in a window, a sort of visual blockage occurs in the movement and resize animation. Precisely dragging some applications in the window area of ​​the screen at a certain point the window stops but the mouse cursor continues, when I release the left mouse button the window appears at that point. Always the same applications have another anomalous visual behavior: when I click on the corner of the window with the mouse cursor to resize it, it slides down and adjusts while enlarging it happens the same thing as before, ie the window remains the same size while the cursor moves, when I release the click the window appears suddenly enlarged in the position where the cursor arrived. Some examples of applications where this occurs are the Intel graphics panel; the QuickLook and Affinity Photo display windows, to name a few.
I think it's due to the scaled 4K display resolution.
This problem has been confirmed for some time with various versions of Intel graphics drivers including the latter from August.
Does anyone know exactly what is due?

Replies (5)

Microsoft has resolved the issue with cumulative update "KB4517211" dated 09/27/2019 for "Windows 10 May 2019 Update"!

Community Accepted Solution

Someone who owns an XPS 9570 like me, obviously with a 4K touch screen, finds this strange anomaly ??

I have a Logitech BT mouse and the drivers are up to date, as far as the touchpad is concerned I do not find any available updates.

But the strange thing is, why only with certain open applications?

Here I make a list of those with which the problem arises:

Intel graphics panel; Intel Raid Storage Settings Panel; Affinity Photo; Affinity Designer; Dell Power Manager.

The rest, including windows explorer windows and settings windows work properly!

After many tests with video drivers, settings for adjusting graphics performance and updating the panel, deactivating tactile inputs and pen, etc. The problem remains. But I discovered one thing, it all happens with the touchpad and the mouse, while it does not occur using the touchscreen of the screen! Dragging and resizing the windows of such applications with the touchscreen all works smoothly.

What can this strange behavior depend on?

The Intel video drivers are updated to the latest August release of support, namely:


I tried to disable the automatic panel update in the settings, but with no results.

The strange thing is that with the explorer windows and many programs used it works regularly, in others the problem occurs. And it does it both with an electrical network and with a battery.

I put a link to the video I shot about it to make the problem look better.


Top Contributor
Latest Solutions