XPS

Last reply by 09-05-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
1049

XPS15 unable to see XP PC on network

My Dell XPS15 is unable to see another computer on my network. It's a Samsung NC10 running Windows XP. It is visible from another W10 Pro PC - a Chillblast desktop professionally built.

I have checked that the three options in Windows Features - SMB 1.0/CIFS File Sharing Support has all three entries enabled. SMB Direct is disabled.

These are the same entries as on my Chillblast W10 Pro PC. The Samsung is visible on that but not on the Dell. The only difference is the Chillblast is connected via ethernet to the router whereas the Dell is via wi-fi.

I have exhausted my knowledge trying to find a solution to this annoying problem. I can ping the Samsung and the response is fine. So why can't it be seen on my Dell XPS15?

Any help appreciated.

Solution (1)

Accepted Solutions
3 Zinc
1031

Windows Networking has been messed up for a couple of years. Sometimes you can see systems and sometimes you can't. Try this.

1. Make sure the startup settings for the following services on the Dell are set at automatic. (Reboot if you make any changes)

- Function Discovery Provider Host

- Function Discovery Resource Publication

- SSDP Discovery

- UPnP Device Host

2. In Windows File Explorer on your Dell, click on "Network" in the Navigation pane and in the address bar enter the name of your XP system preceded by \\ (such as  \\MYXPSYSTEM). Se if it then shows.

JohnD

 

View solution in original post

Replies (7)
3 Zinc
1032

Windows Networking has been messed up for a couple of years. Sometimes you can see systems and sometimes you can't. Try this.

1. Make sure the startup settings for the following services on the Dell are set at automatic. (Reboot if you make any changes)

- Function Discovery Provider Host

- Function Discovery Resource Publication

- SSDP Discovery

- UPnP Device Host

2. In Windows File Explorer on your Dell, click on "Network" in the Navigation pane and in the address bar enter the name of your XP system preceded by \\ (such as  \\MYXPSYSTEM). Se if it then shows.

JohnD

 

2 Bronze
2 Bronze
1025

Thanks John. I had searched for solutions and have those services running but the last two are manual. I’ll try them as automatic.

I can confirm that if I enter \\192.168.1.144 the shared folders are then shown. So why on earth Windows won’t show the computer without doing this is baffling. But on my W10 desktop it shows it without the above action. Same OS, same build number. You couldn’t make it up.

1016

As I mentioned. I have been battling this for a couple of years. Usually I have no problem, but every once in a while I can't get one of mine to recognize another. It seems to happen with my older desktop dropping another computer. Sometimes if one goes to sleep this will happen. If I use the computer name in the File Explorer Network address bar I can bring it back. It has something to do with the "master browser" losing it. I have assigned my router to be the master browser. That seemed to help but it still isn't 100% foolproof. You might want to give that a try if your router has that capability.

JohnD

1014


@Ray Proudfoot wrote:

I can confirm that if I enter \\192.168.1.144 the shared folders are then shown. 


Good.

Then entering \\COMPUTER-NAME should also work.

On your little Windows Peer-To-Peer network ... The Browse-Master machine assignment and/or it's machine-list might not be complete, but that doesn't mean the machine or it's shares are offline.

If it's that big a deal ... try a fixed-IP, router-reservation, and/or leaving machine on.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
1006

@johnptd 

I wouldn’t know how to make my BT Smart Hub 2 my master browser. I’m UK based. Now that I have a means of accessing the computer it’s not really an issue any longer. I only need occasional access. Thanks for your help.

@Tesla1856 the PC is left on all the time as it’s connected to a weather station. It seems to have changed after swapping from a TP-Link Archer VR2800 to a BT router as part of a FTTP package.

A fixed IP address is worth trying but as I said to John I do have a way of accessing it. Thank you both for your help. Bloody Windows eh?

7 Plutonium
962

@Ray Proudfoot  The behavior you’re seeing isn’t entirely “bloody Windows” with “messed up networking”. The original Network Neighborhood discovery that you’re discussing and that dates back to Windows 95 was achieved with some ancient, inefficient, and insecure protocols, including SMBv1, which Microsoft now very strongly recommends against enabling because it does represent a security liability. That has since been deprecated, and network discovery on newer Windows versions now occurs using a newer protocol that runs over IPv6 — but Windows XP didn’t have IPv6 installed by default, and even if you install it manually, I’m not sure it supports this specific newer discovery protocol. I would really recommend that you rely on accessing your XP host by directly typing its UNC path so that you can disable SMBv1 again on your new system. But then again you’re also still running XP on your network even though it hasn’t received updates for about 7 years now, so maybe SMBv1 isn’t your biggest problem from a security perspective.


960

@jphughan , I appreciate your concern but I consider this a very low level security risk. I live alone, am computer savvy and don’t visit dodgy websites or click on links in email unless I’m sure of the sender. Of course if there was a concerted attack I’d be in trouble but the chances are negligible.

My weather website has been visited from interested parties from countries all over the world including some dodgy ones. Despite that I feel the risk is low.

Latest Solutions
Top Contributor