Start a Conversation



44 Posts


March 14th, 2018 09:00

OME 2.4 no longer discovers any system updates, after installing OMSA and enabling SNMP

A few days ago, I set up OME 2.4 for a customer. It is for monitoring 8 x R640 and 2 x R730xd servers.

Initially I just configured discovery by IDrac/WS-MAN. This worked splendidly and OME gave me a nice list of about 5 available updates for each server on the “non-compliant systems” tab.

But as far as I know and as far as I can tell, OME cannot discover missing or outdated drives through IDrac/WS-MAN. For this, OMSA is needed on the servers and SNMP must be enabled for discovery in OME.

So I installed OMSA 9.1 on one of the R640 servers, including configuring the Windows SNMP Service on the server. The server is running Windows Server 2016.

Following this, I completely deleted the discovery range in OME and recreated it with a modified IP-range to include not only the IDrac IP-addresses and to allow SNMP configuration.

I performed a full discovery and inventory. The result looks good in Devices. Everything was discovered.

All the servers without OMSA look the same in system update: About 5 updates are presented. But for the server with OMSA, there are no longer presented any updates at all in OME System Update. Very strange…

I tried the Troubleshooting tool that comes with OME to verify the SNMP protocol. Running the tool on the OME machine verified easily that SNMP works by reporting basic OMSA component versions from the server with OMSA. In addition, the three items in the “data sources” list for the server in OME all show the green symbol.

So why can OME no longer see any updates?

In addition: The “issues and resolutions for Updates” tab under system update in OME reports this:


44 Posts

March 14th, 2018 13:00

Hm. The screenshot from OME seems not to work unless I am logged in to forum. It says this:


Inventory collector is not installed on this server. In band updates cannot be applied.


Schedule inventory collection task. Recommended to schedule periodic inventory collection.


But I have definitely installed OMSA. And I have run the inventory manually several times.

March 15th, 2018 10:00

I faced the same issue with OME 2.3.X and 2.4.  I had upgraded to OME 2.4 in hopes that it would resolve the issue, but unfortunately not.  The affected system was a PowerEdge R515 -Windows 2012 R2 - OMSA 9.1.  It turns out I had to uninstall OMSA 9.1 on the affected system and install OMSA 8.5 to get the complaint status back in OME.  Apparently, OME does not play nicely with Inventory Collector 17.12.000 (included in OMSA 9.1) but likes 17.03.200 (included in OMSA 8.5).

On a side note, I have two PowerEdge R620 - Windows 2012 R2 - OMSA 9.1 that work just fine with OME.  Maybe having the system updated with OS Collector 2.1 has something to do with that, I'm unsure.  I also have a new PowerEdge R740xd with the same symptoms, it has Windows 2016 installed so I need OMSA 9.1 installed (with OMSA 8.5 I lose storage in the GUI).  In this case it has OS Collector 3.0 installed (probably another incompatibility).

Try going with OMSA 8.5 and do another Discovery and Inventory in OME, with my R515 it returned good after a few minutes.  If that doesn't work, check the support downloads for an update for the OS Collector for those chassis.  Some have it, some don't from what I have learned.

Hope this helps.

EDIT: BTW, I am using SNMP for discovery on all systems, I haven't tried WS-MAN for iDRAC discovery on the R740xd yet (which I probably will have to).  If your systems have iDRACs, you could try that as well.

44 Posts

March 16th, 2018 07:00

Thank you for this!

I will try out OMSA 8.5 with my R640.

What is “an update for the OS Collector for those chassis”? Can I find that on the website?

Using just iDRAC with WS-MAN basically works fine on newer systems. At least 13G and 14G. But you do not get any info on missing or outdated drivers and we need that.

I will let you know how it goes.

March 16th, 2018 08:00

Glad to help,

From here:


I don't know if this has anything to do with OME detection, put it's worth trying if it's not up-to-date.  I'd try OMSA 8.5 first since on my other newer chassis with OS COLLECTOR 3.0 it wasn't being detected either.

March 16th, 2018 08:00

Apparently I was wrong with my assumption with the OS Collector, the description says it all...

OS COLLECTOR 3.1 is designed to supplement the iDRAC hardware state and configuration data with the host's operating system state & configuration information data as well as the system event logs. 

So give OMSA 8.5 a try and see where that goes.


March 20th, 2018 04:00

Hi all,

In OMSA 9.1, the component that provides software inventory to OME, is disabled by default. It has to be first enabled on each one of your targets by using Sample - Enable Inventory Collector task under Remote Tasks section and then refresh inventory.

With this extra step, the problem should get resolved while working with OMSA 9.1.

Let us know if this helps.

March 20th, 2018 07:00

Thanks, that fixed the detection for 9.1

If anybody is interested, the command to run manually on an affected system:

omconfig system invcol action=enable


28 Posts

March 20th, 2018 08:00

What's the reason for disabling the inventory component in OMSA 9.1 by default?
(Generated a lot of unnecessary troubleshooting time here).

@anonymous456: Thank you for the command line to enable inventory!

(Have been searching for something like this in the "OpenManage Command Line Interface Guide v9.1 without success)

I suppose this command does the same as manually change StartupType for DSM SA Shared Services to Automatic (Delayed Start) instead of Disabled.

July 25th, 2018 06:00

Much easier, thanks, that worked a charm....

July 25th, 2018 06:00

As suggested elsewhere, use this  command on each affected client:

omconfig system invcol action=enable

No Events found!