Start a Conversation


This post is more than 5 years old



24-09-2012 09:00 AM

Dell XPS 13 (ultrabook) Trackpad problems


First of all I am really disappointed in Dell. Come on guys... you build an ultrabook with such good material, carbon fibre and etc. Go all the way through to make it light and durable and then install a trackpad that is so problematic? WHYYYY...? Don't you do any testing prior to release?!

Anyway, here is my problem. I have updated my ultrabook to the latest drivers, both touchpad and quickset and BIOS and... (everything). The touch pad (two finger scrolling, pinch zoom, 3 finger genstures..) all works. What drives me crazy is a simple "single tap click"! In random times when you click on something (single tap) it just wont click and stays the way it is until you move your finger over from where you clicked and then suddenly the click takes into effect. Its like that the single tap click is attached the the event of moving and it won't work until you move your finger (tiny bit) from where you clicked. And you cannot believe how annoying it is!

You know what? I really don't want to return this Ultrabook, as everyhting else works perfectly, and it is just shameful for the name of Dell to use such a buggy touchpad and after 4 months still not being able to programm a driver which resolves ALL the issues we are having. We all have read what other users have been through for the past 5 months until these drivers came out.

SO, hey DELL get stuff moving and develop a good driver, we all know writing a driver is sooo simple for your developers.



1 Message

25-09-2012 20:00 PM

DITTO!!!!!  I am having the same problem.  I love my XPS 13, but hate, HATE, this touch pad.  I've spent lots of time updating drivers and jacking with the setting trying to get this thning to work right.  Tap click is a nightmare on this machine and I would never recommend anyone buy one because of this problem.  My XPS draws attention and people are always saying, "Hey, cool laptop!  What is it?"  I am so frustrated with the touch pad that I can rarely tell them about the wonderful features of this computer because I am too busy telling them about the major problem with the touch pad.  Please, please, please Dell, please come up with a fix for this. I am glad Shahin posted because I thought it was just me having these problems.   I too do not want to return my computer, but wow, this is really becoming a problem. 


27-09-2012 03:00 AM


I request you to delete the touchpad drivers and then use the below link to download drivers:

To delete drivers, type device manager in search box then click Device manager, expand Mice and other pointing device, right click on Touchpad and select uninstall. Check the box that says “Delete the driver software for this device”

There is a separate thread where customers have mentioned about this and have claimed the drivers update has fixed the issue which can be viewed in the link below:

Please let us know about the progress.

29-09-2012 02:00 AM

Hi shahin67/ ayvann

The Engineering team will require the system service tag for further investigation. I request you to send a private message with your system service tag. Please accept my friend request, click on my username and click ‘Start conversation’ to send the service tag.

2 Posts

29-09-2012 06:00 AM


I contacted dell via phone and they remote connected to my XPS 13 and checked everything you can possibly think of; in the end it was not fixed. They asked to send an on-site technician to fix this issue. As this is obviously an issue with the software and not the hardware, I refused and decided to return it and get a full refund. 

If I had read all these reviews about the touch pad I would have never bought this laptop. I have decided to buy the Lenovo X1 Carbon instead.



1 Message

03-10-2012 22:00 PM

I have tried the new drives but the simple left click and the right click does not really work. It is very sporadic. It does work sometimes but not always. 

I have been a dell user for the last 12 years but this is a big dissapointment. I bought the XPS 13 for its portability and now with this issue I have to carry a bluetooth mouse every where I travel. 

I am in india now, but the support in India sucks. I had a tough time (actually I tried atleast 5 times) even getting to the support rep. on the phone. What is the point of having international warranty when it does not help?

The people who said they the trackpad is working do not use AutoCAD or any design software. Please test this on design software and you will understand the frustration. 

This is probably my last DELL product that I am buying ever.


04-10-2012 03:00 AM

Hi vamsip,

I request you to check if this issue happens only in auto cadd and other designer softwares or on all applications. If yes, then check the touch pad settings by following the steps below:

(1) Go to start

(2) Type control panel, click ‘Enter’

(3) Select Dell Touchpad properties, now go to the Touch Pad Settings section and disable all the additional features like One-Finger Scrolling, Two Finger Scrolling, etc.

Check if it works, if it doesn’t, I request you to send a private message with your system service tag. Please accept my friend request, click on my username and click ‘Start conversation’ to send the service tag. I will check on the status of the system warranty and assist you further.

3 Posts

13-12-2012 12:00 PM

I have the exact same issue with the latest driver ", A03" . The previous versions of drivers don't have the 'move finger after tap for a single click'  issue. I had to revert to an earlier version by using the Uninstall method mentioned by Kiran K. But previous version drivers have other issues. Please fix the A03 driver.

19-12-2012 11:00 AM

Hi Suneel G,

I request you to give more information about the issue with the touchpad on both older version and newer version of drivers. Let me know if you have done all the troubleshooting mentioned by me in the above posts. Also send me the system service tag through private message.

I have added you as a friend. Please accept my friend request by clicking on my name highlighted in blue and then click on “Friends” tab at the top and then click on “Request to Review” and finally click on “Accept” button.

I am sending you a private message as well. Click on “Inbox” to respond to the message and provide system’s Service Tag and contact details so I may access your system records and check for further course of action. You could also click on Start Conversation to send a private message.

3 Posts

19-12-2012 12:00 PM

Hi Kiran,

The issue with A03 driver: The tap to click fails occasionally. During the click fail, it takes my first tap as a mouse down event (think of it as clicking on something and not releasing your finger from click. I can see the color of a hyperlink change with first tap). I then have to to put my finger on trackpad and move my finger a little bit for the previous tap to work as a click (think of this as a mouse up event. The browser takes me to the URL i clicked on during the first tap with this action).  Everything else works fine in A03. Disabling trackpad features didn't fix anything. I noticed this behavior in several applications, including windows explorer, like opening folders etc.

Because of this issue I switched to A02 driver. It worked fine for a few days. Suddenly the scrolling and two finger scrolling stopped working (may be because of Windows 7 update?). So I am back to A03 now and still have the issue mentioned above. Sent my service tag in a private message to you.



8 Posts

20-12-2012 18:00 PM

I agree - the XPS 13 is a lemon - stay away from the Dell XPS 13 - it has a trackpad/touchpad that is barely useable, you have to use an external mouse with it, thus your portability is nixed.

04-01-2013 05:00 AM

the trackpad on this laptop is infuriating.

i, too, have had the issues that others have mentioned on this page (the movement during taps, the complete loss of any scrolling after windows 7 update)...and now since that windows update, i had to install the new version to get gesture scrolling back. this version has the most infuriating issue to date-

sometimes (and by sometimes, i really mean sometimes. some days i will not have the issue all day, but some days, i have this issues a few times) ALL of my trackpad inputs will lag behind by one step. what i mean is this- say i move the cursor, it will trigger my last input.


-move pointer up, no pointer movement happens on screen

-move pointer down, pointer goes up (the first movement)

-move pointer right, pointer goes down (the second movement)

-move pointer up, pointer goes right (the third movement)


sometimes this issue lasts for only a few seconds, but sometimes it lasts for multiple minutes. i cannot tell you how frustrating this issue is when it is happening.

after having so many great dell laptops (d620, e6420) being forced to use this work-issued turd is very difficult.

8 Posts

04-01-2013 06:00 AM

There is no answer from Dell that works, follow the links they have to waste your time, have the touch-pad replaced under warranty to waste more. Only use it with a mouse and tape over the touch-pad since its worthless. I gave my Dell XPS 13 to one of my kids to play with, and got a Lenovo X model as many other commentators have.

04-01-2013 14:00 PM

I am planning to get XPS 13 but after hearing about the touchpad issues, I am certainly double minded. I hope Dell folks fix this issue asap.

10-01-2013 15:00 PM

Is there an update regarding this? My XPS 13 touchpad  same issues. How about an updated driver?


Never mind, found it ... hope it works.

I just installed and quickly tested. It has a nice new interface and seems to be functioning rather well. At least much better than the previous version.

27-01-2013 17:00 PM

Foremost I can say the laptop performs with the exception of the touchpad.

The issue I have experienced with the touchpad was left click only seems to work is I move the mouse then attempt to left click (*a high failure rate like 90% of the time)

Also when scrolling long pages like facebook; if you pause while still left clicked then attempt to scroll further your left click action seems to have "expired"

Just trying the new drivers now.

So nice they made me register a new account to post here.