Start a Conversation



1 Message


April 24th, 2018 02:00

CPU Core Speed stuck at 0.80GHz Latitude e7440

Hello every one,

I try the core speed of my cpu won't exceed 0.78 Ghz. I've updated the bios to A25 check that's not the issue. Power options in the windows settings are high performance so that's not the issue either.

The core speed is the same when the PC is idle, and when I send it through stress test.

My PC specs

Intec cor i5 4310u

8Go Ram

256 SSD

windows 10

Thank you for helping





Under StressUnder Stress




1 Message

29-12-2018 14:00 PM

For me the solution was to remove the screw below the c-key, as suggested by a few people in the comments to this post (with youtube video): As an indication: I noted that the core speed would shortly increase after hitting the bottom of the laptop on the left side (i.e. in the area below the c-key).

4 Posts

24-05-2019 02:00 AM

Hello there,

Thanks for the good guide, it really save my days.....
I have been troubleshooting for 5 days, until I saw this post. 

I removed the screw underneath the keyboard, and then the CPU throttling is gone.

I'm happy!

1 Message

29-05-2019 03:00 AM

Worked perfectly. I work in a company with over 500 Dell E7440 and as the years went by did this issues start to show up and we contacted Dell. No one could give a good explanation to why some of our E7440 out of the blue started to act up and even send a service guy. He did the debugging and diagnostic and no of them gave error or reported an issue. So they concluded it was a defect motherboard or CPU. Unlucky for us had the warranty already ran out and and buying parts costed the same as a new laptop.

After long time looking did i finally came across this answer and a youtube video and i was a little.. are pulling my leg right? and i tried it and boom the CPU went up to 100% and the right clock speed like nothing was wrong.

I did notice a minor details, that was the crashes that happened afterwards. I think i solved the issue by putting a piece of tape underneath the metal plate and the motherboard. So the plate where the keyboard is attached to can't touch they motherboard.

3 Posts

13-12-2019 00:00 AM

It's bios problem. I found how to go full speed again. I go Start menu -> power -> sleep. Wait till computer sleeps. Than power up from sleep pressing power button. Thats it.

1 Message

10-01-2020 08:00 AM

I experienced the same (Latitude 7470) the CPU was at 0.79 GHz.

Processor Speed Limited to 0.79GHz / 800MHz

Following steps resolved the issue for me
* Turn the laptop off
* Disconnect the external AC power adapter from the Laptop
* Open the back cover and disconnect/remove the battery
* Reconnect the external AC power adapter to the Laptop
* Restart the computer without the battery and press F2 to enter the BIOS
* Check the speed. It will reset to its native clock speed (mine was at 3.0 GHz)
* Exit the BIOS and allow it to boot into Windows
* Turn the Laptop off
* Reconnect the battery and back cover
* Turn the Laptop on

89 Posts

14-01-2020 13:00 PM

Removing the screw under the C key worked for me. Crazy.

30-05-2020 01:00 AM

Hi there,


Go to BIOS, by pressing F2 on start up , than go to Performance, and click on +. Find Option Intel SpeedStep TM, and Disable it.

By this operation CPU will be working on highest performance. However this will for sure decrease the battery state, but will solve the issue with CPU itself.

No need for removing the screw underneath C letter, or other removal interventions. 

Problem should be investigated deeper.

26-08-2020 10:00 AM

NOPE...I've turned off Speedstep on other Dell's and it fixed the slowness issue, But not on this 7440. BIOS A28.

ThrottleStop WILL turn it on full speed, but that's a pain as it needs to be run every time.


REMOVING THE SCREW under the 'C' key worked for me, too.

You'll need  Phillips (P) and fine-tipped Flathead (F) screwdrivers or one of those Apple iphone tools - Spudger (S).

  • Shut down
  • Unplug from power
  • Remove the battery
  • Remove the 2 P screws that hold the back cover in place that are in the battery compartment's upper left and right corners
  • Remove the  2 P screws that have the K near them (they hold down the keyboard)
  • Flip over the laptop
  • CAREFULLY Pry up and Remove the trim piece around the keyboard with F or S tool - the part that has 'LATITUDE E7440' printed on it
  • Remove the 3  silver-colored metal P screws along the top of the keyboard that are now exposed
  • Carefully lift up the keyboard until the P screw under the 'C' key area is accessible
  • Remove the P screw
  • Reinstall everything in reverse order



1 Message

26-09-2020 14:00 PM

I also confirm that removing the P screen under the C key worked!

I have a 5+ year old latitude E7440 that was stuck at 0.78 GHz.   I first tried to reset the BIOS by unplugging and replugging the CMOS battery.    That didn’t work.   (btw - that initially caused my computer to brick.  (Solved thanks to

 I followed instructions from @PowderGeek and that fixed the issue.

at first my keyboard didn’t work upon reassembly.   I found that the connecting cables became unplugged while I removed and reinstalled the keyboard. They’re funky flat ribbons that snap into a connector.    I learned how to reconnect keyboard cables by consulting pics here:   Look at KeyBoard section of this link

Now my computer is fully restored!   Happy Days

Thanks to all for sharing your discoveries!

1 Message

10-10-2020 11:00 AM

Thanks @Rizanmsm - This procedure mostly worked for me with my 2016 M3800.

I took off the back cover. Then disconnected the battery and started the computer with only the power supply connected. The clock speed was still 800 megahertz in the BIOS at that point. I then turned the computer off.

I then disconnected the power and reconnected the battery. When I connected the battery the computer started making a periodic beeping sound. It looked like it was trying to power up. I pressed the power button to turn it off.

Then I reconnected the power supply and started this system. At that point everything was fine and the clock speed showed the normal speed of around 3 GHz.

4 Posts

28-11-2020 14:00 PM

The battery trick didn't work but removing the screw under the letter C did. 

1 Message

01-12-2020 02:00 AM

Yes, I confirm the screw remove fix works. My reaction was ?!?

I have 2 questions :

1. Who/how did this fix get discovered?

2. What is the screw used for?

11 Posts

01-12-2020 05:00 AM

As a laptop enthusiast, I am also extremely curious about this "C key screw" solution. 

I've read that people have done this hundreds of times.

6 Posts

16-03-2021 11:00 AM

Adding an update to this.  Increasing wattage to a power supply does not "necessarily" fix this issue.  I tested with a 130 watt power supply (thin profile) that had the same symptoms and I tested with a 90 watt power supply (thicker profile, more "brick" shaped) that did not have this issue.  I believe the problem is mitigated if the power supply has the ability to hold voltage for a few seconds after being unplugged by the wall.  This further points to a "timing issue" with whatever is detecting the voltage.  As long as the power supply doesn't drain off power too quickly you should be fine.  I would expect the permanent fix to be fixing the timing issue in the BIOS for low-voltage detection.

6 Posts

16-03-2021 11:00 AM

I believe I have tracked down an issue that is similar (at least for our location.)

Problem:  Dell Latitude 5510 is seen throttling CPU speeds to 0.40 GHz (viewed under Performance tab in Task Manager.)

Cause:  From what I've seen, I believe it has to do with the computer detecting a "low voltage" from the power supply and dropping the CPUs into a safe-mode setting of 400 MHz.

Testing:  I am testing a Dell Latitude 5510 with a 65 watt power supply.  I start with a powered off laptop.  I plug in the 65 watt adapter to the wall, then I plug it into the laptop.  I power up the laptop into Windows and go into Task Manager to observe the CPU speed.  It sometimes hovers around 4.0 GHz or so (Intel Core i5-10310U@1.70GHz).  If I then unplug the power supply from the wall (not from the computer), this causes a low-voltage detection on the computer (rather than a clean power removal) and the CPUs drop to 0.40 GHz.  From this point the laptop will stay at 0.40 GHz regardless of workload.  To get the laptop CPU to ramp up again, I plug the power supply back into the wall.  The CPUs come back up to normal speed.  Now if I unplug the power supply from the side of the laptop (clean power supply removal), the CPUs continue to function normally on battery.

Test #2:  I ran this same scenario, but used a 180 watt power supply instead and did not experience the CPU safe-mode of 0.40 GHz.

Conclusion:  I believe that the BIOS is attempting to detect low voltage from the power supply.  This detection method is slower than the power runoff from the 65 watt power supply when it is unplugged from power, but left plugged into the laptop.  When you use a larger power supply such as a 180 watt power supply, the BIOS has enough time to determine that it's not a voltage drop, but that it's actually the power supply has been unplugged from the wall.

I would assume the fix would either be to fix the voltage drop detection speed (or remove it altogether) from the BIOS or to use a larger power adapter to compensate for the slow voltage drop detection method in the BIOS.

No Events found!