Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

6 Posts

129

June 12th, 2024 10:14

U2724DE, MacBook Pro, no Thunderbolt signal, #5

I have a brand new Dell U2724DE connected to my MacBook Pro 13". Unfortunately I cannot get a signal. When I plug the cable, something happens in the background because I hear "beep" sound on my MacBook and also Dell shows "Scanning for signal", but few seconds later, "No Thunderbolt signal from your device". Thunderbolt's cable is plugged in the right port USB-C upstream port  for video + data (port also has a 90W label). MacBook get's the power, because battery is charging normally, only video signal is not going through.

I have been using Dell Ultrasharp 27" monitors for many years now. I have just upgraded from U2722DE that I have been using for the last 2 years. Before that I had U2721DE, U2719DC, U2717D... upgraded to latest model every two years. Till now there were no problems connecting to my MacBook.

My MacBook Pro 13" is 2020 model, the latest generation with Intel cpu, before they switched to Apple M1... I also have Bootcamp and it's the same story if I try to connect it from MacOS or from Windows 10 (BootCamp). But if I connect my new monitor to wife's MacBook Air (also from 2020), monitors connects without a problem (on MacOS or on Windows 10).

So far I have tried:

- different USB-C/Thunderbolt cables. Original one from Dell that has mark "4" printed on connector. Also tried same black Dell cable that was included with previous U2722DE model. Also tried original USB-C cable that was included with my MacBook. No luck with any of those cables.

- upgraded monitor's firmware to latest version (from May 2024)

- reset MacBook Pro's SMC and NVRAM/PRAM

- multiple shutdown's of MacBook and power cycles of monitor

- tried to connect MacBook Pro to original power adapter (to test if maybe monitor has issue with charging power + video signal at the same time)

I am running out of ideas and I have a bad feeling that I will not manage to get a signal at all :(

What would you recommend?

1 Rookie

 • 

6 Posts

June 13th, 2024 11:48

If someone else will have the same problem, I have spent almost the whole day finding a solution, in the end I realized that I had to plug the cable in the ports at left side of MacBook Pro. After restart of computer, everything started to work - video signal, network adapter, usb hub, charging. It works with all original Dell cables (the old one, the new one), it works from MacOS and even from Windows (BootCamp). Even if I was using right side of the ports for last 4 years with older model of UltraSharp monitors, it happens that the new one is a bit picky and only works with the ports on the left side.

(edited)

1 Rookie

 • 

6 Posts

June 12th, 2024 14:14

I the following article: https://www.dell.com/support/kbdoc/en-si/000131273/using-a-dell-ultrasharp-usb-c-monitor-with-a-mac I have seen that there is a difference between my old monitor U2722DE (DisplayPort Alt Mode) and new monitor U2724DE (Thunderbolt 4).
There is also some troubleshooting advices at the bottom of the article and it's one similar example with different monitor:

>There is no video or no display when the Mac is connected to UP2720Q.
The UP2720Q monitor ships with a Thunderbolt 3 (USB-C) Active Cable for connecting to a Thunderbolt 3 Mac computer. Using this cable with a Mac computer that only supports USB-C (with DP Alt Mode) may lead to No Video. If the user is using a Mac computer with USB-C (with DP Alt Mode) such as MacBook 2015, purchase a Thunderbolt 3 (USB-C) Passive Cable or USB-C DP Alt Mode Cable separately. Dell Part numbers for Thunderbolt 3 (USB-C) Passive Cable: A9905599, A9905597, A9269731

But the cable that was included with new monitor already is passive Thunderbolt 4 cable, and I have tried different cables (Dell's original passive Thunderbolt 4 that is included with U2724DE, Dell's original USB-C cable included with U2722DE - it's written Type C Gen2 5A on it), but none of them works.

My Macbook Pro 2020 (Intel) has four Thunderbolt 3 (USB-C) ports with support for:
- Charging
- DisplayPort
- Thunderbolt 3 (up to 40Gb/s)
- USB 3.1 Gen 2 (up to 10Gb/s)
And my wife's Macbook Air 2019 (Intel) has exactly the same two Thunderbolt 3 (USB-C) ports with support for:
- Charging
- DisplayPort
- Thunderbolt 3 (up to 40 Gb/s)
- USB 3.1 Gen 2 (up to 10 Gb/s)

So from specifications everything looks the same, except that MacBook Air get's the signal without a problem with every cable I have tried, but my MacBook Pro has no signal.
No Events found!

Top