Start a Conversation

Unsolved

G

1 Rookie

 • 

4 Posts

74

October 26th, 2023 15:50

Recover raid10 config after accidentally deleting 7/8 disks, H730p mini on a PowerEdge R630

Hi everyone! New to the server world so pleas bare with me. 

Inherited a PowerEdge R630 server with PERC H730p controller. Setup was a raid10 using all 8 sas disks. 

I attempt of backing up the physical disks (replacing each disk at one time and allowing the raid to do its job). 

This didn't work out clearly as I deleted the foreign configuration. 

Now I'm left with only 1/8 disk, online, as part of the raid10. The raid is offline. The other 7/8 disks show as ready, online and unconfigured. 

I did mark the disk location. My question is: is the a way to restore the configuration on the disks so they can be part of the same raid that is shown on the remaining working disk. 

Hopefully there is a solution to this without loosing the data. 

My next question is, of course, the best way to backup the entire virtual disk so it can be restored in any machine or virtual drive with the same or larger capacity. 

Thank you in advance.

PS I've uploaded pic of the PERC bios configuration if it helps. 

Moderator

 • 

3.1K Posts

October 26th, 2023 20:14

Hello Gazza,

 

I am sorry to see that. You may Consider Data Recovery Company if this is critical data and you do not have a backup. It may not be recoverable but anything we do could make it mor difficult or impossible for them to recover the data, if it is possible at all.

 

See if you can clear the controller configuration and import configuration from the drives, if they still have one. I have my doubts.

While turned off, Unseat all drives, then boot in to controller and clear configuration, save ,exit shut down

Insert all drives and boot to the controller to see if there is foreign configuration to import.

 

Lastly you could Perform a RETAG

RETAG refers to a troubleshooting process in which the Virtual Disk is deleted and recreate using the identical parameters (Drives, Drive Order, Stripe Size, Cache Policies, etc.). After creation do NOT initialize the Virtual Disk.

 

1 Rookie

 • 

4 Posts

October 27th, 2023 09:13

@Dell -Charles R​ 

Hi, thank you for your reply.

 

 

 

 

I did try clearing controller configuration but it brought the same results. When clearing foreign config, disks were seated. Assume it cleared config in the disks too. As far as I'm aware no initialisation has taken place so data should still be intact. Assuming RETAG should work. (With Windows pc rebuild MBR can fix lost partition. Not sure how raid works in that respect.)

 

 

 

 

I came across this proces from *ArduinoGuy*

 

***A retag is as follows (Done from the virtual disk page of PERC BIOS):

 

1. Delete the target virtual disk.

 

    -F2 on the virtual disk tog get a context menu. Arrow to delete and hit enter

 

2. Recreate said virtual disk using the same RAID level *AND* the same stripe size

 

     -F2 on the controller to get the context menu and create a new VD there.

 

3. DO NOT initialize. The initialization is what blanks out the RAID data.***

 

 

 

 

Not sure if this proces is correct or needs any extra steps. Couple of questions on this one.

 

-The parameters mentioned, especially stripe size which I'm not sure off. I took pic of system setup as I was getting familiar with the layout. Pic attached suspect indicates the correct info?? 

 

-Once raid is created, not initialised, the data would just come back on power up, assuming it works??

 

 

 

 

Data is important and could try two options. 

 

1- test/practice the theory on spare disks 

 

2- restore the raid on 7/8 disks. Maintaining the working disk as a reference 

Moderator

 • 

3K Posts

27-10-2023 10:01 AM

Hi,

 

The steps seem to be correct. Stripe size will usually be default size during creating the RAID, 64 KB. Assuming, retagging is done correctly, and all disk do not have issues, yes data will come back up. Though, you mentioned data is important, I suggest what Charles mentioned, to consider data recover company to restore data. 

 

 

DELL-Joey C

Social Media and Communities Professional

Dell Technologies | Enterprise Support Services

#IWork4Dell

Did I answer your query? Please click on ‘Mark as Accepted Answer’. ‘Thumbs up’ the posts you like!

1 Rookie

 • 

4 Posts

October 27th, 2023 14:43

Hi Joey, 

Thank you for your reply. I will Replicate the fault with some spare disks I have to confirm the process. Failure will get the data recovered before any tampering is done. 

Will update on the outcome. 

Gazza

1 Rookie

 • 

4 Posts

October 28th, 2023 15:09

Hi @Dell -Charles R @DELL-Joey C 

Thank you for your help. RETAG worked for me. I tested out the proces on some spare disks (installed Linux OS) and in both cases it worked. I cleared the configuration on both the controller and disks. By creating the same raid, it restored what was once there. 

Process followed as above. 

-Entered bios (Ctrl-R)

-Cleared any raining Config to ensure all the disks are ready. (Note config settings from original raid if available before clearing) 

-Create New VD

Old raid settings and associated disks.
New VD options
Select raid level, (mine is Raid10) name it and select physical disks in the correct order. 
(Focus on what's important and leave the typo alone 😉)
Under advance options select the correct strip element (64kb default) AND, VERY IMPORTANT ensure initialisation is deselected (OFF as default)
Once happy with selection OK the rest and Ok the greeted message indicating recovery attempt. 
Reboot and everything should go back to normal, hopefully. 
Hope this help anyone else with the same issue. 
Thank again for your support
Gazza 
No Events found!

Top