Start a Conversation


Go to Solution

1 Rookie


4 Posts


September 26th, 2023 20:24

Precision 5530 - M2 NVME not detected while installing Win11

I'am installing Windows 11 from a new and clean M.2 MVNE drive just installed.

After the initial "welcome" the setup can't find drivers to read the M.2 drive.

Any idea on exactly which driver should I download end examine so Windows 11 can see my new drive and install there?

Setup is already AHCI, no secure boot, and I'am booting Win11 to install from a USB without any issue. Biggest issue is not reading the M.2 drive. 

Hope Chino de Oro can help here!

1 Rookie


4 Posts

September 28th, 2023 06:39

I finally solved it.

I've started Dell's SupportOS Assist and if offered to install Windows 10 for me.
I accepted and then NVME drive was recognized without issue and after that I upgraded to Windows 11.

Thank you all

7 Technologist


11.7K Posts

September 26th, 2023 22:32

This YouTube video will help and the Intel RST driver can be found here. Simply copy the driver to the Windows installation USB drive. Others have had luck by trying another USB port on their systems.

5 Practitioner


3.4K Posts

September 27th, 2023 01:10

Welcome to the community,

Prior to Windows installation, you must verify if the M.2 solid state drive is shown in BIOS settings.

For Windows 11 to function optimally, you need to set BIOS to UEFI mode, enable secure boot and TPM.

And suggested to create your Windows installation USB using Windows Creation Tool.

1 Rookie


4 Posts

September 27th, 2023 12:44

Hi both! thanks for your help.

@Chino de Oro 

Some insights:

- Drive is 512 SSD from Crucial. It is detected by the bios and also tried to delete old data and partitions using GPARTED (booting on legacy mode) and did it well. Now is empty, without any partion.

I verified tthat UEFI is setup, also TPM and Secure boot are enabled

Any other idea? It seems to be the first version of Dell Precision compatible with Windows 11, I don't understand why a clean setup does not recognize the drive. I know I'am now alone on this. Readed a lot of forums.

Any other idea?

@JOcean I followed the video and nothing happens. I tried first downloading the driver from your link from Intel. Unziped on a secondary pendrive and tried to load the driver from the Windows 11 install and does not detect any driver or any hardware. Also I tried using the drivers that the youtuber is linkin from intel too. Nothing. It does not works.

Thank you guys

No Events found!