Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

1 Message

978

February 10th, 2024 17:38

isHighlyActiveTopic

Dell Support Assist won't log in.

XPS 8960

XPS 8960

I have installed the latest version of Dell Support Assist (4.0.0.51819) and it runs fine, but I cannot sign in. Logging in with my Dell account consistently prompts "We are working on signing you in" then fails with the error "We ran into a problem. Something went wrong and we couldn't load your contact information. Would you like to try again?"

1 Rookie

 • 

18 Posts

April 27th, 2024 08:42

With the very kind help from the Dell Support Team here, what worked was to uninstall Support Assist v 4.0.2 and then to reinstall again directly from the Dell Site. The version that is reinstalled is v 3.14.2.45116. This works perfectly fine. No sign in problems and all the functions run smoothly. Hope that this helps.

(edited)

1 Rookie

 • 

20 Posts

May 23rd, 2024 20:13

Error Logging into SupportAssist - SOLVED

Problem solved with not being able to log into SupportAssist:  Go to your Dell Account online (website) and log in.  Then under Account Settings on left, click on Profile Settings, next click on Edit Profile under Profile in center of page.  If you have 2-step verification set up you will need to add code sent to you via email or phone.  After logging in you will need to add your name (first & last).  Once this is done, go back to support assist and login and that's it..  It worked for me.   Hope this helps!

Community Manager

 • 

54.4K Posts

April 2nd, 2024 15:51

For the SA (SupportAssist) "won't log in" issue, contact the GHN (Get Help Now) Chat agents by clicking the blue icon on right. Provide to them your private Service Tag. 

The button is marked with a help icon for easy recognition as per the picture below: 

(edited)

1 Rookie

 • 

1 Message

February 11th, 2024 01:44

I'm also having this problem. Its frustrating especially because my support assist found problems but wont show me them until i can log in...

1 Message

February 11th, 2024 15:45

I am encountering the same issue.

1 Message

February 11th, 2024 19:26

I am also encountering same problem

1 Message

February 12th, 2024 02:35

yup and then the downside is that you can't get assistance to fix the issue without having to call and sit on hold.

1 Message

February 12th, 2024 03:52

Experiencing the same issue.

February 12th, 2024 08:52

Experiencing same issue as well.
On the website through the browser, I can login just fine with no issues. Problem happens only when logging in on the SupportAssist App. (I have downloaded the most recent update).

Also, if I type the wrong password, it immediately recognizes the password is bad. It just happens when I type in the correct credentials. And it happens exactly like it is described at the beginning of this thread.

1 Message

February 12th, 2024 20:45

Same for me as well. Maybe an update will be issued.

Moderator

 • 

16.8K Posts

February 13th, 2024 09:33

Forum Users,

Can  you all attempt the login again?  If it fails then, try again in next 24 hours and share us the results.

(edited)

1 Rookie

 • 

8 Posts

February 13th, 2024 17:13

@DELL-Jesse L​ Did and no luck. 

I have uninstalled the application and installed it again, restarted the computer, and added an exception to the firewall to make sure the app has full access to the internet. Nothing works

Moderator

 • 

16.8K Posts

February 15th, 2024 15:38

Forum Users,


Please uninstall the latest version and install the available version from Dell located here.

1 Rookie

 • 

8 Posts

February 15th, 2024 15:41

@DELL-Jesse L​, I Did install the latest version as recommended, but with not luck. The issue still persists.

(edited)

1 Message

February 18th, 2024 00:16

I'm using the Alienware version and have the same exact issues as of today (2/17/2024).  It appears that most of the features work without logging in.

No Events found!

Top