Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

9856

June 9th, 2014 04:00

Ask help to delete srdf group when the remote VMAX lost all configuration

​Hi All,​

​I haVE 2 VMAX and about 20 srdf groups created, I reimaged VMAX1 and left some stale SRDF groups at VMAX2, and after that I found that I was not able to delete SRDF group at VMAX2 for below error:​

​# symrdf removegrp -sid xyz -label test​

​Execute a Dynamic RDF Removegrp operation for​

​Group Label: 'test' on Symm: xyz (y/ ) ? y ​

​Could not find any online RDF Director connections that the RDF Group can use for the remote call​

​==================================================================================​

​W​​hat I can do to delete these stale rdf group.​

​Thanks in advance!​

213 Posts

June 9th, 2014 04:00

Hello fengli,

Welcome to EMC Community.

The above command is working as designed, what you need to do is to add (-symforce) switch at the end of the command so try this one:

# symrdf removegrp -sid xyz -label test -symforce

When symforce is used with removegrp action, it removes one side of dynamic SRDF group if the other side is not reachable like in your case,

N.B: symforce is not enabled by default, You need to change the symapi option file first and change the below option from FALSE to TRUE as shown below:

# Parameter:       SYMAPI_ALLOW_RDF_SYMFORCE#
# Allowed values: TRUE | FALSE#
# Default value:   FALSE#
# Description:     Indicates whether users can specify -symforce when
#                 performing RDF control operations.

SYMAPI_ALLOW_RDF_SYMFORCE = TRUE

Once you do this, the above command should work fine with you. No need to restart the SE daemons as this is a symapi option not a daemon option.

Hope that helps
Mohammed Salem

1 Rookie

 • 

20.4K Posts

June 9th, 2014 04:00

wasn't there a "half pair" delete command, or something of that nature ? Don't' have access to symcli to verify if that was only for symrd pairs. Worst case ask support to move it in the bin file.

June 9th, 2014 04:00

Hi Fengli,

can you still see the remote VMAX2 array? You can verify with a symcfg list.

Regards

Finbarr.

859 Posts

June 9th, 2014 05:00

use it with force and if that still does not work, contact PSE Labs

213 Posts

June 9th, 2014 06:00

only symforce is available with removegrp switch

Hope that helps

Mohammed Salem

859 Posts

June 9th, 2014 06:00

thanks for the correction

54 Posts

June 9th, 2014 18:00

Your answer works well, but I still have another problem, some of my SRDF group still have stale volume, at this situation the remove rdf group fail for error "The dynamic RDF group operation cannot be completed because the targeted group is not empty".

what operations can I do to delete the pair? I tried delete it by deletepair and failed for below error:

symrdf -sid xyz -rdfg 10 -f /tmp/l5 deletepair  -force

Execute an RDF 'Delete Pair' operation for device file

'/tmp/l5' (y/ ) ? y

An RDF 'Delete Pair' operation execution is in progress for device

file '/tmp/l5'. Please wait...

Could not find any online RDF Director connections that the RDF Group can use for the remote call

Thanks a  lot!

213 Posts

June 9th, 2014 23:00

Hi fengli,

Yes, that is correct, you will need to use half_deletepair switch instead so try the below:

symrdf -sid xxx -rdfg 10 -f /tmp/15 half_deletepair

deletepair will check the pair state from the remote array first before attempting to delete the pair, if it is stale or not reachable then you will have an error like you described above but half_deletepair will not check for this so it will allow you to delete the pair from one side (either R1 or R2) without checking the remote array.

Neither force nor symforce are needed with this command

Hope that helps

Mohammed Salem

213 Posts

June 10th, 2014 01:00

Good to hear fenglin

Thanks for contacting EMC Community....

Hope that helps

Mohammed Salem

54 Posts

June 10th, 2014 01:00

Very appreciated for your help, I had got rid all of these stale pairs and groups.

Thanks!!!

54 Posts

June 10th, 2014 01:00

Thanks all your!!

June 26th, 2014 07:00

Hi Mohammed Salem,

I have a similar situation. We had a DMX that got recently decommissioned which was the source for the SRDF replication to our target VMAX. Now there are some stale RDF groups that we need to get rid of on the VMAX. Tried the half_deletepair and it worked for the group were in "Partitioned" state. However I am not able to delete groups that are in "TransIdle" state with half_deletepair. Tried the -force with -symforce. But get an error:

"The device is not in a valid RDF state for this operation"

Is there any way to convert this group to "Partitioned" or Split state and then run the half_deletepair to remove the pairs? or any other option to half delete the pair?

Appreciate your help in advance.

213 Posts

June 26th, 2014 07:00

Kind Regards,

Mohammed Salem (EMCTAe, EMCIEe, SPEED)

Implementation Specialist

mohammed.salem@emc.com

Landline: +202 2503-2535

Cell: +201 0211 14174

1 Attachment

1 Message

October 6th, 2021 07:00

If the suspend command does not work a disable command may remedy the issue. Try adding the volumes to a text file and issue a disable command as shown below.

Example:
symrdf -sid 0083 -f filename.txt -rdfg 12 disable -force

Filename.txt
#RDF1_Volume RDF2 Volumes
00B6 009A
00B7 009B
00B8 009C
00B9 009D
00BA 009E

If from there you wish to delete the half pair you may issue the following command:

Example:
symrdf -sid 0083 -f filename.txt -rdfg 12 half_deletepair

 

Repeat the steps on the R2 side to remove the volumes

No Events found!

Top