Start a Conversation

Unsolved

This post is more than 5 years old

13847

November 17th, 2017 16:00

Unable to Bring Up Bios or Boot to USB Or Safe Mode in XPS 8930

Wondering if anyone else is having this problem, with XPS Desktops--  no responsive F2 or F12, no boot to usb or safe mode, all advanced start up options give a blank screen.   Unplugged all drives,  took out CMOS battery, still no bios.   Thanks for any help!  (so far Dell support unable to resolve)

9 Legend

 • 

87.5K Posts

November 18th, 2017 08:00

Safe mode in Windows 10 is accessed though the control panel or MSCONFIG.

As for USB boot, what OS is on the flash drive you're trying to boot?

140 Posts

November 18th, 2017 18:00

Have you installed a different video card than what shipped with your 8930?  If so, remove it and connect your monitor to the onboard graphics connector and try again.

2 Posts

November 19th, 2017 08:00

Thanks so much, this was the issue!  I did have a Dell shipped videocard, but had an HDMI monitor plugged into the port right on the computer.  Plugging a display port connection directly to the video card solved the problem (for some reason still the HDMI connection directly to the video card would not bring up Dell logo and bios options)

1 Message

January 21st, 2018 20:00

I am having a similar problem. It just started yesterday and my machine is less than a month old. When it boots up you can hear the hard drive whirrring and all but my screen remains blank and and it goes into sleep mode. A mesage comes up saying that there is no signal coming from the computer (even though that was not the case over the past several weeks). It is not responding to any touch of the keyboard or clicks of the mouse. So as far as the monitor is concerned the computer is sleeping so it also goes to sleep.

I use a DP to mini DP cable from the CPU to the monitor.

This is frustrating.

Can anyone help?

 

March 10th, 2018 07:00

I have the same configuration, mDP, and the same problem trying to interrupt the boot.  Was on phone with Dell Support for an hour because machine would not reliably come back from sleep (and still happening now). and they also said to continuously press first f2 then f12 to no avail. Support guy did not have the same machine available to him so he could not recreate the issue.  I’m wondering if this is a consequence of most boot interruptions only being allowed if you run “System Configuration” in windows 10 before restarting.

It’s very frustrating to have the screen completely blank (and going to sleep) until windows boots successfully as you can’t see what’s going on.

March 10th, 2018 08:00

I searched to see if this is a Windows 10 problem in general.  It appears that it is:

 

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10

March 10th, 2018 08:00

And the mystery deepens.  I tried the reboot methods outlined in the above link to get to the bios.  It reboots but screen is blank. So then I have to power cycle the machine to get it back.

I wonder if the driver for the (new) Dell U2417H monitor is not loaded until after a successful windows boot, therefore it remains blank?  There has got to be a work around for this. 

March 11th, 2018 21:00

Mystery solved.  Apparently there are two set of display connections.  An upper vertical set and just below it a horizontal set.  The horizontal set is primary and apparently the upper vertical is secondary and only meant to be activated when normal Windows 10 has been booted.  Plugging into the lower set allowed me to finally see the BIOS.

Dell's own documentation suggested plugging into the upper connections.  What a wild goose chase this led me on.

1 Message

August 14th, 2018 04:00

Hi, I have the same problem as you. I don't understand what you mean by this: "Plugging a display port connection directly to the video card solved the problem"? Could you explain please?

May 8th, 2019 10:00

That solved the problem for me.

9 Legend

 • 

47K Posts

May 15th, 2019 06:00

"F12" booting requires secure boot OFF.

2 Posts

June 4th, 2020 18:00

I had a similar issue, owner of an XPS 8930 and I was also with Dell Support and they could not resolve the issue of trying to get into the BIOS when I was using an ATI Radeon Card. After this unresolved issue phone call, I pulled out my ATI Card and connected the HDMI cable to my onboard Intel video and I had the display, could use F2 and F12 and resolved the issue that I was having myself. So if you face any issue trying to get into the BIOS, just remove the aftermarket video card and you will get into the BIOS and see the Dell Splash screen

2 Posts

September 25th, 2021 10:00

I have XPS8930 over 1 1/2 years. Upon start Dell logo does not appear. Therefore, cannot use F2, F12 to access BIOS and Boot menu. Never checked this functionality before. Contacted and Dell support suggested it being a software issue. Forced to buy $99 for software support. Problem remained unresolved. Got back refund and was told it was a hardware issue. Ended up paying almost another $200 for that. Sent the PC to Dell Repair Store. PC had 2TB of HD and 256 GB of SSD. Came back with 1 TB of HD only. The Dell tech never tested for Dell logo appearance and F2 & F12 functionality - all the issues remained un-resolved. Contacted Dell support again. With great difficulty the Dell Tech support allowed me to send the PC back which I did. Two days thereafter got an email from Dell repair store stating "Our repair technician is unable to process your system repair due to software, system password, or another problem that requires your assistance". It is despite the fact I had given them my login user id and pwd. First responded through email asking what they mean by system password when I already gave them user id and pwd. They called Dell Tech support and they hung up on me. As of this comment, the PC is still with Dell Store. Can you and all others who have similar problem contact me at  to plan some collective action.

No Events found!

Top