Start a Conversation

Solved!

Go to Solution

201

November 20th, 2023 13:38

Dell ThinOS Update over WMS fails - Package Root failed to install

Hello,

we just started using ThinOS Clients (Wyse 3040 & Optiplex 3000).

I´ve installed Dell WMS to manage the Thin Clients, and now I tried to Upgrade the ThinOS version from 9.3.1129 to 9.4.3087 with the help of a ThinOS 9.x Policy and the Image "ThinOS_2308_9.4.3087.pkg-V9.4.3087".

When I apply the policy the clients do download the firmware, however they always fail to install them. 

The Error Message in WMS is: Generic Audit event received from XX- Package Root failed to install

Error Message on the Client: wms: failed to install package: JSON.stringify(error)

Do you have any idea how I could troubleshoot or solve the problem?

Thank you!

3 Posts

November 29th, 2023 07:01

I have solved the problem with Dell support.

Deleting all unneeded packages from the client fixed the problem.


Apparently the USB image from Dell comes with all sorts of packages distributed by Dell, which makes it slightly cluttered.

(edited)

1 Rookie

 • 

681 Posts

November 20th, 2023 18:32

Do you get the same behavior updating both platforms?  in other words does it happen to both the 3040 and Opti3k the same way?

Are you using WMS cloud or on-prem?  If on-prem, what build?

3 Posts

November 20th, 2023 20:21

Hi,

yes it happens to both platforms.

However I´ve noticed today that clients with a firmware 9.4 or above are able to complete the update successfully. (Factory new devices with newer Firmware)

I´m using WMS on-prem with build 4.1.1.111

November 27th, 2023 15:21

We're having exactly the same issue across two separate WMS on-prem installations. 

Sometimes factory resetting the terminal has allowed the update to run, but most terminals are now 'stuck' on a particular firmware and Citrix Client app version. 

1 Message

November 28th, 2023 20:51

I'm seeing the same thing on the first couple of 3040's I've tried.  WMS is on-prem, version 4.0 526.

December 7th, 2023 12:09

I believe I've found a successful method to upgrade our terminals. In our case, this allowed terminals to upgrade to the latest release.

1. Downgrade the terminal to 3.1.3112 using the DTOS_9.1Full_9.1.3112.pkg-V9.1.3112 package.

2. Upgrade the terminal to 3.1.3129 using DTOS_9.1Full_9.1.3129.pkg-V9.1.3129 package.

After this process, I've been able to upgrade terminals to 9.4.3087 and Citrix client 23.7. 

I use a separate policy in WMS to upgrade terminals, and this is configured to wipe all the certificates from the terminals. Not sure if this is required. 

No Events found!

Top