Start a Conversation

Solved!

Go to Solution

96

February 28th, 2024 12:39

XPS 8930, possible dead motherboard

I'm fairly inexperienced when it comes to troubleshooting internal PC hardware. I think I may have a dead motherboard but I wanted to post here asking for some general troubleshooting advice. Hoping to either have what I currently know confirmed or be informed of some other ways I can troubleshoot/gather a bit more evidence that my motherboard is truly dead beyond the diagnostic light patterns the PC is giving me and the suspicious Dell support representative I talked to that rather suddenly tried to sell me on their overpriced service and parts. Maybe I am being too paranoid. To be clear I have no intention of patronizing Dell further unless I were to learn some reason why that's my only option. Which I highly doubt is the case.

I have a Dell XPS 8930. I've made a few simple upgrades to it that I figure I ought to list because it seems like this can be relevant info for troubleshooting. Upgraded the base 8 GB 2666 MHz Dell ram to 4 x 8 GB 3200 MHz from Crucial. Added an ASUS 3060, an m.2 expansion card, and mounted a Western Digital 1 TB m.2 SSD to it. Replaced the original 460 watt PSU with a 650 watt 80+ gold from Coolermaster.

Friday evening I put the PC to sleep for a moment then tried to wake it back up within a minute. Unfortunately all I managed to get out of it were 4 orange diagnostic led flashes which according to this

https://www.dell.com/support/manuals/en-us/xps-8930-desktop/xps-8930-service-manual/diagnostics?guid=guid-67f3bb39-3728-4f40-9b0c-30883adb6fc0&lang=en-us

means memory or ram failure. So I went about trying to test each stick I have individually. Only managed to get 1 stick into that testing before getting a different result of 1 to 2 orange diagnostic lights and what sounded like my PSU making a single click sound which I assume was a power protection shut off. To test again required me to flip the PSU off and on. Given that extra result and the documentation I was consulting not mentioning anything like that sound I decided to get ahold of Dell support and ran them through everything I've mentioned above. They got me to continue to test each individual stick and I kept getting the same result of one to two orange diagnostic lights and the single click sound. Once I'd gone through each stick they rather suddenly claimed that I definitely had a dead motherboard and then they proceeded to try to sell me on their overpriced service and motherboard.

I'm rather trepidatious for a couple reasons. Firstly the immediate overpriced sales pitch I got after what seems like incredibly minimal troubleshooting compared to what I've seen many other sources recommend in such a situation. Secondly that nothing I've consulted so far has acknowledged or mentioned the PSU click I've noted. Is that truly inconsequential? Is my guess as to what that sound is completely off base? I explicitly asked about that in a follow up reply in my currently open help thread with Dell's support and they responded with the absurd non answer of "Unfortunately we cannot check any non dell PSU".

From consulting other online resources the only troubleshooting I really feel like I have left to do, that I feel comfortable doing, is individually removing anything I've added, and checking the cmos battery to see if I get a different diagnostic code or possibly a power on. Trying to get solid enough info to diagnose this myself so I can avoid having to take it to a local shop who's diagnostic fee starts at $165.

Thanks to anyone who took the time to read and help.

2 Posts

February 28th, 2024 16:41

I highly appreciate everyone's replies. 

Shortly after initially posting, I came across these 2 related suggestions and was going to try them.

https://www.dell.com/community/en/conversations/xps-desktops/xps-8930-dead-motherboard/647f83eff4ccf8a8de2c4c86

https://www.dell.com/support/kbdoc/en-ca/000130691/bios-recovery-steps-for-a-no-post-issue-on-alienware-aurora-r5-r6-r7-r8-r9-r11-and-xps-8910-8920-8930-pcs

Up until early this morning, my computer has been set aside unplugged since the testing I described in my initial post. Before trying to go through all the set up described in those links I decided to try plugging my computer back in just to see if I happened to get a different result. To my excited surprise it booted up into the support assist noting a change in ram. I let it do a quick diagnostic on everything and was shortly loaded into windows with absolutely no issues. I slowly added the ram back with tests in between and I now seem to be back to a fully functioning computer. So as far as I can tell it was the ram all along. At least I sure am crossing my fingers that that's what the issue was all along.

So technically my post has been solved, but I'd still appreciate anyone's input or suggestions regarding anything I might want to be looking out for that could still be wrong or may cause similar issues in the near future. Hopefully this is paranoia that doesn't become justified in the way that my paranoia about the dell support agent was. 

Thanks again for everyone's efforts.  

(edited)

5 Practitioner

 • 

4.6K Posts

February 28th, 2024 14:41

First, replace the coin cell battery with a fresh, new CR2032 and reset CMOS with jumper.  Second, perform a power supply BIST test to ensure you have a good working power supply.  If you still have the old Dell OEM power supply, use that for testing purpose. 

To preserve components from accidental damage and perform troubleshooting with ease, remove the Asus 3060 and connecting monitor to the integrated graphics port, remove PCIe SSD adapter and boot drive, then remove all but one stick of RAM.  If you can not get system to POST, the motherboard is toasted. 

If you can get POST and accessing BIOS setup, your motherboard is still good.  You can then reintroduce each components back to detect which component is causing system to fail POST.  The issue can be resolved when a failure is determined.

(edited)

7 Technologist

 • 

10.3K Posts

February 28th, 2024 14:53

I would concur w Chino. I would normally strip the system to minimum just motherboard and one original memory and original psu to test too in a amber code, but before I try this in this situation is try first clear CMOs settings:

like chino said replace CMOs battery w a new one if you have one, if not ok too.

then use motherboard clear CMOs jumper

https://www.dell.com/support/manuals/en-us/xps-8930-desktop/xps-8930-service-manual/procedure?guid=guid-2a199221-cdfc-4dfe-b196-da786913bc78&lang=en-us

i have a hp 300 series desktop i7-8700 that more or less all of a sudden gave me amber behavior too.  I also updated ram to 4x16 Corsair a while back and they worked.  So I just pulled out all ram, put one back only like OP did, clear CMOs via motherboard jumper. Got it post then added second ram try again 

7 Technologist

 • 

10.3K Posts

February 28th, 2024 15:11

Since OP got different amber codes when ram is changed, chances are it is cmos issue rejecting memory, rather than dead motherboard or psu.  A bad psu would persistently cause one fixed amber code.  I would try clear cmos.  If that doesn’t help definitely try use one original Dell ram stick only (remove all non-Dell ram) and clear cmos again.  Good luck.

No Events found!

Top