Start a Conversation


Go to Solution


November 9th, 2019 18:00

XPS 15 9560, Alert! TPM device is not detected

Having followed these steps & those provided on the Dell support page, I'm still receiving an error during bootup "Alert! TPM device is not detected."
The TPM is not visible in the bios or Windows device manager.
Installing V2.0 firmware was not successful.
TPM Management states, "Compatible TPM cannot be found".
Bios has been updated to the current version. 

My warranty has just conveniently lapsed & not service agents are available until tomorrow.
I've even tried to pay for further support & warranty extension, but to no avail.

What now Dell?


XPS 15 9560

1 Message

February 17th, 2020 01:00

I too had this problem for a long time on several computers at work but managed to solve it.

During my quest to find a solution I tried everything but it never occurred to me that I never shut down my computer and unplugged to power cord. I have always shut it down with the power cord still in, just restarted the computer or have it gone in sleep mode. I bet most corporate do this using sleep mode or have the AC plugged in when shut down.

Well how stupid did I feel when I shut down my computer completely, unplugged it from the AC and let it be for 30 second. When I plugged in the AC again and turned on the computer the magic happened. LOL The TPM alert was gone. For some reason shutting down the computer and unplugging the AC for 30 seconds seems to do something allowing the bios to find the tpm again.

So I tried the same on a second computer and the same stupid fix worked on that one. Well in the end we did this on all the computers encountering this and the same fix applied for all of them. So after this we are now upgrading the bios on all computers and any computer getting this error is easily fixed by shutting it down, removing the AC for 30 second and then firing up again. lol

So if you havent tried this then please try it and see if it works for you. Im not saying it is the fix but worth trying

Need further assistance? Use the "Get Help Now" option at the bottom right to chat with a Dell technician right away. 



Additional Info on TPM:

7 Technologist


11.7K Posts

November 9th, 2019 19:00

3 Posts

November 9th, 2019 21:00

My error is not due to a bios update. I cannot roll it back as I have not updated it.

I will note that my bios version is listed as 10.0.18362.1 & not 1.15 as is referenced in the linked thread.

As an experiment, I just updated to 1.16 to see what would happen when I rolled back. No help. Rolled back to 10.0.18362.1

Should I be looking for a way to source 1.15?

December 19th, 2019 06:00

Same problem on my XPS 9560 with the 1.16 system bios update !! 

I Can use it but i have every Time "alerte Tpm device is not detected" at the beginning 

6 Posts

December 30th, 2019 14:00

Dell precision 5520 here... 1.16.0 had this issue and now the JUST RELEASED 1.18.0 has the same issue... ugh...

January 4th, 2020 08:00

I updated to the new 1.80 bios and I have the same issue.  Going to roll back my bios to one that did not have this issue.

2 Posts

January 8th, 2020 14:00

Not that this is an option for everyone but luckily the laptop was still under warranty and a motherboard swap did the trick for me.  TPM showed up in BIOS and works in Windows.

Best of luck.



24.7K Posts

January 11th, 2020 00:00

Could you type tpm.msc in run command & check the status of TPM. Let me know if it says TPM ready for use.


1 Message

January 13th, 2020 18:00

Exactly the same computer and same BIOS issue. Rolled back to 1.15. I was hoping that 1.18 would fix it. I guess they want us to buy new machines. 

1 Message

January 16th, 2020 07:00

I have the same problem.

Xps 15 9550

BIOS 1.13.1

The tpm will not be found!


It's a problem for many users, I see. How can we easy fix it?

1 Message

January 28th, 2020 10:00

This is very annoying. I have a Precision that I spent almost $3k on and having the same problem. Does Dell put these BIOS update through adequate testing? Does not appear to be the case.


OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name PRECISION-001
System Manufacturer Dell Inc.
System Model Precision 5530
System Type x64-based PC
System SKU 087D
Processor Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date Dell Inc. 1.15.0, 12/25/2019
SMBIOS Version 3.1
Embedded Controller Version 255.255
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 0NFGCT
BaseBoard Version A00
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "10.0.18362.387"
User Name AzureAD\RonaldSircar
Time Zone US Mountain Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.7 GB
Available Physical Memory 6.94 GB
Total Virtual Memory 19.2 GB
Available Virtual Memory 7.92 GB
Page File Space 3.50 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

1 Message

February 3rd, 2020 08:00

I have the same issue and can't fix it myself

1 Message

February 6th, 2020 04:00

Mainboard has to be replaced.

1 Message

February 10th, 2020 05:00

Is this a fact?

2 Posts

February 11th, 2020 04:00

For me it has always been the case. I have had multiple (+10) Latitudes with TPM gone missing after a BIOS update. So far, Dell has always replaced the motherboard.

No Events found!