Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

2 Posts

80

June 9th, 2024 12:30

XPS 15 9570 - Without battery, only booting when plugged in through USB-C

I have a Dell XPS 15 9570, the battery died a few months ago and since I'm just using it at home, I'm keeping it plugged in without the battery, which works fine. I have two chargers, a regular charger and a USB-C one. I realized that it only boots when using the UBS-C charger (it does take 3 attempts 🤦‍♂️), and it doesn't work on the regular charger, the screen turns on, the fans spin up louder than normal, and it shuts down at a few seconds.

Is this related to not having a battery installed? I just ordered one, so hope that fixes it. Just wanted to know if this is normal.

To be honest I had nothing but problems with my XPS so far. Most expensive laptop I ever bought, and had the mobo replaced twice, dead battery, constant overheating, bad performance for the price /rant.

10 Elder

 • 

23.9K Posts

June 9th, 2024 12:41

No, the presence or absence of a battery will not cause that issue.  An issue with the mainboard will.

1 Rookie

 • 

2 Posts

June 9th, 2024 12:48

@ejn63​ Any idea how to debug this, find the source of the issue. And could it really be the mobo, since the USB-C works fine. It would otherwise be the third time I had to get the mainboard fixed. This time out of warranty. It's probably cheaper to buy a new laptop at this point 🤦‍♂️

(edited)

10 Elder

 • 

23.9K Posts

June 9th, 2024 13:01

About the only two things you can try are replacing the AC adapter and/or the DC jack.  Beyond that, any other issue means either a replacement mainboard (and as you note, that may not make economic sense on a 6 year old notebook) or  a replacement system.

No Events found!

Top