Sutekh
1 Nickel

IDE ATA/ATAPI controllers not showing up, unable to TRIM SSD

I am having an issue with my newly installed SSD. I just received an Alienware Aurora R4 with Windows 8. I immediately cloned the hard drive to an OCZ Vector 256GB drive using EaseUs ToDo Backup, as that worked flawlessly when I just upgraded to an SSD on my laptop. At first I had an issue with drive recognition, but then made sure bios was set to AHCI and UEFI and finally Windows 8 loaded. I reformatted the 2TB hard drive for (D:)Data and loaded all my music, video etc. Then when I went to optimize my drives, I clicked on the optimization for the SDD and it changed from needing optimization to "Optimization not available" - which it now says and is grayed out. I realized this is an issue as optimization in Win 8 on an SSD activates TRIM (works on my laptop).  Not sure if this is a concern but the (I am pretty sure the previously hidden) DIAGS partition on the original drive was given a drive letter (F:) on the SSD.

Anyway back to the not optimization/TRIM. My first response was to google 'Optimization not available' and I found this link.

http://answers.microsoft.com/en-us/windows/forum/windows_8-performance/when-i-try-to-optimize-drives...

The poster said he fixed his issue by
updating his Storage Controller drivers. "Basically I downloaded the latest Intel Rapid Storage Technology drivers for Windows 8."
I checked my storage control drivers in device manager and these are listed:

Intel(R) 600 Series chipset SATA AHCI controller
Microsoft storage spaces controller

Reading futher into the article another person with a similar problem mentioned tried using the admin command promp to activate TRIM (which i then tried and had the exact same reult/error message), with the following results:

type "defrag c: /L"

Invoking retrim on drive name (C:)...

Retrim: 100% complete.

The operation requested is not supported by the hardware backing the volume. (0x8900002A)

This indiviual then upgraded to Windows 8 and let it pick the drivers and apparently his began to work. He mentioned that his IDE ATA/ATAPI controller changed in drive manager as well. Reading this I decided to see what mine were and noticed I do not even have IDE ATA/ATAPI controller listed on my system under drive manager! Even when checking to show hidden there is not an IDE ATA/ATAPI controller listing. Should I have this?

I went to the dell driver controller to check to see if I needed any updates. It only shows me Windows 7 updates as it says that it what my Aurora R4 came with when I added my service code (is there a way to fix this?). I just chose to look at a blank Arurora R4 and was able to see the Windows 8 drivers, and downloaded all the updates that seemed relevant (also updated bios from A06 to A07). When I downloaded the listed Serial ATA driver (7D9TS) and clicked update, it just said the file was unzipped but did not install anywhere (unlike the other drivers).

So does anybody know why I do not have IDE ATA/ATAPI listed and how to get this device?

For those that have an SSD drive on their Aurora R4 with Win 8 are you able to optimize and what drivers do you have that would affect this?

What are the latest Intel Rapid Storage Technology drivers for Windows 8 and how do I know if I even have Intel Rapid storage available?

Thanks so much. Sorry the the length but I wanted to be as detailed as possible.

0 Kudos