Napper198
1 Nickel

[M17x R3] HDMI not working properly

Hi guys, I'm out of ideas and need some help.

The story:

When I first got my machine I mainly used the speaker of my home theatre (Pioneer VSX-520) wich was connected via HDMI. It worked well and I never had any problems.

Later on I got myself a Logitech Lapdesk N700 so I used that as my primary speaker and I stopped using my home theatre as speaker only (I still use them when I'm watching videos on my TV of course).

A while ago I left my Lapdesk in the other room an for convenience I just grabbed a HDMI cable and tried to play some music on my Pioneer.

Windows detected hardware, played the sound und the music went silent, but it stayed silent. A quick look in Sound told me, that the device was detected correctly and the audio was going to it, but my AV-Reciever kept awaiting a stream. Wondering what was wrong I turned on my TV (Panasonic TX-P42GW20) and it worked! My music was playing over the AV-Reciever. Strange, I thought and turned off the TV. Again there was no sound, after Windows switched from HDMI to Internal to HDMI again. Again, Windows put through the sound to my Pioneer wich was again awaiting a stream.

The search for the error:

First I fired up my old Desktop (didn't done that in a while... and now I remember why) and checked if that worked. Windows 7 Ultimate 64bit, Nvidia GTX470 with driver 280.26. Works fine. After all updates it still works.

While I done all updates for my desktop, I wrote down the sound-settings and configured my Alienware the same way. No change.

Maybe it's the driver? 285.62 was already installed so I gave 290.26 Beta a try. Still no change.

Maybe I need the Dell Driver? So I gone for it and while I was at it I also got the new A09 BIOS and the chipset-driver from Inter, just to be sure. Well, I can't setup 3D anymore and HDCP for the internal display has gone (thought BDs still work), but after I turn my TV on and off it works.

Since no 3D is no option I gone back to Nvidia 285.62 (HDCP for internal still gone, but BDs still working). While switching the drivers I remembered that Windows is providing it's own driver for HDMI Audio so i tried that one. It detected even more modes for my AV-Reciever, but still not working.

I also wanted to try the old Nvidia 280.26 (wich should work, because it did before) but it aborts because it can't find any compatible hardware.

The cable is okay.

Also HDMI in doesen't work anymore. It connects and switches to it. The display shows a picture for about a half second, then it's turning completely black. Audio works fine, the cable is good and I tried different devices.

I'm pretty sure vbios 70.24.2B.00.06 is responsible for that, but what now? Any ideas?

Thanks in anticipation.

M17xR3 A09 - i7 2630QM - Kingston HyperX XMP 8GB @1600MHz - nVidia GTX580M v295.73 - 1920x1080 120Hz 3D -  Samsung SSD 830 256GB + Seagate Momentus 750GB 7200 1/min - Blu-Ray ODD - Killer Wireless-N 1103 - Windows 7 Home Premium 64bit

0 Kudos